summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-12 21:55:50 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-12 21:55:50 +0000
commit319cd82d788089112122d73c31328616deddc773 (patch)
treeab2ac1bf702917e43c221555382604cbb9199967 /gnome-base
parentRemove mask of poppler-0.9.x testing versions. 0.10.0 is in tree. (diff)
downloadgentoo-2-319cd82d788089112122d73c31328616deddc773.tar.gz
gentoo-2-319cd82d788089112122d73c31328616deddc773.tar.bz2
gentoo-2-319cd82d788089112122d73c31328616deddc773.zip
New version for GNOME 2.24. Now counts in power of 10. Various fixes to backends, gphoto2 and hal are out of process, better cross backen copy/move logic (uses system move if possible). Fix opening of dm-crypt volumes.
(Portage version: 2.2_rc12/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64, RepoMan options: --force)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gvfs/ChangeLog10
-rw-r--r--gnome-base/gvfs/gvfs-1.0.1.ebuild76
-rw-r--r--gnome-base/gvfs/metadata.xml2
3 files changed, 87 insertions, 1 deletions
diff --git a/gnome-base/gvfs/ChangeLog b/gnome-base/gvfs/ChangeLog
index f1e8ebd32450..d3e9668df235 100644
--- a/gnome-base/gvfs/ChangeLog
+++ b/gnome-base/gvfs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/gvfs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.27 2008/09/25 14:18:19 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.28 2008/10/12 21:55:50 eva Exp $
+
+*gvfs-1.0.1 (12 Oct 2008)
+
+ 12 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org> +gvfs-1.0.1.ebuild:
+ New version for GNOME 2.24. Now counts in power of 10. Various fixes to
+ backends, gphoto2 and hal are out of process, better cross backend
+ copy/move logic (uses system move if possible). Fix opening of dm-crypt
+ volumes.
25 Sep 2008; Jeroen Roovers <jer@gentoo.org> gvfs-0.2.5.ebuild:
Stable for HPPA (bug #236971).
diff --git a/gnome-base/gvfs/gvfs-1.0.1.ebuild b/gnome-base/gvfs/gvfs-1.0.1.ebuild
new file mode 100644
index 000000000000..b4e7f008d303
--- /dev/null
+++ b/gnome-base/gvfs/gvfs-1.0.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.0.1.ebuild,v 1.1 2008/10/12 21:55:50 eva Exp $
+
+inherit bash-completion gnome2 eutils
+
+DESCRIPTION="GNOME Virtual Filesystem Layer"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="archive avahi bluetooth cdda doc fuse gnome gphoto2 hal gnome-keyring samba"
+
+RDEPEND=">=dev-libs/glib-2.17.6
+ >=sys-apps/dbus-1.0
+ >=net-libs/libsoup-2.23.91
+ dev-libs/libxml2
+ net-misc/openssh
+ archive? ( app-arch/libarchive )
+ avahi? ( >=net-dns/avahi-0.6 )
+ cdda? (
+ >=sys-apps/hal-0.5.10
+ >=dev-libs/libcdio-0.78.2
+ )
+ fuse? ( sys-fs/fuse )
+ gnome? ( >=gnome-base/gconf-2.0 )
+ hal? ( >=sys-apps/hal-0.5.10 )
+ bluetooth? (
+ dev-libs/dbus-glib
+ >=net-wireless/bluez-libs-3.12
+ dev-libs/expat
+ )
+ gphoto2? ( >=media-libs/libgphoto2-2.4 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-1.0 )
+ samba? ( >=net-fs/samba-3 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.19
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-http
+ --disable-bash-completion
+ $(use_enable archive)
+ $(use_enable avahi)
+ $(use_enable bluetooth obexftp)
+ $(use_enable cdda)
+ $(use_enable fuse)
+ $(use_enable gnome gconf)
+ $(use_enable gphoto2)
+ $(use_enable hal)
+ $(use_enable gnome-keyring keyring)
+ $(use_enable samba)"
+
+ if use cdda && built_with_use dev-libs/libcdio minimal; then
+ ewarn
+ ewarn "CDDA support in gvfs requires dev-libs/libcdio to be built"
+ ewarn "without the minimal USE flag."
+ die "Please re-emerge dev-libs/libcdio without the minimal USE flag"
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+ use bash-completion && \
+ dobashcompletion programs/gvfs-bash-completion.sh ${PN}
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use bash-completion && bash-completion_pkg_postinst
+}
diff --git a/gnome-base/gvfs/metadata.xml b/gnome-base/gvfs/metadata.xml
index 32609a8c31a6..0aad4984cb7b 100644
--- a/gnome-base/gvfs/metadata.xml
+++ b/gnome-base/gvfs/metadata.xml
@@ -10,6 +10,8 @@ using the APIs of libgio. There is also fuse support that allows
applications not using gio to access the gvfs filesystems.
</longdescription>
<use>
+ <flag name='archive'>Enables support for accessing files in archives
+ transparently via <pkg>app-arch/libarchive</pkg></flag>
<flag name='cdda'>Enables Compact Disc Digital Audio (standard audio CDs)
support</flag>
<flag name='fuse'>Enables fuse mount points in $HOME/.gvfs for legacy