summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-03-22 11:10:33 +0000
committerPacho Ramos <pacho@gentoo.org>2015-03-22 11:10:33 +0000
commit47971437a2fa5b471724c8b20d6e95e636308367 (patch)
tree29377e867e0abda14bc9c90c452f3f1c74b90093 /gnome-base
parentx86 stable, see bug 509544 (diff)
downloadgentoo-2-47971437a2fa5b471724c8b20d6e95e636308367.tar.gz
gentoo-2-47971437a2fa5b471724c8b20d6e95e636308367.tar.bz2
gentoo-2-47971437a2fa5b471724c8b20d6e95e636308367.zip
Fix parallel installation (#543812 by tman, Aaron U'Ren and many others)
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gvfs/ChangeLog6
-rw-r--r--gnome-base/gvfs/files/gvfs-1.22.4-fix-parallel.patch25
-rw-r--r--gnome-base/gvfs/gvfs-1.22.4.ebuild9
3 files changed, 37 insertions, 3 deletions
diff --git a/gnome-base/gvfs/ChangeLog b/gnome-base/gvfs/ChangeLog
index 3a8d9694d776..3a5353087749 100644
--- a/gnome-base/gvfs/ChangeLog
+++ b/gnome-base/gvfs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-base/gvfs
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.287 2015/03/19 11:42:40 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.288 2015/03/22 11:10:33 pacho Exp $
+
+ 22 Mar 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/gvfs-1.22.4-fix-parallel.patch, gvfs-1.22.4.ebuild:
+ Fix parallel installation (#543812 by tman, Aaron U'Ren and many others)
*gvfs-1.22.4 (19 Mar 2015)
diff --git a/gnome-base/gvfs/files/gvfs-1.22.4-fix-parallel.patch b/gnome-base/gvfs/files/gvfs-1.22.4-fix-parallel.patch
new file mode 100644
index 000000000000..9e2ed6612200
--- /dev/null
+++ b/gnome-base/gvfs/files/gvfs-1.22.4-fix-parallel.patch
@@ -0,0 +1,25 @@
+From 62c4c2af399dba0566ae69353f127472fa3e3364 Mon Sep 17 00:00:00 2001
+From: Ross Lagerwall <rosslagerwall@gmail.com>
+Date: Mon, 16 Mar 2015 00:06:07 +0000
+Subject: completion: Fix parallel installation
+
+Use install-data-hook rather than install-data-local as
+install-data-hook runs after the other install rules have run. This is
+important for a parallel install so that the destination directory
+already exists when the symlinks are created.
+
+diff --git a/programs/completion/Makefile.am b/programs/completion/Makefile.am
+index 06833e5..971e4ee 100644
+--- a/programs/completion/Makefile.am
++++ b/programs/completion/Makefile.am
+@@ -35,6 +35,6 @@ uninstall-symlinks:
+ rm -f $(DESTDIR)$(BASHCOMP_DIR)/$$file; \
+ done
+
+-install-data-local: install-symlinks
++install-data-hook: install-symlinks
+
+ uninstall-local: uninstall-symlinks
+--
+cgit v0.10.2
+
diff --git a/gnome-base/gvfs/gvfs-1.22.4.ebuild b/gnome-base/gvfs/gvfs-1.22.4.ebuild
index da552664794d..119b56dc3792 100644
--- a/gnome-base/gvfs/gvfs-1.22.4.ebuild
+++ b/gnome-base/gvfs/gvfs-1.22.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.22.4.ebuild,v 1.1 2015/03/19 11:42:40 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.22.4.ebuild,v 1.2 2015/03/22 11:10:33 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -81,9 +81,14 @@ src_prepare() {
-e 's/burn.mount/ /' \
-i daemon/Makefile.am || die
- eautoreconf
+ # Uncomment when eautoreconf stops being needed always
+ #eautoreconf
fi
+ # Fix parallel installation, bug #543812 (from 'master')
+ epatch "${FILESDIR}/${PN}-1.22.4-fix-parallel.patch"
+
+ eautoreconf
gnome2_src_prepare
}