summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-04-12 23:07:24 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-04-12 23:07:24 +0000
commitd8d15a2bb3dcde2ca4367ee26098c55e45ba9963 (patch)
treed9a5430aabd42ad40ca3f7b732780b40b202ddd7 /gnome-base
parentBump to 1.0.2-r3. Install default XDG_DATA_DIRS, bug #264647. Add xset to RDE... (diff)
downloadgentoo-2-d8d15a2bb3dcde2ca4367ee26098c55e45ba9963.tar.gz
gentoo-2-d8d15a2bb3dcde2ca4367ee26098c55e45ba9963.tar.bz2
gentoo-2-d8d15a2bb3dcde2ca4367ee26098c55e45ba9963.zip
Bump to 2.20.10.
* Split out Xsession patches, partly solves bug #220603. * Set env.d and depend on proper xdg-utils, bug #264647. (Portage version: 2.2_rc28/cvs/Linux i686)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gdm/ChangeLog11
-rw-r--r--gnome-base/gdm/files/49-keychain9
-rw-r--r--gnome-base/gdm/files/50-ssh-agent10
-rw-r--r--gnome-base/gdm/files/gdm-2.20.10-custom-session.patch42
-rw-r--r--gnome-base/gdm/files/gdm-2.20.10-xinitrc-ssh-agent.patch26
-rw-r--r--gnome-base/gdm/gdm-2.20.10.ebuild241
6 files changed, 338 insertions, 1 deletions
diff --git a/gnome-base/gdm/ChangeLog b/gnome-base/gdm/ChangeLog
index 10acc975c13a..3838d2dc4b53 100644
--- a/gnome-base/gdm/ChangeLog
+++ b/gnome-base/gdm/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-base/gdm
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdm/ChangeLog,v 1.291 2009/03/21 02:29:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdm/ChangeLog,v 1.292 2009/04/12 23:07:23 eva Exp $
+
+*gdm-2.20.10 (12 Apr 2009)
+
+ 12 Apr 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gdm-2.20.10-xinitrc-ssh-agent.patch, +files/49-keychain,
+ +files/50-ssh-agent, +files/gdm-2.20.10-custom-session.patch,
+ +gdm-2.20.10.ebuild:
+ Bump to 2.20.10. Split out Xsession patches, partly solves bug #220603.
+ Set env.d and depend on proper xdg-utils, bug #264647.
21 Mar 2009; Jeroen Roovers <jer@gentoo.org> gdm-2.20.9-r1.ebuild:
Stable for HPPA (bug #244468).
diff --git a/gnome-base/gdm/files/49-keychain b/gnome-base/gdm/files/49-keychain
new file mode 100644
index 000000000000..bafc962f1b2a
--- /dev/null
+++ b/gnome-base/gdm/files/49-keychain
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+# source keychain variables
+
+keychain="`which keychain`"
+if [ -n "$keychain" ] && [ -x "$keychain" ] && [ -f "$HOME/.bash_profile" ]
+then
+ . "${HOME}/.bash_profile"
+fi
diff --git a/gnome-base/gdm/files/50-ssh-agent b/gnome-base/gdm/files/50-ssh-agent
new file mode 100644
index 000000000000..6bbdc47d84eb
--- /dev/null
+++ b/gnome-base/gdm/files/50-ssh-agent
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+# add ssh-agent if found
+
+sshagent="`gdmwhich ssh-agent`"
+if [ -n "$sshagent" ] && [ -x "$sshagent" ] && [ -z "$SSH_AUTH_SOCK" ]; then
+ command="$sshagent -- $command"
+elif [ -z "$sshagent" ] ; then
+ echo "$0: ssh-agent not found!"
+fi
diff --git a/gnome-base/gdm/files/gdm-2.20.10-custom-session.patch b/gnome-base/gdm/files/gdm-2.20.10-custom-session.patch
new file mode 100644
index 000000000000..b1f70c00cb54
--- /dev/null
+++ b/gnome-base/gdm/files/gdm-2.20.10-custom-session.patch
@@ -0,0 +1,42 @@
+---
+ fix custom sessions (see bug #216984, work done by Gilles, I'm just committing)
+
+ config/Xsession.in | 18 +++++++++---------
+ 1 file changed, 9 insertions(+), 9 deletions(-)
+
+Index: b/config/Xsession.in
+===================================================================
+--- a/config/Xsession.in
++++ b/config/Xsession.in
+@@ -177,15 +177,6 @@ if [ -n "$GDM_LANG" ]; then
+ fi
+ fi
+
+-# run all system xinitrc shell scripts.
+-if [ -d /etc/X11/xinit/xinitrc.d ]; then
+- for i in /etc/X11/xinit/xinitrc.d/* ; do
+- if [ -x "$i" ]; then
+- . "$i"
+- fi
+- done
+-fi
+-
+ if [ "x$command" = "xcustom" ] ; then
+ if [ -x "$HOME/.xsession" ]; then
+ command="$HOME/.xsession"
+@@ -213,6 +204,15 @@ if [ "x$command" = "xdefault" ] ; then
+ fi
+ fi
+
++# run all system xinitrc shell scripts.
++if [ -d /etc/X11/xinit/xinitrc.d ]; then
++ for i in /etc/X11/xinit/xinitrc.d/* ; do
++ if [ -x "$i" ]; then
++ . "$i"
++ fi
++ done
++fi
++
+ # add ssh-agent if found
+ sshagent="`gdmwhich ssh-agent`"
+ if [ -n "$sshagent" ] && [ -x "$sshagent" ] && [ -z "$SSH_AUTH_SOCK" ]; then
diff --git a/gnome-base/gdm/files/gdm-2.20.10-xinitrc-ssh-agent.patch b/gnome-base/gdm/files/gdm-2.20.10-xinitrc-ssh-agent.patch
new file mode 100644
index 000000000000..8d20d1c1c671
--- /dev/null
+++ b/gnome-base/gdm/files/gdm-2.20.10-xinitrc-ssh-agent.patch
@@ -0,0 +1,26 @@
+---
+ ssh-agent really needs to be handled by xinitrc like other agents.
+ Gentoo bug: 220603
+
+ config/Xsession.in | 8 --------
+ 1 file changed, 8 deletions(-)
+
+Index: b/config/Xsession.in
+===================================================================
+--- a/config/Xsession.in
++++ b/config/Xsession.in
+@@ -213,14 +213,6 @@ if [ -d /etc/X11/xinit/xinitrc.d ]; then
+ done
+ fi
+
+-# add ssh-agent if found
+-sshagent="`gdmwhich ssh-agent`"
+-if [ -n "$sshagent" ] && [ -x "$sshagent" ] && [ -z "$SSH_AUTH_SOCK" ]; then
+- command="$sshagent -- $command"
+-elif [ -z "$sshagent" ] ; then
+- echo "$0: ssh-agent not found!"
+-fi
+-
+ echo "$0: Setup done, will execute: $command"
+
+ eval exec $command
diff --git a/gnome-base/gdm/gdm-2.20.10.ebuild b/gnome-base/gdm/gdm-2.20.10.ebuild
new file mode 100644
index 000000000000..18de4a3f88d6
--- /dev/null
+++ b/gnome-base/gdm/gdm-2.20.10.ebuild
@@ -0,0 +1,241 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdm/gdm-2.20.10.ebuild,v 1.1 2009/04/12 23:07:23 eva Exp $
+
+inherit eutils pam gnome2
+
+DESCRIPTION="GNOME Display Manager"
+HOMEPAGE="http://www.gnome.org/projects/gdm/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+IUSE_LIBC="elibc_glibc"
+IUSE="accessibility afs branding dmx ipv6 gnome-keyring pam remote selinux tcpd xinerama $IUSE_LIBC"
+
+# Name of the tarball with gentoo specific files
+GDM_EXTRA="${PN}-2.20.9-gentoo-files-r1"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${GDM_EXTRA}.tar.bz2
+ branding? ( mirror://gentoo/gentoo-gdm-theme-r3.tar.bz2 )"
+
+RDEPEND="dev-libs/dbus-glib
+ >=dev-libs/glib-2.12
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.3
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomecanvas-2
+ >=gnome-base/librsvg-1.1.1
+ >=dev-libs/libxml2-2.4.12
+ >=media-libs/libart_lgpl-2.3.11
+ x11-libs/gksu
+ x11-libs/libXi
+ x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-apps/sessreg
+ x11-libs/libXdmcp
+ xinerama? ( x11-libs/libXinerama )
+ sys-auth/consolekit
+ accessibility? ( x11-libs/libXevie )
+ afs? ( net-fs/openafs sys-libs/lwp )
+ dmx? ( x11-libs/libdmx )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.22 )
+ pam? (
+ virtual/pam
+ >=sys-auth/pambase-20080318 )
+ !pam? ( elibc_glibc? ( sys-apps/shadow ) )
+ remote? ( gnome-extra/zenity )
+ selinux? ( sys-libs/libselinux )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ >=x11-misc/xdg-utils-1.0.2-r3"
+DEPEND="${RDEPEND}
+ dmx? ( x11-proto/dmxproto )
+ xinerama? ( x11-proto/xineramaproto )
+ sys-devel/gettext
+ x11-proto/inputproto
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19
+ >=app-text/scrollkeeper-0.1.4
+ >=app-text/gnome-doc-utils-0.3.2"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-prefetch
+ --sysconfdir=/etc/X11
+ --localstatedir=/var
+ --with-xdmcp=yes
+ --with-pam-prefix=/etc
+ --with-console-kit=yes
+ SOUND_PROGRAM=/usr/bin/gdmplay
+ $(use_enable accessibility xevie)
+ $(use_enable ipv6)
+ $(use_enable remote secureremote)
+ $(use_with selinux)
+ $(use_with tcpd tcp-wrappers)
+ $(use_with xinerama)"
+
+ if use dmx ; then
+ G2CONF="${G2CONF} --with-dmx=yes"
+ else
+ G2CONF="${G2CONF} --with-dmx=no"
+ fi
+
+ if use gnome-keyring && ! built_with_use gnome-base/gnome-keyring pam; then
+ eerror "You need to build gnome-base/gnome-keyring with USE=\"pam\""
+ eerror "for USE=\"gnome-keyring\" to have any effect on this package."
+ fi
+
+ if use pam; then
+ G2CONF="${G2CONF} --enable-authentication-scheme=pam"
+
+ if use gnome-keyring && ! built_with_use sys-auth/pambase gnome-keyring; then
+ eerror "You need USE=\"gnome\" in sys-auth/pambase for proper keyring"
+ eerror "unlocking at login time. It will not work properly otherwise."
+ fi
+ else
+ G2CONF="${G2CONF} --enable-console-helper=no"
+ if use elibc_glibc ; then
+ G2CONF="${G2CONF} --enable-authentication-scheme=shadow"
+ else
+ G2CONF="${G2CONF} --enable-authentication-scheme=crypt"
+ fi
+ fi
+
+ enewgroup gdm
+ enewuser gdm -1 -1 /var/lib/gdm gdm
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # remove unneeded linker directive for selinux (#41022)
+ epatch "${FILESDIR}/${PN}-2.13.0.1-selinux-remove-attr.patch"
+
+ # Add gksu to gdmsetup menu entry
+ epatch "${FILESDIR}/${PN}-2.20.2-gksu.patch"
+
+ # Fix parallel install, bug #217037
+ epatch "${FILESDIR}/${PN}-2.20.9-parallel-make.patch"
+
+ # Make custom session work, bug #.
+ epatch "${FILESDIR}/${PN}-2.20.10-custom-session.patch"
+
+ # ssh-agent handling must be done at xinitrc.d
+ epatch "${FILESDIR}/${PN}-2.20.10-xinitrc-ssh-agent.patch"
+}
+
+src_install() {
+ gnome2_src_install
+
+ local gentoodir="${WORKDIR}/${GDM_EXTRA}"
+
+ # gdm-binary should be gdm to work with our init (#5598)
+ rm -f "${D}/usr/sbin/gdm"
+ dosym /usr/sbin/gdm-binary /usr/sbin/gdm
+
+ # our x11's scripts point to /usr/bin/gdm
+ dosym /usr/sbin/gdm-binary /usr/bin/gdm
+
+ # log, etc.
+ keepdir /var/log/gdm
+ keepdir /var/gdm
+
+ fowners root:gdm /var/gdm
+ fperms 1770 /var/gdm
+
+ # add a custom xsession .desktop by default (#44537)
+ exeinto /etc/X11/dm/Sessions
+ doexe "${gentoodir}/custom.desktop"
+
+ # add xinitrc.d scripts
+ exeinto /etc/X11/xinit/xinitrc.d
+ doexe "${FILESDIR}/49-keychain"
+ doexe "${FILESDIR}/50-ssh-agent"
+
+ # install XDG_DATA_DIRS gdm changes
+ echo 'XDG_DATA_DIRS="/usr/share/gdm"' > 99xdg-gdm
+ doenvd 99xdg-gdm || die "doenvd failed"
+
+ # add a custom sound playing script (#248253)
+ dobin "${gentoodir}/gdmplay"
+
+ # avoid file collision, bug #213118
+ rm -f "${D}/usr/share/xsessions/gnome.desktop"
+
+ # We replace the pam stuff by our own
+ rm -rf "${D}/etc/pam.d"
+
+ if use pam ; then
+ use gnome-keyring && sed -i "s:#Keyring=::g" "${gentoodir}"/pam.d/*
+
+ dopamd "${gentoodir}"/pam.d/*
+ dopamsecurity console.apps "${gentoodir}/security/console.apps/gdmsetup"
+ fi
+
+ # use graphical greeter local
+ dosed "s:#Greeter=/usr/libexec/gdmlogin:Greeter=/usr/libexec/gdmgreeter:" \
+ /usr/share/gdm/defaults.conf
+
+ # list available users
+ dosed "s:^#MinimalUID=.*:MinimalUID=1000:" /usr/share/gdm/defaults.conf
+ dosed "s:^#IncludeAll=.*:IncludeAll=true:" /usr/share/gdm/defaults.conf
+
+ # Fix old X11R6 paths
+ dosed "s:/usr/X11R6/bin:/usr/bin:" /usr/share/gdm/defaults.conf
+
+ # Move Gentoo theme in
+ if use branding ; then
+ mv "${WORKDIR}"/gentoo-* "${D}/usr/share/gdm/themes"
+ fi
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "To make GDM start at boot, edit /etc/conf.d/xdm"
+ elog "and then execute 'rc-update add xdm default'."
+
+ elog "GDM has changed the location of its configuration file. Please"
+ elog "edit /etc/X11/gdm/custom.conf. The factory defaults are located"
+ elog "at /usr/share/gdm/{defaults.conf,factory-defaults.conf}"
+
+ elog "See README.install for more information about the change."
+
+ if use gnome-keyring; then
+ elog "For autologin to unlock your keyring, you need to set an empty"
+ elog "password on your keyring. Use app-crypt/seahorse for that."
+ fi
+
+ if [ -f "/etc/X11/gdm/gdm.conf" ]; then
+ elog "You had /etc/X11/gdm/gdm.conf which is the old configuration"
+ elog "file. It has been moved to /etc/X11/gdm/gdm-pre-gnome-2.16"
+ mv /etc/X11/gdm/gdm.conf /etc/X11/gdm/gdm-pre-gnome-2.16
+ fi
+
+ # Soft restart, assumes Gentoo defaults for file locations
+ # Do restart after gdm.conf move above
+ FIFOFILE=/var/gdm/.gdmfifo
+ PIDFILE=/var/run/gdm.pid
+
+ if [ -w ${FIFOFILE} ] ; then
+ if [ -f ${PIDFILE} ] ; then
+ if kill -0 `cat ${PIDFILE}`; then
+ (echo;echo SOFT_RESTART) >> ${FIFOFILE}
+ fi
+ fi
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ if [[ "$(rc-config list default | grep xdm)" != "" ]] ; then
+ elog "To remove GDM from startup please execute"
+ elog "'rc-update del xdm default'"
+ fi
+}