summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2014-03-17 23:44:49 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2014-03-17 23:44:49 +0000
commitf8d639d292a9f39d03d5f1f33a1b1721829aa4f4 (patch)
tree2a49cc2ddf1243d11710cc6e76e19658fca32ae4 /gnome-base
parentversion bump (diff)
downloadgentoo-2-f8d639d292a9f39d03d5f1f33a1b1721829aa4f4.tar.gz
gentoo-2-f8d639d292a9f39d03d5f1f33a1b1721829aa4f4.tar.bz2
gentoo-2-f8d639d292a9f39d03d5f1f33a1b1721829aa4f4.zip
Fix patch to work with both freetype-2.4.11 and >=2.5.1 (bug #504850, thanks to Fabio Rossi).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libgnomeprint/ChangeLog7
-rw-r--r--gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-freetype-2.5.1.patch48
-rw-r--r--gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild5
3 files changed, 50 insertions, 10 deletions
diff --git a/gnome-base/libgnomeprint/ChangeLog b/gnome-base/libgnomeprint/ChangeLog
index 28b3a3f38f0e..9492bf3f13e1 100644
--- a/gnome-base/libgnomeprint/ChangeLog
+++ b/gnome-base/libgnomeprint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/libgnomeprint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.195 2014/03/17 04:05:13 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.196 2014/03/17 23:44:49 tetromino Exp $
+
+ 17 Mar 2014; Alexandre Rostovtsev <tetromino@gentoo.org>
+ libgnomeprint-2.18.8.ebuild, files/libgnomeprint-2.18.8-freetype-2.5.1.patch:
+ Fix patch to work with both freetype-2.4.11 and >=2.5.1 (bug #504850, thanks
+ to Fabio Rossi).
17 Mar 2014; Alexandre Rostovtsev <tetromino@gentoo.org>
libgnomeprint-2.18.8.ebuild,
diff --git a/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-freetype-2.5.1.patch b/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-freetype-2.5.1.patch
index c21e92177c5f..c0cb5957fae8 100644
--- a/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-freetype-2.5.1.patch
+++ b/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-freetype-2.5.1.patch
@@ -1,14 +1,48 @@
-From 9ed3ddc0cefd9aec123eeee3ce494289bf080495 Mon Sep 17 00:00:00 2001
+From cf17a44bd5b8aac1c73f3bb00ca872cd8f08df4a Mon Sep 17 00:00:00 2001
From: Alexandre Rostovtsev <tetromino@gentoo.org>
Date: Mon, 17 Mar 2014 00:01:10 -0400
Subject: [PATCH] Update freetype includes to work with >=freetype-2.5.1
---
- libgnomeprint/gnome-font-face.c | 2 +-
- libgnomeprint/gnome-print-gdi.c | 2 +-
- libgnomeprint/gnome-rfont.c | 4 ++--
- 3 files changed, 4 insertions(+), 4 deletions(-)
+ configure.in | 22 +++-------------------
+ libgnomeprint/gnome-font-face.c | 2 +-
+ libgnomeprint/gnome-print-gdi.c | 2 +-
+ libgnomeprint/gnome-rfont.c | 4 ++--
+ 4 files changed, 7 insertions(+), 23 deletions(-)
+diff --git a/configure.in b/configure.in
+index c15bb69..aebe591 100644
+--- a/configure.in
++++ b/configure.in
+@@ -162,25 +162,9 @@ LDFLAGS="$LDFLAGS $LIBM"
+ dnl =================================
+ dnl Checking for freetype2
+ dnl =================================
+-FREETYPE_LIBS=
+-FREETYPE_CFLAGS=
+-AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
+-if test "x$FREETYPE_CONFIG" = "xno" ; then
+- AC_MSG_ERROR(You need FreeType2 (freetype-devel v 2.x package) for this version of libgnomeprint)
+-else
+- FREETYPE_CFLAGS=`$FREETYPE_CONFIG --cflags`
+- FREETYPE_LIBS=`$FREETYPE_CONFIG --libs`
+-fi
+-
+-libgnomeprint_save_ldflags=$LDFLAGS
+-LDFLAGS="$LDFLAGS $FREETYPE_LIBS"
+-
+-freetype_version=false
+-AC_MSG_NOTICE([checking for sufficiently new FreeType (at least 2.0.5)])
+-AC_CHECK_LIB(freetype, FT_Get_Postscript_Name,:,[
+- AC_MSG_ERROR(You need FreeType2 (freetype-devel 2.0.5 or greater package) for this version of libgnomeprint)])
+-
+-LDFLAGS=$libgnomeprint_save_ldflags
++dnl "freetype2 >= 17" means freetype-2.5.1
++PKG_CHECK_MODULES(FREETYPE, freetype2 >= 17, ,
++ [PKG_CHECK_MODULES(FREETYPE, freetype2, [FREETYPE_CFLAGS="$FREETYPE_CFLAGS -I`$PKG_CONFIG --variable=includedir freetype2`/freetype2/freetype"])])
+
+ dnl =================================
+ dnl END: Checking for freetype2
diff --git a/libgnomeprint/gnome-font-face.c b/libgnomeprint/gnome-font-face.c
index 0447377..f9f8f3e 100644
--- a/libgnomeprint/gnome-font-face.c
@@ -23,7 +57,7 @@ index 0447377..f9f8f3e 100644
#include <libgnomeprint/gnome-print-private.h>
#include <libgnomeprint/gnome-font-private.h>
diff --git a/libgnomeprint/gnome-print-gdi.c b/libgnomeprint/gnome-print-gdi.c
-index f89a8e8..d30672b 100755
+index f89a8e8..7755673 100755
--- a/libgnomeprint/gnome-print-gdi.c
+++ b/libgnomeprint/gnome-print-gdi.c
@@ -36,7 +36,7 @@
@@ -31,7 +65,7 @@ index f89a8e8..d30672b 100755
#include <ft2build.h>
-#include <freetype/freetype.h>
-+#include <freetype.h>
++#include FT_FREETYPE_H
#define WIN32_LEAN_AND_MEAN
#include <windows.h>
diff --git a/gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild b/gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild
index 118929720c8d..f60dcb57034e 100644
--- a/gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild
+++ b/gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild,v 1.12 2014/03/17 04:05:13 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild,v 1.13 2014/03/17 23:44:49 tetromino Exp $
EAPI="3"
GCONF_DEBUG="no"
-inherit eutils gnome2
+inherit autotools eutils gnome2
DESCRIPTION="Printer handling for Gnome"
HOMEPAGE="http://www.gnome.org/"
@@ -46,6 +46,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${P}-stdio-include.patch
epatch "${FILESDIR}"/${P}-freetype-2.5.1.patch
+ eautoreconf
gnome2_src_prepare
# Drop DEPRECATED flags, bug #384807