summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-09-25 18:49:20 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-09-25 18:49:20 +0000
commitf8edfc03bb6def96b99d34ab1501f305d62e30a3 (patch)
tree6aaf6ced37dfe5c86a3365d6f8b78c60a75d486d /gnome-extra/at-spi
parentNew series for Gnome 2.20 (diff)
downloadgentoo-2-f8edfc03bb6def96b99d34ab1501f305d62e30a3.tar.gz
gentoo-2-f8edfc03bb6def96b99d34ab1501f305d62e30a3.tar.bz2
gentoo-2-f8edfc03bb6def96b99d34ab1501f305d62e30a3.zip
New series for Gnome 2.20
(Portage version: 2.1.3.9)
Diffstat (limited to 'gnome-extra/at-spi')
-rw-r--r--gnome-extra/at-spi/ChangeLog5
-rw-r--r--gnome-extra/at-spi/at-spi-1.20.0.ebuild54
-rw-r--r--gnome-extra/at-spi/files/at-spi-1.19.3-tests.patch80
-rw-r--r--gnome-extra/at-spi/files/digest-at-spi-1.20.03
4 files changed, 141 insertions, 1 deletions
diff --git a/gnome-extra/at-spi/ChangeLog b/gnome-extra/at-spi/ChangeLog
index b59de29481fc..fe557870df54 100644
--- a/gnome-extra/at-spi/ChangeLog
+++ b/gnome-extra/at-spi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for gnome-extra/at-spi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.154 2007/09/22 09:34:27 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.155 2007/09/25 18:49:20 dang Exp $
+
+ 25 Sep 2007; Daniel Gryniewicz <dang@gentoo.org> ChangeLog:
+ New series for Gnome 2.20
22 Sep 2007; Tom Gall <tgall@gentoo.org>
at-spi-1.18.1-r1.ebuild:
diff --git a/gnome-extra/at-spi/at-spi-1.20.0.ebuild b/gnome-extra/at-spi/at-spi-1.20.0.ebuild
new file mode 100644
index 000000000000..2e61f7b519bf
--- /dev/null
+++ b/gnome-extra/at-spi/at-spi-1.20.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.20.0.ebuild,v 1.1 2007/09/25 18:49:20 dang Exp $
+
+WANT_AUTOMAKE="1.9"
+
+inherit virtualx autotools eutils gnome2
+
+DESCRIPTION="The Gnome Accessibility Toolkit"
+HOMEPAGE="http://developer.gnome.org/projects/gap/"
+
+LICENSE="LGPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/atk-1.17
+ >=x11-libs/gtk+-2.10.0
+ >=gnome-base/gail-1.9.0
+ >=gnome-base/libbonobo-1.107
+ >=gnome-base/orbit-2
+ dev-libs/popt
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1 )
+
+ x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ #
+ epatch "${FILESDIR}"/${PN}-1.19.3-tests.patch
+
+ cp aclocal.m4 old_macros.m4
+ AT_M4DIR="." eautoreconf
+}
+
+src_test() {
+ Xmake check || die "Testing phase failed"
+}
diff --git a/gnome-extra/at-spi/files/at-spi-1.19.3-tests.patch b/gnome-extra/at-spi/files/at-spi-1.19.3-tests.patch
new file mode 100644
index 000000000000..4840284f01e7
--- /dev/null
+++ b/gnome-extra/at-spi/files/at-spi-1.19.3-tests.patch
@@ -0,0 +1,80 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN at-spi-1.19.3.orig/atk-bridge/bridge.c at-spi-1.19.3/atk-bridge/bridge.c
+--- at-spi-1.19.3.orig/atk-bridge/bridge.c 2007-04-28 02:56:51.000000000 -0400
++++ at-spi-1.19.3/atk-bridge/bridge.c 2007-06-04 13:29:46.000000000 -0400
+@@ -435,10 +435,23 @@ spi_atk_bridge_get_registry (void)
+
+ if (ev._major != CORBA_NO_EXCEPTION)
+ {
++ gchar *err_desc = NULL;
++ const CORBA_char *id = CORBA_exception_id (&ev);
++
++ if (strcmp(id, "IDL:Bonobo/GeneralError:1.0") == 0)
++ {
++ Bonobo_GeneralError* ge = CORBA_exception_value (&ev);
++ err_desc = g_strdup_printf ("bonobo activation problem: %s",
++ ge->description);
++ }
++
+ g_error ("Accessibility app error: exception during "
+- "registry activation from id: %s\n",
+- CORBA_exception_id (&ev));
++ "registry activation from id: %s\n"
++ "Error description: %s\n", id, err_desc == NULL ? "-" : err_desc);
++
+ CORBA_exception_free (&ev);
++ if (err_desc != NULL)
++ g_free (err_desc);
+ }
+
+ if (registry_died && registry)
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN at-spi-1.19.3.orig/test/Makefile.am at-spi-1.19.3/test/Makefile.am
+--- at-spi-1.19.3.orig/test/Makefile.am 2007-05-22 05:40:43.000000000 -0400
++++ at-spi-1.19.3/test/Makefile.am 2007-06-04 13:31:11.000000000 -0400
+@@ -37,11 +37,18 @@ INCLUDES = -I$(top_srcdir) \
+ $(TESTS_CFLAGS) \
+ $(DEBUG_CFLAGS)
+
+-LDADD = ../libspi/libspi.la ../cspi/libcspi.la ../login-helper/libloginhelper.la $(TESTS_LIBS) $(X_LIBS) $(XINPUT_LIBS)
++LDADD = ../libspi/libspi.la ../cspi/libcspi.la ../login-helper/libloginhelper.la ../atk-bridge/libatk-bridge.la $(TESTS_LIBS) $(X_LIBS) $(XINPUT_LIBS)
+
+ TESTS = test-simple
+
+ TESTS_ENVIRONMENT = \
+- LD_LIBRARY_PATH=$(top_builddir)/libspi/.libs/:$(top_builddir)/cspi/.libs/ \
+- PATH=$(top_builddir)/registryd/.libs/:$(PATH)
++ BONOBO_ACTIVATION_PATH=$(top_builddir)/test
++
++BUILT_SOURCES = Accessibility_Registry.server
++
++Accessibility_Registry.server:
++ rm -f Accessibility_Registry.server
++ sed -e "s,@REGISTRYD_PATH\@,`which libtool` --mode=execute `pwd`/../registryd,g" \
++ $(top_builddir)/registryd/Accessibility_Registry.server.in.in > \
++ Accessibility_Registry.server
+
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN at-spi-1.19.3.orig/test/test-simple.c at-spi-1.19.3/test/test-simple.c
+--- at-spi-1.19.3.orig/test/test-simple.c 2007-01-09 22:08:21.000000000 -0500
++++ at-spi-1.19.3/test/test-simple.c 2007-06-04 13:29:46.000000000 -0400
+@@ -714,7 +714,7 @@ test_keylisteners (void)
+ key_listener = SPI_createAccessibleKeystrokeListener (
+ key_listener_cb, &stroke);
+
+- test_keyset = SPI_createAccessibleKeySet (1, "=", NULL, NULL);
++ test_keyset = SPI_createAccessibleKeySet (1, "t", NULL, NULL);
+
+ g_assert (SPI_registerAccessibleKeystrokeListener (
+ key_listener,
+@@ -725,11 +725,11 @@ test_keylisteners (void)
+
+ for (i = 0; i < 3; i++) {
+ memset (&stroke, 0, sizeof (AccessibleKeystroke));
+- g_assert (SPI_generateKeyboardEvent ('=', NULL, SPI_KEY_SYM));
++ g_assert (SPI_generateKeyboardEvent ('t', NULL, SPI_KEY_SYM));
+ while (!(key_press_received))
+ g_main_context_iteration (NULL, TRUE);
+ fprintf (stderr, "p [%s]", stroke.keystring);
+- g_assert (!strcmp (stroke.keystring, "="));
++ g_assert (!strcmp (stroke.keystring, "t"));
+ while (!(key_release_received))
+ g_main_context_iteration (NULL, TRUE);
+ fprintf (stderr, "r [%s]", stroke.keystring);
diff --git a/gnome-extra/at-spi/files/digest-at-spi-1.20.0 b/gnome-extra/at-spi/files/digest-at-spi-1.20.0
new file mode 100644
index 000000000000..c273daefbf46
--- /dev/null
+++ b/gnome-extra/at-spi/files/digest-at-spi-1.20.0
@@ -0,0 +1,3 @@
+MD5 fd1f916463f379b435399e2b2075742f at-spi-1.20.0.tar.bz2 847348
+RMD160 ec56bd5bc32decd992089315a9460c53b1efbe84 at-spi-1.20.0.tar.bz2 847348
+SHA256 fecb4b39f79656e32bd196d39dcb377f42d9d07c9184325f0ba8599bb340907f at-spi-1.20.0.tar.bz2 847348