summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-07-22 21:21:52 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-07-22 21:21:52 +0000
commit32cc18fe7f08d74edb6f32a79c507ff58e4fd23f (patch)
treee895a607d462a3d5025ad70e6a50c5bd6f56d1f5 /gnome-extra/evolution-data-server
parentAdd ~amd64 keyword (bug #278733). (diff)
downloadgentoo-2-32cc18fe7f08d74edb6f32a79c507ff58e4fd23f.tar.gz
gentoo-2-32cc18fe7f08d74edb6f32a79c507ff58e4fd23f.tar.bz2
gentoo-2-32cc18fe7f08d74edb6f32a79c507ff58e4fd23f.zip
Fix
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/evolution-data-server')
-rw-r--r--gnome-extra/evolution-data-server/ChangeLog12
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-2.24.5-r3.ebuild129
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-2.26.3.ebuild11
-rw-r--r--gnome-extra/evolution-data-server/files/evolution-data-server-2.24.5-fix-body.patch34
4 files changed, 183 insertions, 3 deletions
diff --git a/gnome-extra/evolution-data-server/ChangeLog b/gnome-extra/evolution-data-server/ChangeLog
index a65cf558e059..9bee492d54dc 100644
--- a/gnome-extra/evolution-data-server/ChangeLog
+++ b/gnome-extra/evolution-data-server/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for gnome-extra/evolution-data-server
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.234 2009/07/20 21:50:54 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.235 2009/07/22 21:21:52 eva Exp $
+
+*evolution-data-server-2.24.5-r3 (22 Jul 2009)
+
+ 22 Jul 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +evolution-data-server-2.24.5-r3.ebuild,
+ +files/evolution-data-server-2.24.5-fix-body.patch,
+ evolution-data-server-2.26.3.ebuild:
+ Fix gtkdoc-rebase breaking build, bug #278538. Apply bug #277218 on other
+ ebuilds except current stable which will be kicked out soon. Apply last
+ fix for bug #261203 in 2.24.5-r3.
*evolution-data-server-2.26.3 (20 Jul 2009)
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-2.24.5-r3.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-2.24.5-r3.ebuild
new file mode 100644
index 000000000000..e9ee8ec4f977
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-2.24.5-r3.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-2.24.5-r3.ebuild,v 1.1 2009/07/22 21:21:52 eva Exp $
+
+EAPI="2"
+
+inherit db-use eutils flag-o-matic gnome2 autotools versionator
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="http://www.gnome.org/projects/evolution/"
+
+LICENSE="LGPL-2 Sleepycat"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc ipv6 kerberos gnome-keyring krb4 ldap ssl"
+
+RDEPEND=">=dev-libs/glib-2.16.1
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/orbit-2.9.8
+ >=gnome-base/libbonobo-2.20.3
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnome-2
+ >=dev-libs/libxml2-2
+ >=net-libs/libsoup-2.4
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.20.1 )
+ >=dev-db/sqlite-3.5
+ ssl? (
+ >=dev-libs/nspr-4.4
+ >=dev-libs/nss-3.9 )
+ >=gnome-base/libgnomeui-2
+ sys-libs/zlib
+ =sys-libs/db-4*
+ ldap? ( >=net-nds/openldap-2.0 )
+ kerberos? ( virtual/krb5 )
+ krb4? ( app-crypt/mit-krb5[krb4] )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35.5
+ >=gnome-base/gnome-common-2
+ >=dev-util/gtk-doc-am-1.9
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+DOCS="ChangeLog MAINTAINERS NEWS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with ldap openldap)
+ $(use_with krb4 krb4 /usr)
+ $(use_with kerberos krb5 /usr)
+ $(use_enable ssl nss)
+ $(use_enable ssl smime)
+ $(use_enable ipv6)
+ $(use_enable gnome-keyring)
+ --with-libdb=/usr/$(get_libdir)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Adjust to gentoo's /etc/service
+ epatch "${FILESDIR}"/${PN}-1.2.0-gentoo_etc_services.patch
+
+ # Fix broken libdb build
+ epatch "${FILESDIR}"/${PN}-1.11.3-no-libdb.patch
+
+ # Rewind in camel-disco-diary to fix a crash
+ epatch "${FILESDIR}"/${PN}-1.8.0-camel-rewind.patch
+
+ # Fix building evo-exchange with --as-needed, upstream bug #342830
+ epatch "${FILESDIR}"/${PN}-2.23.6-as-needed.patch
+
+ # Fix S/MIME verification. Bug #258867
+ epatch "${FILESDIR}"/${P}-CVE-2009-0547.patch
+
+ # Fix S/MIME message display, bug #258867
+ epatch "${FILESDIR}"/${P}-fix-body.patch
+
+ # Fix NTLM SASL authentication. Bug #261203
+ epatch "${FILESDIR}"/${PN}-CVE-2009-0582.patch
+
+
+ if use doc; then
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=/usr/bin/gtkdoc-rebase" \
+ -i gtk-doc.make || die "sed 1 failed"
+ else
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=$(type -P true)" \
+ -i gtk-doc.make || die "sed 2 failed"
+ fi
+
+ # gtk-doc-am and gnome-common needed for this
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ if use ssl ; then
+ sed -i -e "s|mozilla-nss|nss|
+ s|mozilla-nspr|nspr|" "${S}"/configure || die "sed failed"
+ G2CONF="${G2CONF} --enable-nss=yes"
+ else
+ G2CONF="${G2CONF} --without-nspr-libs --without-nspr-includes \
+ --without-nss-libs --without-nss-includes"
+ fi
+
+ # /usr/include/db.h is always db-1 on FreeBSD
+ # so include the right dir in CPPFLAGS
+ append-cppflags "-I$(db_includedir)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use ldap; then
+ MY_MAJORV=$(get_version_component_range 1-2)
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/calentry.schema || die "doins failed"
+ dosym "${D}"/usr/share/${PN}-${MY_MAJORV}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
+ fi
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if use ldap; then
+ elog ""
+ elog "LDAP schemas needed by evolution are installed in /etc/openldap/schema"
+ fi
+}
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-2.26.3.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-2.26.3.ebuild
index 09722c85ce3b..44c70e92ca62 100644
--- a/gnome-extra/evolution-data-server/evolution-data-server-2.26.3.ebuild
+++ b/gnome-extra/evolution-data-server/evolution-data-server-2.26.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-2.26.3.ebuild,v 1.1 2009/07/20 21:50:54 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-2.26.3.ebuild,v 1.2 2009/07/22 21:21:52 eva Exp $
EAPI="2"
@@ -78,6 +78,14 @@ src_prepare() {
# Fix hang while updating search folders, bug #277864, upstream bug #583507
epatch "${FILESDIR}/${PN}-2.26.3-camel-vee-folder.patch"
+ if use doc; then
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=/usr/bin/gtkdoc-rebase" \
+ -i gtk-doc.make || die "sed 1 failed"
+ else
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=$(type -P true)" \
+ -i gtk-doc.make || die "sed 2 failed"
+ fi
+
# gtk-doc-am and gnome-common needed for this
intltoolize --force --copy --automake || die "intltoolize failed"
eautoreconf
@@ -106,7 +114,6 @@ src_install() {
doins "${FILESDIR}"/calentry.schema || die "doins failed"
dosym "${D}"/usr/share/${PN}-${MY_MAJORV}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
fi
-
}
pkg_postinst() {
diff --git a/gnome-extra/evolution-data-server/files/evolution-data-server-2.24.5-fix-body.patch b/gnome-extra/evolution-data-server/files/evolution-data-server-2.24.5-fix-body.patch
new file mode 100644
index 000000000000..2671d0de0000
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/evolution-data-server-2.24.5-fix-body.patch
@@ -0,0 +1,34 @@
+From dcd2f9ebc6c66ab1c068764da3b528f8fbfeb8b5 Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Tue, 31 Mar 2009 11:54:36 +0000
+Subject: [PATCH] ** Fix for bug #564465
+
+2009-03-31 Milan Crha <mcrha@redhat.com>
+
+ ** Fix for bug #564465
+
+ * camel-smime-context.c: (sm_decrypt):
+ Pass correct body for signature verification.
+
+svn path=/trunk/; revision=10194
+---
+ camel/camel-smime-context.c | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/camel/camel-smime-context.c b/camel/camel-smime-context.c
+index 7470953..1913d6a 100644
+--- a/camel/camel-smime-context.c
++++ b/camel/camel-smime-context.c
+@@ -963,7 +963,8 @@ sm_decrypt(CamelCipherContext *context, CamelMimePart *ipart, CamelMimePart *opa
+ camel_data_wrapper_construct_from_stream((CamelDataWrapper *)opart, ostream);
+
+ if (NSS_CMSMessage_IsSigned(cmsg)) {
+- valid = sm_verify_cmsg(context, cmsg, NULL, ex);
++ camel_stream_reset (ostream);
++ valid = sm_verify_cmsg (context, cmsg, ostream, ex);
+ } else {
+ valid = camel_cipher_validity_new();
+ valid->encrypt.description = g_strdup(_("Encrypted content"));
+--
+1.6.3.3
+