summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-09 09:29:21 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-09 09:29:21 +0000
commit70dc50ab991de9f07f779f258ed5e8af4716a502 (patch)
tree346417eea6f7d86cad2861e81ff8bd590b468aa4 /gnome-extra/libgda
parentallow gnome2_src_configure/compile to have more than 1 parameter (diff)
downloadgentoo-2-70dc50ab991de9f07f779f258ed5e8af4716a502.tar.gz
gentoo-2-70dc50ab991de9f07f779f258ed5e8af4716a502.tar.bz2
gentoo-2-70dc50ab991de9f07f779f258ed5e8af4716a502.zip
fix freetds issue. #18962
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/ChangeLog5
-rw-r--r--gnome-extra/libgda/files/digest-libgda-0.11.02
-rw-r--r--gnome-extra/libgda/libgda-0.11.0.ebuild45
3 files changed, 30 insertions, 22 deletions
diff --git a/gnome-extra/libgda/ChangeLog b/gnome-extra/libgda/ChangeLog
index 33293f3f091d..dbf890174600 100644
--- a/gnome-extra/libgda/ChangeLog
+++ b/gnome-extra/libgda/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for gnome-extra/libgda
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.16 2003/03/15 22:52:17 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.17 2003/04/09 09:29:09 liquidx Exp $
*libgda-0.11.0 (15 Mar 2003)
+ 09 Apr 2003; Alastair Tse <liquidx@gentoo.org> libgda-0.11.0.ebuild:
+ disabling freetds support until we have 0.61
+
15 Mar 2003; Alastair Tse <liquidx@gentoo.org> libgda-0.11.0.ebuild:
version bump
diff --git a/gnome-extra/libgda/files/digest-libgda-0.11.0 b/gnome-extra/libgda/files/digest-libgda-0.11.0
index 4b0aa016f4e6..2acd56a69aff 100644
--- a/gnome-extra/libgda/files/digest-libgda-0.11.0
+++ b/gnome-extra/libgda/files/digest-libgda-0.11.0
@@ -1 +1,3 @@
+MD5 b25e6e812f6a42246239fb79f338c09e /files/libgda-0.2.96-gentoo.patch 3345
+MD5 c0365280ad0baf2c352569690a2aa866 /libgda-0.11.0.ebuild 2509
MD5 8e50d1082033f413c8e8b700b078194b libgda-0.11.0.tar.bz2 828283
diff --git a/gnome-extra/libgda/libgda-0.11.0.ebuild b/gnome-extra/libgda/libgda-0.11.0.ebuild
index 56a7352967aa..44ce9c2d2bb6 100644
--- a/gnome-extra/libgda/libgda-0.11.0.ebuild
+++ b/gnome-extra/libgda/libgda-0.11.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-0.11.0.ebuild,v 1.1 2003/03/15 22:52:17 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-0.11.0.ebuild,v 1.2 2003/04/09 09:29:09 liquidx Exp $
-IUSE="odbc postgres mysql ldap"
+IUSE="odbc postgres mysql ldap firebird"
inherit gnome2 gnome.org
@@ -27,11 +27,13 @@ RDEPEND=">=gnome-base/ORBit2-2.3.91
mysql? ( >=dev-db/mysql-3.23.51 )
postgres? ( >=dev-db/postgresql-7.2.1 )
odbc? ( >=dev-db/unixODBC-2.0.6 )
- ldap? ( net-nds/openldap )"
+ ldap? ( net-nds/openldap )
+ firebird? ( >=dev-db/firebird-1.0 )"
-# removing un-ratified use flags
+# - libgda needs a version that portage doesn't have yet
+# freetds? ( >=dev-db/freetds-0.61 )"
+# - removing un-ratified use flags
# sqlite? ( >=dev-db/sqlite-2.4.2 )
-# freetds? ( >=dev-db/freetds-0.53 )
DEPEND=">=dev-util/pkgconfig-0.8
>=dev-util/intltool-0.22
@@ -42,9 +44,9 @@ src_compile() {
local myconf
if [ -n "`use mysql`" ]; then
- myconf="--with-mysql=/usr"
+ myconf="${myconf} --with-mysql=/usr"
else
- myconf="--without-mysql"
+ myconf="${myconf} --without-mysql"
fi
if [ -n "`use postgres`" ]; then
@@ -65,32 +67,33 @@ src_compile() {
myconf="${myconf} --without-ldap"
fi
- # disabling unratified USE flags
-
+ # disabling unratified USE flags
#if [ -n "`use sqlite`" ]; then
# myconf="$myconf --with-sqlite=/usr"
#else
# myconf="$myconf --without-sqlite"
#fi
+ # explicitly disabling freetds until we have a
+ # compatible versions in portage
#if [ -n "`use freetds`" ]; then
# myconf="$myconf --with-tds=/usr"
#else
# myconf="$myconf --without-tds"
#fi
- # not setting these, because we should allow
- # libgda to autodetect the environment if
- # there are no use flags for these backends.
-
- #myconf="${myconf} --without-sqlite"
- #myconf="${myconf} --without-tds"
- #myconf="${myconf} --without-ibmdb2"
- #myconf="${myconf} --without-sybase"
- #myconf="${myconf} --without-oracle"
- #myconf="${myconf} --without-firebird"
- #myconf="${myconf} --without-mdb"
+ if [ -n "`use firebird`" ]; then
+ myconf="${myconf} --with-firebird=/usr"
+ else
+ myconf="${myconf} --without-firebird"
+ fi
- gnome2_src_compile ${myconf}
+ myconf="${myconf} --without-tds"
+ myconf="${myconf} --without-sqlite"
+ myconf="${myconf} --without-ibmdb2"
+ myconf="${myconf} --without-sybase"
+ myconf="${myconf} --without-oracle"
+ myconf="${myconf} --without-mdb"
+ gnome2_src_compile ${myconf}
}