summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-05 16:25:22 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-05 16:25:22 +0000
commit9292253d0f7dd0681b2a5a6866ce283a63fa4fcf (patch)
treed5d96915c967bc19abbe941be4663e33c0f693af /gnome-extra/libgsf/libgsf-1.6.0.ebuild
parentremoved 20021212 cvs snapshot version (diff)
downloadgentoo-2-9292253d0f7dd0681b2a5a6866ce283a63fa4fcf.tar.gz
gentoo-2-9292253d0f7dd0681b2a5a6866ce283a63fa4fcf.tar.bz2
gentoo-2-9292253d0f7dd0681b2a5a6866ce283a63fa4fcf.zip
New version
Diffstat (limited to 'gnome-extra/libgsf/libgsf-1.6.0.ebuild')
-rw-r--r--gnome-extra/libgsf/libgsf-1.6.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/libgsf-1.6.0.ebuild b/gnome-extra/libgsf/libgsf-1.6.0.ebuild
new file mode 100644
index 000000000000..510f48bb1f87
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.6.0.ebuild,v 1.1 2003/01/05 16:25:22 foser Exp $
+
+inherit gnome2
+
+IUSE="gnome doc"
+S=${WORKDIR}/${P}
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+RDEPEND=">=dev-libs/libxml2-2.4.16
+ >=dev-libs/glib-2
+ >=sys-libs/zlib-1.1.4
+ gnome? ( >=gnome-base/libbonobo-2
+ >=gnome-base/gnome-vfs-2 )"
+
+DEPEND=">=dev-util/pkgconfig-0.9
+ doc? ( dev-util/gtk-doc )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/doc/
+
+ # little hack to fix bug 7570
+ cp Makefile.in Makefile.in.orig
+ sed -e "s:doc\$(TARGET_DIR):\$(TARGET_DIR):" \
+ Makefile.in.orig > Makefile.in
+}
+
+src_compile() {
+ local myconf
+
+ use gnome \
+ && myconf="--with-gnome" \
+ || myconf="--without-gnome"
+
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
+
+ econf ${myconf} --with-zlib || die
+ emake || die
+}
+
+DOCS="dodoc AUTHORS COPYING* ChangeLog INSTALL NEWS README"