summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-03-30 19:23:10 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-03-30 19:23:10 +0000
commitd5be54ce1474e1446297df2122e0238b0c8a5d9a (patch)
tree9e753425b5b563e8fbd7eaba80f2867fd4c7b9c5 /gnome-extra/libgsf
parentPostgreSQL unit testing comes to Gentoo. Initial commit. (diff)
downloadgentoo-2-d5be54ce1474e1446297df2122e0238b0c8a5d9a.tar.gz
gentoo-2-d5be54ce1474e1446297df2122e0238b0c8a5d9a.tar.bz2
gentoo-2-d5be54ce1474e1446297df2122e0238b0c8a5d9a.zip
Version bump. Python support is now only provided by introspection.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-extra/libgsf')
-rw-r--r--gnome-extra/libgsf/ChangeLog7
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.26.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/gnome-extra/libgsf/ChangeLog b/gnome-extra/libgsf/ChangeLog
index 566b4e1f7b07..92efdec4c0fa 100644
--- a/gnome-extra/libgsf/ChangeLog
+++ b/gnome-extra/libgsf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/libgsf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.220 2013/03/29 22:48:57 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.221 2013/03/30 19:23:10 eva Exp $
+
+*libgsf-1.14.26 (30 Mar 2013)
+
+ 30 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org> +libgsf-1.14.26.ebuild:
+ Version bump. Python support is now only provided by introspection.
29 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org> libgsf-1.14.23.ebuild,
-libgsf-1.14.24.ebuild:
diff --git a/gnome-extra/libgsf/libgsf-1.14.26.ebuild b/gnome-extra/libgsf/libgsf-1.14.26.ebuild
new file mode 100644
index 000000000000..2917fd92515a
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.26.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.26.ebuild,v 1.1 2013/03/30 19:23:10 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="http://projects.gnome.org/libgsf/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? ( x11-libs/gtk+:2 )
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35.0
+ dev-libs/gobject-introspection-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+} \ No newline at end of file