summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-12-08 16:57:23 +0000
committerPacho Ramos <pacho@gentoo.org>2010-12-08 16:57:23 +0000
commitde0a1b71fd0f42acf7f88827950623b9c5d0a768 (patch)
tree425532b077345836dbea3465be832f7bca6742b3 /gnome-extra/music-applet
parentVersion bump. (diff)
downloadgentoo-2-de0a1b71fd0f42acf7f88827950623b9c5d0a768.tar.gz
gentoo-2-de0a1b71fd0f42acf7f88827950623b9c5d0a768.tar.bz2
gentoo-2-de0a1b71fd0f42acf7f88827950623b9c5d0a768.zip
Needs gnome-panel with bonobo support, let it work when python3 is set as main interpreter.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/music-applet')
-rw-r--r--gnome-extra/music-applet/ChangeLog6
-rw-r--r--gnome-extra/music-applet/music-applet-2.5.1.ebuild21
2 files changed, 20 insertions, 7 deletions
diff --git a/gnome-extra/music-applet/ChangeLog b/gnome-extra/music-applet/ChangeLog
index 70cea9e667c8..28d80c49bb74 100644
--- a/gnome-extra/music-applet/ChangeLog
+++ b/gnome-extra/music-applet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/music-applet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/ChangeLog,v 1.25 2010/06/23 15:06:35 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/ChangeLog,v 1.26 2010/12/08 16:57:23 pacho Exp $
+
+ 08 Dec 2010; Pacho Ramos <pacho@gentoo.org> music-applet-2.5.1.ebuild:
+ Needs gnome-panel with bonobo support, let it work when python3 is set as
+ main interpreter.
23 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
music-applet-2.5.1.ebuild:
diff --git a/gnome-extra/music-applet/music-applet-2.5.1.ebuild b/gnome-extra/music-applet/music-applet-2.5.1.ebuild
index a764aa5ccab5..4d5f4e984b68 100644
--- a/gnome-extra/music-applet/music-applet-2.5.1.ebuild
+++ b/gnome-extra/music-applet/music-applet-2.5.1.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/music-applet-2.5.1.ebuild,v 1.4 2010/06/23 15:06:35 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/music-applet-2.5.1.ebuild,v 1.5 2010/12/08 16:57:23 pacho Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
inherit gnome2 python eutils
@@ -18,7 +21,7 @@ IUSE="libnotify mpd"
RDEPEND=">=x11-libs/gtk+-2.6
>=x11-libs/pango-1.6
>=gnome-base/libgnomeui-2
- >=gnome-base/gnome-panel-2
+ || ( gnome-base/gnome-panel[bonobo] <gnome-base/gnome-panel-2.32 )
>=dev-python/gconf-python-2.14
>=dev-python/gnome-keyring-python-2.14
>=dev-python/gnome-applets-python-2.14
@@ -31,20 +34,26 @@ RDEPEND=">=x11-libs/gtk+-2.6
DEPEND="dev-util/pkgconfig
dev-util/intltool"
-src_unpack() {
- gnome2_src_unpack
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ gnome2_src_prepare
# disable pyc compiling
mv py-compile py-compile.orig
ln -s $(type -P true) py-compile
+
+ python_convert_shebangs -r 2 .
}
pkg_postinst() {
gnome2_pkg_postinst
- python_mod_optimize $(python_get_sitedir)/musicapplet
+ python_mod_optimize musicapplet
}
pkg_postrm() {
gnome2_pkg_postrm
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/musicapplet
+ python_mod_cleanup musicapplet
}