summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-04-15 12:45:26 +0000
committerPacho Ramos <pacho@gentoo.org>2011-04-15 12:45:26 +0000
commitb884d9362a9e5c54d70f3797a47de7ac3de4e803 (patch)
treee3ecc19eb4049037ad907fa6fb99897578915c7e /gnome-extra/panflute
parentversion bump (diff)
downloadgentoo-2-b884d9362a9e5c54d70f3797a47de7ac3de4e803.tar.gz
gentoo-2-b884d9362a9e5c54d70f3797a47de7ac3de4e803.tar.bz2
gentoo-2-b884d9362a9e5c54d70f3797a47de7ac3de4e803.zip
Version bump with lots of bugfixes (bug #363701 by Justin Lecher), also fixing old dbus-daemon cpu usage bug #354729 and modifying RDEPEND as it's depending automagically on gnome stuff causing problems like bug #362589 (by Diego Elio Pettenò).
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/panflute')
-rw-r--r--gnome-extra/panflute/ChangeLog10
-rw-r--r--gnome-extra/panflute/panflute-0.7.0.ebuild87
2 files changed, 96 insertions, 1 deletions
diff --git a/gnome-extra/panflute/ChangeLog b/gnome-extra/panflute/ChangeLog
index 130997d192db..e17eefdd87cb 100644
--- a/gnome-extra/panflute/ChangeLog
+++ b/gnome-extra/panflute/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-extra/panflute
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/panflute/ChangeLog,v 1.5 2011/03/21 11:43:32 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/panflute/ChangeLog,v 1.6 2011/04/15 12:45:26 pacho Exp $
+
+*panflute-0.7.0 (15 Apr 2011)
+
+ 15 Apr 2011; Pacho Ramos <pacho@gentoo.org> +panflute-0.7.0.ebuild:
+ Version bump with lots of bugfixes (bug #363701 by Justin Lecher), also
+ fixing old dbus-daemon cpu usage bug #354729 and modifying RDEPEND as it's
+ depending automagically on gnome stuff causing problems like bug #362589 (by
+ Diego Elio Pettenò).
21 Mar 2011; Markos Chandras <hwoarang@gentoo.org> panflute-0.6.2.ebuild:
Stable on amd64 wrt bug #359471
diff --git a/gnome-extra/panflute/panflute-0.7.0.ebuild b/gnome-extra/panflute/panflute-0.7.0.ebuild
new file mode 100644
index 000000000000..c6e1075e8c63
--- /dev/null
+++ b/gnome-extra/panflute/panflute-0.7.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/panflute/panflute-0.7.0.ebuild,v 1.1 2011/04/15 12:45:26 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils gnome2 python versionator
+
+MY_MAJORV="$(get_version_component_range 1-2)"
+
+DESCRIPTION="GNOME applet to control various music players"
+HOMEPAGE="http://launchpad.net/panflute"
+SRC_URI="http://launchpad.net/${PN}/${MY_MAJORV}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify mpd"
+
+# This ebuild is far from perfect, it does a lot of automagic detection
+RDEPEND="
+ >=dev-python/dbus-python-0.80
+ >=dev-libs/dbus-glib-0.71
+ dev-python/pygobject:2
+ >=x11-libs/pango-1.6
+ >=dev-python/gconf-python-2.14
+ >=dev-python/gnome-applets-python-2.14
+ >=dev-python/pygtk-2.16:2
+ libnotify? ( dev-python/notify-python )
+ mpd? ( >=dev-python/python-mpd-0.2.1 )
+ !gnome-extra/music-applet
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.40
+"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README THANKS"
+ python_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Upstream: https://bugs.launchpad.net/panflute/+bug/761701
+ has_version ">=x11-libs/libnotify-0.7" && epatch \
+ "${FILESDIR}"/${PN}-0.6.2-libnotify-0.7.patch
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_execute_function -s gnome2_src_configure
+}
+
+src_compile() {
+ python_execute_function -s gnome2_src_compile
+}
+
+src_test() {
+ python_execute_function -s -d
+}
+
+src_install() {
+ python_execute_function -s gnome2_src_install
+ python_clean_installation_image
+ python_convert_shebangs -r 2 "${ED}"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize panflute
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup panflute
+}