summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-11 19:13:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-11 19:13:04 +0000
commit6fd0146b581c7c8da8e4b30b1bc0357ac4a34c46 (patch)
treed141db14185516b71e65eaf298df56918130a1a6 /gnome-extra/polkit-gnome
parentmask new polkit-gnome in the glib mask (diff)
downloadgentoo-2-6fd0146b581c7c8da8e4b30b1bc0357ac4a34c46.tar.gz
gentoo-2-6fd0146b581c7c8da8e4b30b1bc0357ac4a34c46.tar.bz2
gentoo-2-6fd0146b581c7c8da8e4b30b1bc0357ac4a34c46.zip
Version bump.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/polkit-gnome')
-rw-r--r--gnome-extra/polkit-gnome/ChangeLog8
-rw-r--r--gnome-extra/polkit-gnome/polkit-gnome-0.101.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/gnome-extra/polkit-gnome/ChangeLog b/gnome-extra/polkit-gnome/ChangeLog
index c37bd5461fdf..ecbca90bc984 100644
--- a/gnome-extra/polkit-gnome/ChangeLog
+++ b/gnome-extra/polkit-gnome/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/polkit-gnome
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/polkit-gnome/ChangeLog,v 1.27 2011/03/04 12:37:51 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/polkit-gnome/ChangeLog,v 1.28 2011/03/11 19:13:04 ssuominen Exp $
+
+*polkit-gnome-0.101 (11 Mar 2011)
+
+ 11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +polkit-gnome-0.101.ebuild:
+ Version bump.
04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-gnome-0.99.ebuild:
x86 stable per bug 354509
diff --git a/gnome-extra/polkit-gnome/polkit-gnome-0.101.ebuild b/gnome-extra/polkit-gnome/polkit-gnome-0.101.ebuild
new file mode 100644
index 000000000000..9c9a068eeadb
--- /dev/null
+++ b/gnome-extra/polkit-gnome/polkit-gnome-0.101.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/polkit-gnome/polkit-gnome-0.101.ebuild,v 1.1 2011/03/11 19:13:04 ssuominen Exp $
+
+EAPI=3
+inherit autotools eutils
+
+DESCRIPTION="A dbus session bus service that is used to bring up authentication dialogs"
+HOMEPAGE="http://hal.freedesktop.org/docs/PolicyKit/"
+SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples +introspection"
+
+# XXX: Change to gtk3 when it gets added to ~arch
+# Strict dep on the same polkit shouldn't be needed, but we can't be sure
+RDEPEND=">=x11-libs/gtk+-2.17.1:2
+ >=sys-auth/polkit-${PV}
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
+ !lxde-base/lxpolkit"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ dev-util/pkgconfig
+ gnome-base/gnome-common
+ sys-devel/gettext
+ doc? ( >=dev-util/gtk-doc-1.3 )"
+
+src_prepare() {
+ # Fix make check, bug 298345
+ epatch "${FILESDIR}"/${PN}-0.95-fix-make-check.patch
+
+ if use doc; then
+ # Fix parallel build failure, bug 293247
+ epatch "${FILESDIR}"/${PN}-0.95-parallel-build-failure.patch
+
+ gtkdocize || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable doc gtk-doc) \
+ $(use_enable examples) \
+ $(use_enable introspection)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS HACKING NEWS
+
+ # polkit-gnome-authentication-agent-1.desktop was removed, manually added now
+ # translations are lost though, what to do about that?
+ insinto /etc/xdg/autostart
+ doins "${FILESDIR}"/polkit-gnome-authentication-agent-1.desktop
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}