summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-05 13:49:01 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-05 13:49:01 +0000
commitff30fbfbb702227e54dacdaee4e8dfc076af4853 (patch)
tree9bd6dcf96b574278962fa4bd32535a81da949102 /gnome-extra/zenity
parentVersion bump to 9.6.3. (diff)
downloadgentoo-2-ff30fbfbb702227e54dacdaee4e8dfc076af4853.tar.gz
gentoo-2-ff30fbfbb702227e54dacdaee4e8dfc076af4853.tar.bz2
gentoo-2-ff30fbfbb702227e54dacdaee4e8dfc076af4853.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/zenity')
-rw-r--r--gnome-extra/zenity/ChangeLog8
-rw-r--r--gnome-extra/zenity/files/zenity-2.32.1-libnotify-0.7.patch27
-rw-r--r--gnome-extra/zenity/zenity-2.32.1.ebuild11
3 files changed, 41 insertions, 5 deletions
diff --git a/gnome-extra/zenity/ChangeLog b/gnome-extra/zenity/ChangeLog
index bd07ac004408..746060c9ae5e 100644
--- a/gnome-extra/zenity/ChangeLog
+++ b/gnome-extra/zenity/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/zenity
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/ChangeLog,v 1.195 2010/11/29 18:40:56 pacho Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/ChangeLog,v 1.196 2011/02/05 13:49:01 ssuominen Exp $
+
+ 05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> zenity-2.32.1.ebuild,
+ +files/zenity-2.32.1-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
*zenity-2.32.1 (29 Nov 2010)
diff --git a/gnome-extra/zenity/files/zenity-2.32.1-libnotify-0.7.patch b/gnome-extra/zenity/files/zenity-2.32.1-libnotify-0.7.patch
new file mode 100644
index 000000000000..4d5bf7447b58
--- /dev/null
+++ b/gnome-extra/zenity/files/zenity-2.32.1-libnotify-0.7.patch
@@ -0,0 +1,27 @@
+--- src/notification.c
++++ src/notification.c
+@@ -30,6 +30,9 @@
+
+ #ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ #include "zenity.h"
+@@ -184,10 +187,14 @@
+ icon = freeme = g_filename_to_uri (icon_file, NULL, NULL);
+ }
+
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ /* notify_notification_new_with_status_icon was removed */
++#else
+ notif = notify_notification_new_with_status_icon (
+ message[0] /* title */,
+ message[1] /* summary */,
+ icon, status_icon);
++#endif
+
+ g_strfreev (message);
+ g_free (freeme);
diff --git a/gnome-extra/zenity/zenity-2.32.1.ebuild b/gnome-extra/zenity/zenity-2.32.1.ebuild
index e18efa0f3ff3..ba7dbab9fed4 100644
--- a/gnome-extra/zenity/zenity-2.32.1.ebuild
+++ b/gnome-extra/zenity/zenity-2.32.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/zenity-2.32.1.ebuild,v 1.1 2010/11/29 18:40:56 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/zenity-2.32.1.ebuild,v 1.2 2011/02/05 13:49:01 ssuominen Exp $
EAPI="3"
GCONF_DEBUG="yes"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
HOMEPAGE="http://live.gnome.org/Zenity"
@@ -37,6 +37,11 @@ pkg_setup() {
DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+ gnome2_src_prepare
+}
+
src_install() {
gnome2_src_install