summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-18 22:38:57 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-18 22:38:57 +0000
commit526e1a23a7f52101e9492e9b01d1d535778d6512 (patch)
tree90302aa1cf658d222003e3189c3bef57d928b88a /gnome-extra
parentAdded translations, thanks to kavol@email.cz, bug #250317 (diff)
downloadgentoo-2-526e1a23a7f52101e9492e9b01d1d535778d6512.tar.gz
gentoo-2-526e1a23a7f52101e9492e9b01d1d535778d6512.tar.bz2
gentoo-2-526e1a23a7f52101e9492e9b01d1d535778d6512.zip
Bump to 0.9.14-r1. Include a bunch of ubuntu/debian patches (bug #248939) and fix missing DEPEND.
(Portage version: 2.2_rc20/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gsynaptics/ChangeLog14
-rw-r--r--gnome-extra/gsynaptics/files/gsynaptics-0.9.14-build-filename.patch2
-rw-r--r--gnome-extra/gsynaptics/files/gsynaptics-0.9.14-do-not-set-zero.patch185
-rw-r--r--gnome-extra/gsynaptics/files/gsynaptics-0.9.14-dot-fixes.patch68
-rw-r--r--gnome-extra/gsynaptics/files/gsynaptics-0.9.14-fix-docbook.patch64
-rw-r--r--gnome-extra/gsynaptics/gsynaptics-0.9.14-r1.ebuild61
6 files changed, 390 insertions, 4 deletions
diff --git a/gnome-extra/gsynaptics/ChangeLog b/gnome-extra/gsynaptics/ChangeLog
index dd68508e1ed6..957504653bbf 100644
--- a/gnome-extra/gsynaptics/ChangeLog
+++ b/gnome-extra/gsynaptics/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for gnome-extra/gsynaptics
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gsynaptics/ChangeLog,v 1.14 2008/07/14 13:14:18 eva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gsynaptics/ChangeLog,v 1.15 2009/01/18 22:38:57 eva Exp $
+
+*gsynaptics-0.9.14-r1 (18 Jan 2009)
+
+ 18 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ files/gsynaptics-0.9.14-build-filename.patch,
+ +files/gsynaptics-0.9.14-do-not-set-zero.patch,
+ +files/gsynaptics-0.9.14-dot-fixes.patch,
+ +files/gsynaptics-0.9.14-fix-docbook.patch, +gsynaptics-0.9.14-r1.ebuild:
+ Bump to 0.9.14-r1. Include a bunch of ubuntu/debian patches (bug #248939)
+ and fix missing DEPEND.
*gsynaptics-0.9.14 (14 Jul 2008)
diff --git a/gnome-extra/gsynaptics/files/gsynaptics-0.9.14-build-filename.patch b/gnome-extra/gsynaptics/files/gsynaptics-0.9.14-build-filename.patch
index c48689533d76..4f8716d75329 100644
--- a/gnome-extra/gsynaptics/files/gsynaptics-0.9.14-build-filename.patch
+++ b/gnome-extra/gsynaptics/files/gsynaptics-0.9.14-build-filename.patch
@@ -4,8 +4,6 @@
## All lines beginning with `## DP:' are a description of the patch.
## DP: https://sourceforge.jp/tracker/index.php?func=detail&aid=12568&group_id=1720&atid=6435
## DP: Missing terminating NULL for g_build_filename call.
-
-@DPATCH@
diff -urNad gsynaptics-0.9.14~/src/main.c gsynaptics-0.9.14/src/main.c
--- gsynaptics-0.9.14~/src/main.c 2008-02-28 23:27:28.000000000 +0100
+++ gsynaptics-0.9.14/src/main.c 2008-05-17 08:34:04.000000000 +0200
diff --git a/gnome-extra/gsynaptics/files/gsynaptics-0.9.14-do-not-set-zero.patch b/gnome-extra/gsynaptics/files/gsynaptics-0.9.14-do-not-set-zero.patch
new file mode 100644
index 000000000000..996d68227ed0
--- /dev/null
+++ b/gnome-extra/gsynaptics/files/gsynaptics-0.9.14-do-not-set-zero.patch
@@ -0,0 +1,185 @@
+Do not set to 0 when some keys are not defined.
+Debian bug #480744.
+
+Forwarded to https://sourceforge.jp/tracker/index.php?func=detail&aid=12545&group_id=1720&atid=6435
+
+diff -urNad gsynaptics-0.9.14~/src/init.c gsynaptics-0.9.14/src/init.c
+--- gsynaptics-0.9.14~/src/init.c 2008-02-28 23:27:41.000000000 +0100
++++ gsynaptics-0.9.14/src/init.c 2008-05-17 09:14:12.000000000 +0200
+@@ -36,63 +36,148 @@
+ {
+ gboolean b_value;
+ gint i_value;
++ GConfValue *gval = NULL;
+
+ if (!gconf_client_dir_exists (gconf, DIRNAME, NULL))
+ return;
+
+ /* touchpad on/off */
+- b_value = gconf_client_get_bool (gconf, OFF_KEY, NULL);
+- g_synaptics_set_enabled (synaptics, b_value ? 1 : 0);
++ gval = gconf_client_get (gconf, OFF_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_BOOL) {
++ b_value = gconf_value_get_bool(gval);
++ g_synaptics_set_enabled (synaptics, b_value ? 1 : 0);
++ }
++ gconf_value_free(gval);
++ }
+
+ /* vertical scroll delta */
+- i_value = gconf_client_get_int (gconf, VERTSCROLLDELTA_KEY, NULL);
+- g_synaptics_set_vertical_scroll_delta (synaptics, i_value);
++ gval = gconf_client_get (gconf, VERTSCROLLDELTA_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_INT) {
++ i_value = gconf_value_get_int(gval);
++ g_synaptics_set_vertical_scroll_delta (synaptics, i_value);
++ }
++ gconf_value_free(gval);
++ }
+
+ /* horizontal scroll delta */
+- i_value = gconf_client_get_int (gconf, HORIZSCROLLDELTA_KEY, NULL);
+- g_synaptics_set_horizontal_scroll_delta (synaptics, i_value);
++ gval = gconf_client_get (gconf, HORIZSCROLLDELTA_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_INT) {
++ i_value = gconf_value_get_int(gval);
++ g_synaptics_set_horizontal_scroll_delta (synaptics, i_value);
++ }
++ gconf_value_free(gval);
++ }
+
+ /* circular scroll */
+- i_value = gconf_client_get_int (gconf, CIRCSCROLLDELTA_KEY, NULL);
+- b_value = gconf_client_get_bool (gconf, CIRCULARSCROLLING_KEY, NULL);
+- g_synaptics_set_circular_scroll_delta (synaptics, i_value);
+- g_synaptics_set_circular_scroll_enabled (synaptics, b_value);
++ gval = gconf_client_get (gconf, CIRCSCROLLDELTA_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_INT) {
++ i_value = gconf_value_get_int(gval);
++ g_synaptics_set_circular_scroll_delta (synaptics, i_value);
++ }
++ gconf_value_free(gval);
++ }
++ gval = gconf_client_get (gconf, CIRCULARSCROLLING_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_BOOL) {
++ b_value = gconf_value_get_bool(gval);
++ g_synaptics_set_circular_scroll_enabled (synaptics, b_value);
++ }
++ gconf_value_free(gval);
++ }
+ /* the trigger of circular scrolling */
+- i_value = gconf_client_get_int (gconf, CIRCSCROLLTRIGGER_KEY, NULL);
+- g_synaptics_set_circular_scroll_trigger (synaptics, i_value);
++ gval = gconf_client_get (gconf, CIRCSCROLLTRIGGER_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_INT) {
++ i_value = gconf_value_get_int(gval);
++ g_synaptics_set_circular_scroll_trigger (synaptics, i_value);
++ }
++ gconf_value_free(gval);
++ }
+
+
+ /* tapping time */
+- i_value = gconf_client_get_int (gconf, MAXTAPTIME_KEY, NULL);
+- g_synaptics_set_tap_time (synaptics, i_value);
++ gval = gconf_client_get (gconf, MAXTAPTIME_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_INT) {
++ i_value = gconf_value_get_int(gval);
++ g_synaptics_set_tap_time (synaptics, i_value);
++ }
++ gconf_value_free(gval);
++ }
+
+ /* fast taps */
+- b_value = gconf_client_get_bool (gconf, FASTTAPS_KEY, NULL);
+- g_synaptics_set_fast_taps (synaptics, b_value);
++ gval = gconf_client_get (gconf, FASTTAPS_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_BOOL) {
++ b_value = gconf_value_get_bool(gval);
++ g_synaptics_set_fast_taps (synaptics, b_value);
++ }
++ gconf_value_free(gval);
++ }
+
+ /* sensitivity */
+- i_value = gconf_client_get_int (gconf, SENSITIVITY_KEY, NULL);
+- g_synaptics_set_sensitivity (synaptics, i_value);
++ gval = gconf_client_get (gconf, SENSITIVITY_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_INT) {
++ i_value = gconf_value_get_int(gval);
++ g_synaptics_set_sensitivity (synaptics, i_value);
++ }
++ gconf_value_free(gval);
++ }
+
+ /* coasting */
+- b_value = gconf_client_get_bool (gconf, COASTENABLE_KEY, NULL);
+- g_synaptics_set_coasting_enabled (synaptics, b_value);
++ gval = gconf_client_get (gconf, COASTENABLE_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_BOOL) {
++ b_value = gconf_value_get_bool(gval);
++ g_synaptics_set_coasting_enabled (synaptics, b_value);
++ }
++ gconf_value_free(gval);
++ }
+
+ /* edge motion */
+- b_value = gconf_client_get_bool (gconf, EDGEMOTIONUSEALWAYS_KEY, NULL);
+- g_synaptics_set_edge_motion_enabled (synaptics, b_value);
++ gval = gconf_client_get (gconf, EDGEMOTIONUSEALWAYS_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_BOOL) {
++ b_value = gconf_value_get_bool(gval);
++ g_synaptics_set_edge_motion_enabled (synaptics, b_value);
++ }
++ gconf_value_free(gval);
++ }
+
+ /* min speed */
+- i_value = gconf_client_get_int (gconf, MINSPEED_KEY, NULL);
+- g_synaptics_set_min_speed (synaptics, i_value);
++ gval = gconf_client_get (gconf, MINSPEED_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_INT) {
++ i_value = gconf_value_get_int(gval);
++ g_synaptics_set_min_speed (synaptics, i_value);
++ }
++ gconf_value_free(gval);
++ }
+
+ /* max speed */
+- i_value = gconf_client_get_int (gconf, MAXSPEED_KEY, NULL);
+- g_synaptics_set_max_speed (synaptics, i_value);
++ gval = gconf_client_get (gconf, MAXSPEED_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_INT) {
++ i_value = gconf_value_get_int(gval);
++ g_synaptics_set_max_speed (synaptics, i_value);
++ }
++ gconf_value_free(gval);
++ }
+
+ /* accel factor */
+- i_value = gconf_client_get_int (gconf, ACCELFACTOR_KEY, NULL);
+- g_synaptics_set_accel_factor (synaptics, i_value);
++ gval = gconf_client_get (gconf, ACCELFACTOR_KEY, NULL);
++ if (gval != NULL) {
++ if (gval->type == GCONF_VALUE_INT) {
++ i_value = gconf_value_get_int(gval);
++ g_synaptics_set_accel_factor (synaptics, i_value);
++ }
++ gconf_value_free(gval);
++ }
+
+ }
+
diff --git a/gnome-extra/gsynaptics/files/gsynaptics-0.9.14-dot-fixes.patch b/gnome-extra/gsynaptics/files/gsynaptics-0.9.14-dot-fixes.patch
new file mode 100644
index 000000000000..94eebe5e5449
--- /dev/null
+++ b/gnome-extra/gsynaptics/files/gsynaptics-0.9.14-dot-fixes.patch
@@ -0,0 +1,68 @@
+# Fix format strings to always use . as decimal separator, see
+# https://sourceforge.jp/tracker/index.php?func=detail&aid=12498&group_id=1720&atid=6435
+#
+# Forwarded to https://sourceforge.jp/tracker/index.php?func=detail&aid=12544&group_id=1720&atid=6435
+diff -urNad gsynaptics-0.9.14~/src/gsynaptics.c gsynaptics-0.9.14/src/gsynaptics.c
+--- gsynaptics-0.9.14~/src/gsynaptics.c 2008-02-28 23:21:17.000000000 +0100
++++ gsynaptics-0.9.14/src/gsynaptics.c 2008-05-17 08:36:54.000000000 +0200
+@@ -713,8 +713,9 @@
+ if (priv->synclient)
+ {
+ gchar *command;
+- command = g_strdup_printf ("synclient AccelFactor=%f",
+- (gdouble)value / 1000);
++ char strval[G_ASCII_DTOSTR_BUF_SIZE];
++ g_ascii_dtostr(strval, sizeof(strval), (gdouble)value / 1000);
++ command = g_strdup_printf ("synclient AccelFactor=%s", strval);
+ g_spawn_command_line_async (command, NULL);
+ g_free (command);
+ }
+@@ -734,8 +735,9 @@
+ if (priv->synclient)
+ {
+ gchar *command;
+- command = g_strdup_printf ("synclient MaxSpeed=%f",
+- (gdouble)value / 1000);
++ char strval[G_ASCII_DTOSTR_BUF_SIZE];
++ g_ascii_dtostr(strval, sizeof(strval), (gdouble)value / 1000);
++ command = g_strdup_printf ("synclient MaxSpeed=%s", strval);
+ g_spawn_command_line_async (command, NULL);
+ g_free (command);
+ }
+@@ -755,8 +757,9 @@
+ if (priv->synclient)
+ {
+ gchar *command;
+- command = g_strdup_printf ("synclient MinSpeed=%f",
+- (gdouble)value / 1000);
++ char strval[G_ASCII_DTOSTR_BUF_SIZE];
++ g_ascii_dtostr(strval, sizeof(strval), (gdouble)value / 1000);
++ command = g_strdup_printf ("synclient MinSpeed=%s", strval);
+ g_spawn_command_line_async (command, NULL);
+ g_free (command);
+ }
+@@ -822,8 +825,10 @@
+ if (priv->synclient)
+ {
+ gchar *command;
+- command = g_strdup_printf ("synclient CoastingSpeed=%f",
+- thresh);
++ char strval[G_ASCII_DTOSTR_BUF_SIZE];
++ g_ascii_dtostr(strval, sizeof(strval), thresh);
++ command = g_strdup_printf ("synclient CoastingSpeed=%s",
++ strval);
+ g_spawn_command_line_async (command, NULL);
+ g_free (command);
+ }
+@@ -843,8 +848,9 @@
+ if (priv->synclient)
+ {
+ gchar *command;
+- command = g_strdup_printf ("synclient CircScrollDelta=%f",
+- (gdouble)delta / 1000);
++ char strval[G_ASCII_DTOSTR_BUF_SIZE];
++ g_ascii_dtostr(strval, sizeof(strval), (gdouble)delta / 1000);
++ command = g_strdup_printf ("synclient CircScrollDelta=%s", strval);
+ g_spawn_command_line_async (command, NULL);
+ g_free (command);
+ }
diff --git a/gnome-extra/gsynaptics/files/gsynaptics-0.9.14-fix-docbook.patch b/gnome-extra/gsynaptics/files/gsynaptics-0.9.14-fix-docbook.patch
new file mode 100644
index 000000000000..87af5634358b
--- /dev/null
+++ b/gnome-extra/gsynaptics/files/gsynaptics-0.9.14-fix-docbook.patch
@@ -0,0 +1,64 @@
+Fix docbook document to be valid.
+
+See https://sourceforge.jp/tracker/index.php?func=detail&aid=13557&group_id=1720&atid=6433
+
+diff -urNad gsynaptics-0.9.14~/help/C/gsynaptics.xml gsynaptics-0.9.14/help/C/gsynaptics.xml
+--- gsynaptics-0.9.14~/help/C/gsynaptics.xml 2008-02-28 23:38:55.000000000 +0100
++++ gsynaptics-0.9.14/help/C/gsynaptics.xml 2008-09-22 11:08:43.000000000 +0200
+@@ -214,7 +214,7 @@
+ </para>
+ <para>Also, it will only be able to communicate with the driver,
+ if the <command>synclient</command> tool is installed and
+- operational, which means there is <term>"SHMConfig" "true"</term>
++ operational, which means there is <varname>"SHMConfig" "true"</varname>
+ in the section of the synaptics driver in
+ <filename>xorg.conf</filename> or <filename>XF86Config</filename>.
+ </para>
+@@ -321,7 +321,7 @@
+ Makes the driver react faster to a single tap, but
+ also makes double clicks caused by double tapping
+ slower </quote>. (borrowed from <command>man 5
+- synaptics</command> for <term>FastTaps</term>
++ synaptics</command> for <varname>FastTaps</varname>
+ configuration value of the driver)
+ </para>
+ </listitem>
+@@ -342,8 +342,6 @@
+ The touchpad can be used to control scrolling, as could
+ be done with a scroll-wheel mouse.
+ </para>
+- </listitem>
+- <listitem>
+ <variablelist>
+ <varlistentry id="enable-mail-summary-popup">
+ <term><guilabel>Enable vertical scrolling</guilabel></term>
+@@ -353,8 +351,6 @@
+ (emulating a scroll mouse) is possible when moving
+ the finger along the right side of the touchpad.
+ </para>
+- </listitem>
+- <listitem>
+ <para>The scrolling speed can be set here.</para>
+ </listitem>
+ </varlistentry>
+@@ -366,8 +362,6 @@
+ possible when moving the finger along the bottom
+ side of the touchpad.
+ </para>
+- </listitem>
+- <listitem>
+ <para>The scrolling speed can be set here.</para>
+ </listitem>
+ </varlistentry>
+@@ -379,11 +373,7 @@
+ a scrolling wheel, by drawing a circle with the
+ finger on the touchpad.
+ </para>
+- </listitem>
+- <listitem>
+ <para>The scrolling speed can be set here.</para>
+- </listitem>
+- <listitem>
+ <para>The start point of the circle for circular scrolling can also be set here.</para>
+ </listitem>
+ </varlistentry>
diff --git a/gnome-extra/gsynaptics/gsynaptics-0.9.14-r1.ebuild b/gnome-extra/gsynaptics/gsynaptics-0.9.14-r1.ebuild
new file mode 100644
index 000000000000..3e0a0984252a
--- /dev/null
+++ b/gnome-extra/gsynaptics/gsynaptics-0.9.14-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gsynaptics/gsynaptics-0.9.14-r1.ebuild,v 1.1 2009/01/18 22:38:57 eva Exp $
+
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="A GTK+ based configuration utility for the synaptics driver"
+HOMEPAGE="http://gsynaptics.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/29684/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.6.0
+ >=gnome-base/gconf-2.0
+ >=gnome-base/libglade-2"
+DEPEND="${DEPEND}
+ >=dev-util/pkgconfig-0.19
+ app-text/gnome-doc-utils
+ sys-devel/gettext
+ test? ( ~app-text/docbook-xml-dtd-4.1.2 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix ?
+ epatch "${FILESDIR}/${PN}-0.9.13-CoastingSpeedThreshold.patch"
+
+ # Fix crash on startup, thanks to debian folks, bug #210958
+ epatch "${FILESDIR}/${P}-build-filename.patch"
+
+ # Ubuntu/Debian patch stack. See bug #248939 and
+ # http://patches.ubuntu.com/by-release/extracted/debian/g/gsynaptics/
+ epatch "${FILESDIR}/${P}-do-not-set-zero.patch"
+ epatch "${FILESDIR}/${P}-dot-fixes.patch"
+ epatch "${FILESDIR}/${P}-fix-docbook.patch"
+
+ rm -rf "${S}/.pc"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ echo
+ elog "Ensure that the following line is in the InputDevice section in"
+ elog "your X config file (/etc/X11/xorg.conf):"
+ elog
+ elog "Option \"SHMConfig\" \"on\""
+ elog
+ elog "You need to add gsynaptics-init to your session to restore your"
+ elog "settings the next time you log into GNOME:"
+ elog "Desktop -> Preferences -> Sessions -> Start Programs -> Add"
+ echo
+}