summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-03-23 21:06:19 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-03-23 21:06:19 +0000
commitb18db1906506d66255be5f91750b87188f341c86 (patch)
treee0871732c67391b84f2a568dadf060129332a6ff /gnome-extra
parentold (diff)
downloadgentoo-2-b18db1906506d66255be5f91750b87188f341c86.tar.gz
gentoo-2-b18db1906506d66255be5f91750b87188f341c86.tar.bz2
gentoo-2-b18db1906506d66255be5f91750b87188f341c86.zip
Bump to 2.24.5. Bug fixes.
(Portage version: 2.2_rc26/cvs/Linux i686)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-exchange/ChangeLog8
-rw-r--r--gnome-extra/evolution-exchange/evolution-exchange-2.24.5.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/gnome-extra/evolution-exchange/ChangeLog b/gnome-extra/evolution-exchange/ChangeLog
index a7a8c7c05673..de1890cf82bf 100644
--- a/gnome-extra/evolution-exchange/ChangeLog
+++ b/gnome-extra/evolution-exchange/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-exchange
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.86 2009/03/16 22:31:21 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.87 2009/03/23 21:06:19 eva Exp $
+
+*evolution-exchange-2.24.5 (23 Mar 2009)
+
+ 23 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +evolution-exchange-2.24.5.ebuild:
+ Bump to 2.24.5. Bug fixes.
16 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org>
-files/evolution-exchange-2.12.3-fix-locks.patch,
diff --git a/gnome-extra/evolution-exchange/evolution-exchange-2.24.5.ebuild b/gnome-extra/evolution-exchange/evolution-exchange-2.24.5.ebuild
new file mode 100644
index 000000000000..1343f1aa47f7
--- /dev/null
+++ b/gnome-extra/evolution-exchange/evolution-exchange-2.24.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/evolution-exchange-2.24.5.ebuild,v 1.1 2009/03/23 21:06:19 eva Exp $
+
+EAPI="1"
+
+inherit eutils gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
+HOMEPAGE="http://www.novell.com/products/desktop/features/evolution.html"
+LICENSE="GPL-2"
+
+SLOT="2.0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="debug doc static"
+
+RDEPEND="
+ >=mail-client/evolution-2.24.3
+ >=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/gconf-2.0
+ >=gnome-base/libbonobo-2.20.3
+ >=gnome-base/libglade-2.0
+ >=gnome-base/libgnomeui-2.0
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ >=gnome-extra/evolution-data-server-2.24.3
+ >=net-nds/openldap-2.1.30-r2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_with debug e2k-debug)"
+
+ if ! built_with_use gnome-extra/evolution-data-server ldap || ! built_with_use gnome-extra/evolution-data-server kerberos; then
+ eerror "Please re-emerge gnome-extra/evolution-data-server with"
+ eerror "the use flags ldap and kerberos."
+ die
+ fi
+
+ G2CONF="${G2CONF} $(use_with static static-ldap) --with-openldap"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # intltoolize because e-e won't install locales otherwise
+ # thanks to recent intltool, no need to eautoreconf/eautomake
+ intltoolize --force --copy --automake || die "intltoolize failed"
+}