summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2013-03-28 15:03:25 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2013-03-28 15:03:25 +0000
commit52560849a2199fb281ef257528df7c88918dcb53 (patch)
tree47583b0ee724d4c0690170ee26d85faccb3360ab /gnustep-apps/textedit
parentamd64 stable, wrt bug #463554 (diff)
downloadgentoo-2-52560849a2199fb281ef257528df7c88918dcb53.tar.gz
gentoo-2-52560849a2199fb281ef257528df7c88918dcb53.tar.bz2
gentoo-2-52560849a2199fb281ef257528df7c88918dcb53.zip
Fix NSInvalidArgumentException on document creation, patch from Debian in bug #462786
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'gnustep-apps/textedit')
-rw-r--r--gnustep-apps/textedit/ChangeLog12
-rw-r--r--gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch26
-rw-r--r--gnustep-apps/textedit/textedit-0.95_pre20100427-r1.ebuild (renamed from gnustep-apps/textedit/textedit-0.95_pre20060928.ebuild)15
3 files changed, 47 insertions, 6 deletions
diff --git a/gnustep-apps/textedit/ChangeLog b/gnustep-apps/textedit/ChangeLog
index 720f6e1b847d..3f8f2bfbee3b 100644
--- a/gnustep-apps/textedit/ChangeLog
+++ b/gnustep-apps/textedit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnustep-apps/textedit
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/textedit/ChangeLog,v 1.18 2012/08/29 10:59:23 voyageur Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/textedit/ChangeLog,v 1.19 2013/03/28 15:03:25 voyageur Exp $
+
+*textedit-0.95_pre20100427-r1 (28 Mar 2013)
+
+ 28 Mar 2013; Bernard Cafarelli <voyageur@gentoo.org>
+ -textedit-0.95_pre20060928.ebuild, +textedit-0.95_pre20100427-r1.ebuild,
+ +files/textedit-0.95_pre20100427-nsinvalidargument.patch:
+ Fix NSInvalidArgumentException on document creation, patch from Debian in bug
+ #462786
29 Aug 2012; Bernard Cafarelli <voyageur@gentoo.org>
textedit-0.95_pre20100427.ebuild,
diff --git a/gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch b/gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch
new file mode 100644
index 000000000000..345a0641fcbc
--- /dev/null
+++ b/gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch
@@ -0,0 +1,26 @@
+--- textedit.app-4.0+20061029.orig/Document.m
++++ textedit.app-4.0+20061029/Document.m
+@@ -124,12 +124,6 @@
+ [self setViewSize: size];
+ }
+
+- [[NSNotificationCenter defaultCenter]
+- addObserver: self
+- selector: @selector (fixUpScrollViewBackgroundColor:)
+- name: NSSystemColorsDidChangeNotification
+- object: nil];
+-
+ potentialSaveDirectory = nil;
+ return self;
+ }
+@@ -195,10 +189,6 @@
+ NSNotificationCenter *center = [NSNotificationCenter defaultCenter];
+
+ [center removeObserver: self
+- name: NSSystemColorsDidChangeNotification
+- object: nil];
+-
+- [center removeObserver: self
+ name: NSTextStorageDidProcessEditingNotification
+ object: [self textStorage]];
+
diff --git a/gnustep-apps/textedit/textedit-0.95_pre20060928.ebuild b/gnustep-apps/textedit/textedit-0.95_pre20100427-r1.ebuild
index bc8e75fe34e7..c0caf9d96fe4 100644
--- a/gnustep-apps/textedit/textedit-0.95_pre20060928.ebuild
+++ b/gnustep-apps/textedit/textedit-0.95_pre20100427-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/textedit/textedit-0.95_pre20060928.ebuild,v 1.4 2008/03/08 13:54:06 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/textedit/textedit-0.95_pre20100427-r1.ebuild,v 1.1 2013/03/28 15:03:25 voyageur Exp $
-inherit gnustep-2
+EAPI=5
+inherit eutils gnustep-2
S=${WORKDIR}/TextEdit
@@ -10,6 +11,12 @@ DESCRIPTION="A text editor with font, color, and style capabilities for GNUstep"
HOMEPAGE="http://www.nongnu.org/backbone/"
SRC_URI="mirror://gentoo/${P}.tar.gz"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="~amd64 ~ppc ~x86"
LICENSE="GPL-2"
SLOT="0"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+ epatch "${FILESDIR}"/${P}-nsinvalidargument.patch
+}