summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2007-09-26 11:52:46 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2007-09-26 11:52:46 +0000
commit185134af6a8d36706fd8525624fe6adb611f8c07 (patch)
tree7a2575fa65b5b9cc9e2f64395fa63ae9887e66cc /gnustep-apps
parentfixed init script (diff)
downloadgentoo-2-185134af6a8d36706fd8525624fe6adb611f8c07.tar.gz
gentoo-2-185134af6a8d36706fd8525624fe6adb611f8c07.tar.bz2
gentoo-2-185134af6a8d36706fd8525624fe6adb611f8c07.zip
Fix bug 193806, add some quoting
(Portage version: 2.1.3.9)
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/gnumail/ChangeLog8
-rw-r--r--gnustep-apps/gnumail/files/digest-gnumail-1.2.0_pre3-r13
-rw-r--r--gnustep-apps/gnumail/files/gnumail-1.2.0_pre3-pgpversion.patch33
-rw-r--r--gnustep-apps/gnumail/gnumail-1.2.0_pre3-r1.ebuild90
4 files changed, 133 insertions, 1 deletions
diff --git a/gnustep-apps/gnumail/ChangeLog b/gnustep-apps/gnumail/ChangeLog
index 4665c5e81cbb..c177dad10a68 100644
--- a/gnustep-apps/gnumail/ChangeLog
+++ b/gnustep-apps/gnumail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-apps/gnumail
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gnumail/ChangeLog,v 1.24 2007/09/10 19:06:45 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gnumail/ChangeLog,v 1.25 2007/09/26 11:52:46 voyageur Exp $
+
+*gnumail-1.2.0_pre3-r1 (26 Sep 2007)
+
+ 26 Sep 2007; Bernard Cafarelli <voyageur@gentoo.org>
+ +files/gnumail-1.2.0_pre3-pgpversion.patch, +gnumail-1.2.0_pre3-r1.ebuild:
+ Fix a crash on amd64, patch by Jose Quinteiro <gentoo@quinteiro.com>
*gnumail-1.2.0_pre3 (10 Sep 2007)
diff --git a/gnustep-apps/gnumail/files/digest-gnumail-1.2.0_pre3-r1 b/gnustep-apps/gnumail/files/digest-gnumail-1.2.0_pre3-r1
new file mode 100644
index 000000000000..f6d45a96a127
--- /dev/null
+++ b/gnustep-apps/gnumail/files/digest-gnumail-1.2.0_pre3-r1
@@ -0,0 +1,3 @@
+MD5 66094028676b19cb2eee15e163073ee5 GNUMail-1.2.0pre3.tar.gz 1327521
+RMD160 5d8ff5d6d520f586eca5eb194ed2bafa3e718d0c GNUMail-1.2.0pre3.tar.gz 1327521
+SHA256 29127a65f35208a461436853b41de81f46db7d735958b40e06776805114d7b37 GNUMail-1.2.0pre3.tar.gz 1327521
diff --git a/gnustep-apps/gnumail/files/gnumail-1.2.0_pre3-pgpversion.patch b/gnustep-apps/gnumail/files/gnumail-1.2.0_pre3-pgpversion.patch
new file mode 100644
index 000000000000..6fd1d333a00b
--- /dev/null
+++ b/gnustep-apps/gnumail/files/gnumail-1.2.0_pre3-pgpversion.patch
@@ -0,0 +1,33 @@
+--- Bundles/PGP/PGPController.h.orig 2007-09-21 13:51:25.000000000 -0700
++++ Bundles/PGP/PGPController.h 2007-09-21 13:58:22.000000000 -0700
+@@ -69,6 +69,7 @@
+ // other methods
+ //
+ - (void) updateAndRestartTimer;
++- (NSString *) myVersion;
+
+ @end
+
+--- Bundles/PGP/PGPController.m.orig 2007-09-21 13:51:37.000000000 -0700
++++ Bundles/PGP/PGPController.m 2007-09-21 13:58:19.000000000 -0700
+@@ -274,7 +274,7 @@
+ //
+ //
+ //
+-- (NSString *) version
++- (NSString *) myVersion
+ {
+ return @"v0.9.1";
+ }
+--- Bundles/PGP/PGPViewController.m.orig 2007-09-25 11:42:10.000000000 -0700
++++ Bundles/PGP/PGPViewController.m 2007-09-25 11:42:30.000000000 -0700
+@@ -71,7 +71,7 @@
+
+ // We set the version label value
+ [versionLabel setStringValue: [NSString stringWithFormat: _(@"Version: %@"),
+- [[PGPController singleInstance] version]]];
++ [[PGPController singleInstance] myVersion]]];
+
+ return self;
+ }
+
diff --git a/gnustep-apps/gnumail/gnumail-1.2.0_pre3-r1.ebuild b/gnustep-apps/gnumail/gnumail-1.2.0_pre3-r1.ebuild
new file mode 100644
index 000000000000..a7eab67a2974
--- /dev/null
+++ b/gnustep-apps/gnumail/gnumail-1.2.0_pre3-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gnumail/gnumail-1.2.0_pre3-r1.ebuild,v 1.1 2007/09/26 11:52:46 voyageur Exp $
+
+inherit gnustep-2
+
+MY_PN=${PN/gnum/GNUM}
+
+S=${WORKDIR}/${MY_PN}
+
+DESCRIPTION="A fully featured mail application for GNUstep"
+HOMEPAGE="http://www.collaboration-world.com/gnumail/"
+SRC_URI="http://www.collaboration-world.com/gnumail.data/releases/Stable/${MY_PN}-${PV/_/}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="crypt emoticon xface"
+DEPEND="=gnustep-libs/pantomime-${PV}
+ >=gnustep-base/gnustep-gui-0.11.0
+ gnustep-apps/addresses"
+RDEPEND="crypt? ( app-crypt/gnupg )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-index.patch
+ epatch "${FILESDIR}"/${P}-pgpversion.patch
+ sed -i -e \
+ 's|$(GNUSTEP_INSTALLATION_DIR)/Library|$(DESTDIR)$(GNUSTEP_SYSTEM_LIBRARY)|' \
+ Bundles/*/GNUmakefile || die "gnustep-make-2 sed failed"
+}
+
+src_compile() {
+ egnustep_env
+ egnustep_make
+
+ cd Bundles/Clock
+ egnustep_make
+ cd "${S}"
+
+ if use xface ; then
+ cd Bundles/Face
+ egnustep_make
+ cd "${S}"
+ fi
+
+ if use crypt ; then
+ cd Bundles/PGP
+ egnustep_make
+ cd "${S}"
+ fi
+
+ if use emoticon ; then
+ cd Bundles/Emoticon
+ egnustep_make
+ cd "${S}"
+ fi
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ cd Bundles/Clock
+ egnustep_install || die
+ cd "${S}"
+
+ if use xface ; then
+ cd Bundles/Face
+ egnustep_install || die
+ cd "${S}"
+ fi
+ if use crypt ; then
+ cd Bundles/PGP
+ egnustep_install || die
+ cd "${S}"
+ fi
+ if use emoticon ; then
+ cd Bundles/Emoticon
+ egnustep_install || die
+ cd "${S}"
+ fi
+
+ dodoc "${S}"/Documentation/*
+
+ # FIX ?
+ rm -rf "${D}"$(egnustep_install_domain)/Applications/GNUMail.app/Resources/Resources
+}