summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2007-09-10 18:08:11 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2007-09-10 18:08:11 +0000
commit46a784d4c97aaffdc809787459edb40d75dd0852 (patch)
treebe159c940a8e631dd5cd634abd6e7835b59afbc0 /gnustep-libs/steptalk/steptalk-0.10.0-r1.ebuild
parentppc stable, bug #186219 (diff)
downloadgentoo-2-46a784d4c97aaffdc809787459edb40d75dd0852.tar.gz
gentoo-2-46a784d4c97aaffdc809787459edb40d75dd0852.tar.bz2
gentoo-2-46a784d4c97aaffdc809787459edb40d75dd0852.zip
Version bump from the GNUstep overlay
(Portage version: 2.1.3.9)
Diffstat (limited to 'gnustep-libs/steptalk/steptalk-0.10.0-r1.ebuild')
-rw-r--r--gnustep-libs/steptalk/steptalk-0.10.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnustep-libs/steptalk/steptalk-0.10.0-r1.ebuild b/gnustep-libs/steptalk/steptalk-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..61c42738acb6
--- /dev/null
+++ b/gnustep-libs/steptalk/steptalk-0.10.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/steptalk/steptalk-0.10.0-r1.ebuild,v 1.1 2007/09/10 18:08:10 voyageur Exp $
+
+inherit gnustep-2
+
+MY_PN="StepTalk"
+DESCRIPTION="StepTalk is the official GNUstep scripting framework."
+HOMEPAGE="http://www.gnustep.org/experience/StepTalk.html"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_PN}-${PV}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-gnustep-make-2.patch
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ if use doc ; then
+ egnustep_env
+ mkdir -p ${D}${GNUSTEP_SYSTEM_DOC}/Developer/${MY_PN}
+ cp -R Documentation/* ${D}${GNUSTEP_SYSTEM_DOC}/Developer/${MY_PN}
+ fi
+}