summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
commit469c774bcd0309358560d5b77f5346fb8804f9bf (patch)
treece4119225d8c992262a6486b5bb41718a6a9529c /kde-base/dolphin-plugins
parent[profiles] Update kde mask (diff)
downloadgentoo-2-469c774bcd0309358560d5b77f5346fb8804f9bf.tar.gz
gentoo-2-469c774bcd0309358560d5b77f5346fb8804f9bf.tar.bz2
gentoo-2-469c774bcd0309358560d5b77f5346fb8804f9bf.zip
[kde-base] Add KDE SC 4.7.1
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/dolphin-plugins')
-rw-r--r--kde-base/dolphin-plugins/ChangeLog8
-rw-r--r--kde-base/dolphin-plugins/dolphin-plugins-4.7.1.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/dolphin-plugins/ChangeLog b/kde-base/dolphin-plugins/ChangeLog
index 8d37c8ae859f..e0e88d2ff499 100644
--- a/kde-base/dolphin-plugins/ChangeLog
+++ b/kde-base/dolphin-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/dolphin-plugins
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.26 2011/08/15 21:28:54 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.27 2011/09/07 20:13:53 alexxy Exp $
+
+*dolphin-plugins-4.7.1 (07 Sep 2011)
+
+ 07 Sep 2011; Alexey Shvetsov <alexxy@gentoo.org>
+ +dolphin-plugins-4.7.1.ebuild:
+ Version bump KDE SC 4.7.1
15 Aug 2011; Markus Meier <maekke@gentoo.org> dolphin-plugins-4.6.5.ebuild:
x86 stable, bug #377465
diff --git a/kde-base/dolphin-plugins/dolphin-plugins-4.7.1.ebuild b/kde-base/dolphin-plugins/dolphin-plugins-4.7.1.ebuild
new file mode 100644
index 000000000000..9235e0ef26d4
--- /dev/null
+++ b/kde-base/dolphin-plugins/dolphin-plugins-4.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/dolphin-plugins-4.7.1.ebuild,v 1.1 2011/09/07 20:13:53 alexxy Exp $
+
+EAPI=4
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Extra Dolphin plugins"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +git +subversion"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kompare)
+ git? ( dev-vcs/git )
+ subversion? ( dev-vcs/subversion )
+"
+
+# SCM plugins moved from dolphin somewhere before 4.4.75
+add_blocker dolphin '<4.4.75'
+
+KMLOADLIBS="libkonq"
+
+#
+# See bug 351147 for why this is necessary
+#
+src_prepare() {
+ echo 'macro_optional_add_subdirectory ( dolphin-plugins )' >> CMakeLists.txt || die
+ echo > dolphin-plugins/CMakeLists.txt || die
+ use git && echo 'add_subdirectory ( git )' >> dolphin-plugins/CMakeLists.txt
+ use subversion && echo 'add_subdirectory ( svn )' >> dolphin-plugins/CMakeLists.txt
+
+ kde4-meta_src_prepare
+}
+
+src_install() {
+ { use git || use subversion; } && kde4-meta_src_install
+}