summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-06 22:49:24 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-06 22:49:24 +0000
commitd9c13c790ac3e16ee6bc958cd395e20288d9cf04 (patch)
treeb596ba84f1086acb02fd262a68c43bab6f0949bd /kde-base/dolphin
parentVersion bump KDE 4.2.3 (diff)
downloadgentoo-2-d9c13c790ac3e16ee6bc958cd395e20288d9cf04.tar.gz
gentoo-2-d9c13c790ac3e16ee6bc958cd395e20288d9cf04.tar.bz2
gentoo-2-d9c13c790ac3e16ee6bc958cd395e20288d9cf04.zip
Version bump KDE 4.2.3
(Portage version: 2.2_rc31/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.2.3.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 1a49e935f8b2..e6784daea8e7 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.30 2009/04/17 06:10:13 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.31 2009/05/06 22:49:24 scarabeus Exp $
+
+*dolphin-4.2.3 (06 May 2009)
+
+ 06 May 2009; Tomas Chvatal <scarabeus@gentoo.org> +dolphin-4.2.3.ebuild:
+ Version bump
17 Apr 2009; Alexey Shvetsov <alexxy@gentoo.org> dolphin-4.2.2:
Restore ~hppa keywords
diff --git a/kde-base/dolphin/dolphin-4.2.3.ebuild b/kde-base/dolphin/dolphin-4.2.3.ebuild
new file mode 100644
index 000000000000..009ac7208613
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.2.3.ebuild,v 1.1 2009/05/06 22:49:24 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc +semantic-desktop thumbnail"
+
+DEPEND="
+ >=kde-base/kdelibs-${PV}:${SLOT}[kdeprefix=,semantic-desktop=]
+ >=kde-base/libkonq-${PV}:${SLOT}[kdeprefix=]
+"
+RDEPEND="${DEPEND}
+ !kdeprefix? ( !kde-misc/dolphin )
+ >=kde-base/kfind-${PV}:${SLOT}[kdeprefix=]
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT}[kdeprefix=] )
+"
+PDEPEND="
+ thumbnail? ( media-video/mplayerthumbs:1 )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+
+ kde4-meta_src_configure
+}