summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-01-28 05:17:41 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-01-28 05:17:41 +0000
commitdea81fce322123168f22e7c1d68f4f544252fecf (patch)
treed54b62f9bc38b37eee22cc338a2b53177f88d52f /kde-base/kabcclient/kabcclient-4.4.10.ebuild
parentAdd KDEPIM 4.4.10 support (diff)
downloadgentoo-2-dea81fce322123168f22e7c1d68f4f544252fecf.tar.gz
gentoo-2-dea81fce322123168f22e7c1d68f4f544252fecf.tar.bz2
gentoo-2-dea81fce322123168f22e7c1d68f4f544252fecf.zip
Version bump KDEPIM 4.4.10
Diffstat (limited to 'kde-base/kabcclient/kabcclient-4.4.10.ebuild')
-rw-r--r--kde-base/kabcclient/kabcclient-4.4.10.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/kde-base/kabcclient/kabcclient-4.4.10.ebuild b/kde-base/kabcclient/kabcclient-4.4.10.ebuild
new file mode 100644
index 000000000000..2c51e3d739e7
--- /dev/null
+++ b/kde-base/kabcclient/kabcclient-4.4.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kabcclient/kabcclient-4.4.10.ebuild,v 1.1 2011/01/28 05:17:39 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdepim"
+KMMODULE="console/${PN}"
+inherit kde4-meta
+
+DESCRIPTION="A command line client for accessing the KDE addressbook"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~~amd64-linux ~x86-linux"
+IUSE="debug +handbook"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ kde4-meta_src_install
+
+ # work around NULL DT_RPATH in kabc2mutt
+ dosym kabcclient ${PREFIX}/bin/kabc2mutt || die "couldn't symlink kabc2mutt to kabcclient"
+}