summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-02-07 04:58:00 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2013-02-07 04:58:00 +0000
commitd7e1a4366ff9ba481421bd6f31539139be38e99a (patch)
tree06cf6fc3ad2522bd965c90e770efaf564b4caf81 /kde-base/kalgebra
parentMask KDE SC 4.10.0 for keywording bug #455960 (diff)
downloadgentoo-2-d7e1a4366ff9ba481421bd6f31539139be38e99a.tar.gz
gentoo-2-d7e1a4366ff9ba481421bd6f31539139be38e99a.tar.bz2
gentoo-2-d7e1a4366ff9ba481421bd6f31539139be38e99a.zip
Add KDE SC 4.10.0
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'kde-base/kalgebra')
-rw-r--r--kde-base/kalgebra/ChangeLog7
-rw-r--r--kde-base/kalgebra/kalgebra-4.10.0.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/kalgebra/ChangeLog b/kde-base/kalgebra/ChangeLog
index 5b9e5cbb4335..8dc040ee0b93 100644
--- a/kde-base/kalgebra/ChangeLog
+++ b/kde-base/kalgebra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalgebra
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.156 2013/01/28 12:12:35 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.157 2013/02/07 04:57:59 alexxy Exp $
+
+*kalgebra-4.10.0 (06 Feb 2013)
+
+ 06 Feb 2013; Alexey Shvetsov <alexxy@gentoo.org> +kalgebra-4.10.0.ebuild:
+ Version bump KDE SC 4.10.0
28 Jan 2013; Agostino Sarubbo <ago@gentoo.org> -kalgebra-4.9.3.ebuild,
-kalgebra-4.9.4.ebuild:
diff --git a/kde-base/kalgebra/kalgebra-4.10.0.ebuild b/kde-base/kalgebra/kalgebra-4.10.0.ebuild
new file mode 100644
index 000000000000..43f77fc6f1dc
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.10.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.10.0.ebuild,v 1.1 2013/02/07 04:57:59 alexxy Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+OPENGL_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma readline"
+
+DEPEND="
+ $(add_kdebase_dep analitza)
+ $(add_kdebase_dep libkdeedu)
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with readline)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-base_src_configure
+}