summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-07-28 21:16:26 +0000
committerDan Armak <danarmak@gentoo.org>2005-07-28 21:16:26 +0000
commit80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4 (patch)
tree10350f32a739306558a2f194fa917fdb13a0e42c /kde-base/kalyptus/kalyptus-3.4.2.ebuild
parentMarked ~ppc. (diff)
downloadgentoo-2-80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4.tar.gz
gentoo-2-80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4.tar.bz2
gentoo-2-80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4.zip
KDE 3.4.2 split ebuilds. p.masked, to be unmasked shortly.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'kde-base/kalyptus/kalyptus-3.4.2.ebuild')
-rw-r--r--kde-base/kalyptus/kalyptus-3.4.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-base/kalyptus/kalyptus-3.4.2.ebuild b/kde-base/kalyptus/kalyptus-3.4.2.ebuild
new file mode 100644
index 000000000000..f7106a84d358
--- /dev/null
+++ b/kde-base/kalyptus/kalyptus-3.4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalyptus/kalyptus-3.4.2.ebuild,v 1.1 2005/07/28 21:16:10 danarmak Exp $
+
+KMNAME=kdebindings
+KM_MAKEFILESREV=1
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE bindings generator for C, ObjC and Java"
+KEYWORDS=" ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="dev-lang/perl"
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+# Weird build system, weirder errors.
+# You're welcome to fix this in a better way --danarmak
+src_compile () {
+ export S=$S/kalyptus
+ kde-meta_src_compile
+}
+
+src_install() {
+ cd $S/kalyptus
+ make install DESTDIR=$D
+} \ No newline at end of file