summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-06 13:42:15 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-06 13:42:15 +0000
commitdaec5bb32d717672af35168b16bb8164f2533810 (patch)
tree64932fcb885be528a75e27b8edcfefe4903e17a0 /kde-base/kate
parentSwitch 9999 to truly live 'develop' branch per user request. (diff)
downloadgentoo-2-daec5bb32d717672af35168b16bb8164f2533810.tar.gz
gentoo-2-daec5bb32d717672af35168b16bb8164f2533810.tar.bz2
gentoo-2-daec5bb32d717672af35168b16bb8164f2533810.zip
Bump KDE SC 4.10.1
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 7887F787)
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.10.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 52803de36fac..f7193f4c9ed7 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.261 2013/02/23 16:04:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.262 2013/03/06 13:41:56 dilfridge Exp $
+
+*kate-4.10.1 (06 Mar 2013)
+
+ 06 Mar 2013; Andreas K. Huettel <dilfridge@gentoo.org> +kate-4.10.1.ebuild:
+ Version bump KDE SC 4.10.1
23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> kate-4.10.0.ebuild,
kate-4.9.5.ebuild:
diff --git a/kde-base/kate/kate-4.10.1.ebuild b/kde-base/kate/kate-4.10.1.ebuild
new file mode 100644
index 000000000000..2336bcebd167
--- /dev/null
+++ b/kde-base/kate/kate-4.10.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.10.1.ebuild,v 1.1 2013/03/06 13:41:56 dilfridge Exp $
+
+EAPI=5
+KDE_HANDBOOK="optional"
+KMNAME="kate"
+PYTHON_COMPAT=( python{2_7,3_1,3_2} )
+
+inherit python-single-r1 kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma python"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ python? ( $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}" 4.9.2-r1) )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep katepart)
+"
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+ kde4-meta_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build python pate)
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}