summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-10 18:00:20 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-10 18:00:20 +0000
commitb2b19c584143aa3164437f01988775b3baced7a1 (patch)
treed682b95b673d238fe82f54a47550663464f4e5cd /kde-base/kcheckpass
parentSort test dep. Remove useless dies. (diff)
downloadgentoo-2-b2b19c584143aa3164437f01988775b3baced7a1.tar.gz
gentoo-2-b2b19c584143aa3164437f01988775b3baced7a1.tar.bz2
gentoo-2-b2b19c584143aa3164437f01988775b3baced7a1.zip
Version bump
(Portage version: 2.1.10/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog8
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.6.4.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index 52523645b872..205c6c4072b3 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.185 2011/06/10 11:51:04 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.186 2011/06/10 18:00:03 dilfridge Exp $
+
+*kcheckpass-4.6.4 (10 Jun 2011)
+
+ 10 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kcheckpass-4.6.4.ebuild:
+ Version bump
10 Jun 2011; Markos Chandras <hwoarang@gentoo.org> kcheckpass-4.6.3.ebuild:
Stable on amd64 wrt bug #369979
diff --git a/kde-base/kcheckpass/kcheckpass-4.6.4.ebuild b/kde-base/kcheckpass/kcheckpass-4.6.4.ebuild
new file mode 100644
index 000000000000..63124fd1337c
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.6.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.6.4.ebuild,v 1.1 2011/06/10 18:00:03 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+DEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/kdebase-4.0.2-pam-optional.patch"
+)
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}