summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-06-14 22:31:24 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-06-14 22:31:24 +0000
commit8cf172bcc4dc63961c8a68f6d12cbe0bcadb6038 (patch)
tree4987912f48657a67dcdaf2c356408711f69e2c96 /kde-base/kdeaddons/kdeaddons-3.5.3.ebuild
parentReally fix bug #136299. (diff)
downloadgentoo-2-8cf172bcc4dc63961c8a68f6d12cbe0bcadb6038.tar.gz
gentoo-2-8cf172bcc4dc63961c8a68f6d12cbe0bcadb6038.tar.bz2
gentoo-2-8cf172bcc4dc63961c8a68f6d12cbe0bcadb6038.zip
Really fix bug #136299.
(Portage version: 2.1)
Diffstat (limited to 'kde-base/kdeaddons/kdeaddons-3.5.3.ebuild')
-rw-r--r--kde-base/kdeaddons/kdeaddons-3.5.3.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/kde-base/kdeaddons/kdeaddons-3.5.3.ebuild b/kde-base/kdeaddons/kdeaddons-3.5.3.ebuild
index 7297ab5c74aa..8613c4bff6d6 100644
--- a/kde-base/kdeaddons/kdeaddons-3.5.3.ebuild
+++ b/kde-base/kdeaddons/kdeaddons-3.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.5.3.ebuild,v 1.3 2006/06/13 11:52:54 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.5.3.ebuild,v 1.4 2006/06/14 22:31:24 carlo Exp $
inherit db-use kde-dist
@@ -23,7 +23,8 @@ src_compile() {
local myconf="$(use_with sdl) $(use_with xmms)"
if use berkdb; then
- myconf="${myconf} --with-berkeley-db --with-db-lib=$(db_libname)
+ dblib="$(db_libname)"
+ myconf="${myconf} --with-berkeley-db --with-db-lib=${dblib/-/_cxx-}
--with-extra-includes=${ROOT}$(db_includedir)"
else
myconf="${myconf} --without-berkeley-db"