summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-01-23 13:56:20 +0000
committerDan Armak <danarmak@gentoo.org>2002-01-23 13:56:20 +0000
commitd392ff2cd8a750dd9793438377b0df63f0694ff2 (patch)
treebc469020c3fda9ebb247cd760bb13298341633d3 /kde-base/kdebase
parentnew revision with support for kdm session selection. Also adds dynamic genera... (diff)
downloadgentoo-2-d392ff2cd8a750dd9793438377b0df63f0694ff2.tar.gz
gentoo-2-d392ff2cd8a750dd9793438377b0df63f0694ff2.tar.bz2
gentoo-2-d392ff2cd8a750dd9793438377b0df63f0694ff2.zip
Adds support for the new /etc/X11/Sessions scheme in >=xfree-4.2-r2.
If you don't want to recompile kdebase just to get it, create a file /etc/X11/Sessions/kde-2.2.2 (or any other name you like :-) that says: #!/bin/sh /usr/kde/2/bin/startkde
Diffstat (limited to 'kde-base/kdebase')
-rw-r--r--kde-base/kdebase/files/digest-kdebase-2.2.2-r21
-rw-r--r--kde-base/kdebase/kdebase-2.2.2-r2.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/kde-base/kdebase/files/digest-kdebase-2.2.2-r2 b/kde-base/kdebase/files/digest-kdebase-2.2.2-r2
new file mode 100644
index 000000000000..a66cb7601fc2
--- /dev/null
+++ b/kde-base/kdebase/files/digest-kdebase-2.2.2-r2
@@ -0,0 +1 @@
+MD5 39635e42056ab2afb8e6f2ff761eea38 kdebase-2.2.2.tar.bz2 12890112
diff --git a/kde-base/kdebase/kdebase-2.2.2-r2.ebuild b/kde-base/kdebase/kdebase-2.2.2-r2.ebuild
new file mode 100644
index 000000000000..cc303bf1ae45
--- /dev/null
+++ b/kde-base/kdebase/kdebase-2.2.2-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Authors Dan Armak <danarmak@gentoo.org>, Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-2.2.2-r2.ebuild,v 1.1 2002/01/23 13:56:20 danarmak Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Base"
+
+newdepend ">=media-sound/cdparanoia-3.9.8
+ ldap? ( >=net-nds/openldap-1.2 )
+ pam? ( >=sys-libs/pam-0.73 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ lame? ( >=media-sound/lame-3.89b )
+ vorbis? ( >=media-libs/libvorbis-1.0_beta1 )
+ cups? ( net-print/cups )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ media-sound/cdparanoia"
+# opengl? ( virtual/opengl )" #this last for opengl screensavers
+# samba? ( net-fs/samba ) #use flag doesn't exist yet and we don't want such a heavy dep by deafult
+# lm_sensors? ( ?/lm_sensors ) # ebuild doesn't exist yet
+
+src_unpack() {
+
+ base_src_unpack
+
+ kde_sandbox_patch ${S}/konsole/src
+
+}
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use ldap && myconf="$myconf --with-ldap" || myconf="$myconf --without-ldap"
+ use pam && myconf="$myconf --with-pam" || myconf="$myconf --with-shadow"
+ use motif || myconf="$myconf --without-motif"
+ use lame || myconf="$myconf --without-lame"
+ use cups || myconf="$myconf --disable-cups"
+ use vorbis || myconf="$myconf --without-vorbis"
+ #use opengl ||
+ myconf="$myconf --without-gl"
+ use ssl || myconf="$myconf --without-ssl"
+
+ kde_src_compile configure make
+
+}
+
+
+src_install() {
+
+ kde_src_install
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/kscreensaver.pam kscreensaver
+ newins kde.pamd kde
+
+ cd ${D}/${KDEDIR}/bin
+ rm -f ./startkde
+ sed -e "s:_KDEDIR_:${KDEDIR}:" ${FILESDIR}/startkde-${PV} > startkde
+ chmod a+x startkde
+
+ # x11 session script
+ cd ${T}
+ echo "#!/bin/sh
+${KDEDIR}/bin/startkde" > kde-${PV}
+ chmod a+x kde-${PV}
+ # old scheme - compatibility
+ exeinto /usr/X11R6/bin/wm
+ doexe kde-${PV}
+ # new scheme - for now >=xfree-4.2-r3 only
+ exeinto /etc/X11/Sessions
+ doexe kde-${PV}
+
+ cd ${D}/${KDEDIR}/share/config/kdm
+ mv kdmrc kdmrc.orig
+ sed -e 's/SessionTypes=/SessionTypes=kde-2.2.2,kde-3.0,xsession,/' kdmrc.orig | cat > kdmrc
+ rm kdmrc.orig
+
+ dodir ${KDEDIR}/share/templates/.source/emptydir
+
+}