summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2001-11-22 17:32:27 +0000
committerBart Verwilst <verwilst@gentoo.org>2001-11-22 17:32:27 +0000
commit04c9787435ae574479774f67ecc37221a86751cc (patch)
treec730ab2b471318e1e18a0c168c208ed9a44c7ea8 /kde-base/kdegraphics
parentnew version (diff)
downloadgentoo-2-04c9787435ae574479774f67ecc37221a86751cc.tar.gz
gentoo-2-04c9787435ae574479774f67ecc37221a86751cc.tar.bz2
gentoo-2-04c9787435ae574479774f67ecc37221a86751cc.zip
Finally, KDE 2.2.2!! :o) Packages are masked for the first days, to make
sure they all work fine... So test test test! :o) Also contains a new version of KDevelop...
Diffstat (limited to 'kde-base/kdegraphics')
-rw-r--r--kde-base/kdegraphics/files/digest-kdegraphics-2.2.21
-rw-r--r--kde-base/kdegraphics/kdegraphics-2.2.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/kde-base/kdegraphics/files/digest-kdegraphics-2.2.2 b/kde-base/kdegraphics/files/digest-kdegraphics-2.2.2
new file mode 100644
index 000000000000..e0d35332256b
--- /dev/null
+++ b/kde-base/kdegraphics/files/digest-kdegraphics-2.2.2
@@ -0,0 +1 @@
+MD5 b9341505c6b9de8f018dd9d1896356e9 kdegraphics-2.2.2.tar.bz2 1650688
diff --git a/kde-base/kdegraphics/kdegraphics-2.2.2.ebuild b/kde-base/kdegraphics/kdegraphics-2.2.2.ebuild
new file mode 100644
index 000000000000..c2b56f339638
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-2.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-2.2.2.ebuild,v 1.1 2001/11/22 17:32:27 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Graphics"
+
+DEPEND="$DEPEND sys-devel/perl
+ media-gfx/sane-backends
+ tex? ( >=app-text/tetex-1.0.7 )
+ gphoto2? ( =media-gfx/gphoto-2.0_beta1 >=media-libs/libgpio-20010607 )"
+
+RDEPEND="$RDEPEND gphoto2? ( =media-gfx/gphoto-2.0_beta1 >=media-libs/libgpio-20010607 )"
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use gphoto2 && myconf="$myconf --with-gphoto2-includes=/usr/include/gphoto2 --with-gphoto2-libraries=/usr/lib/gphoto2" || myconf="$myconf --without-kamera"
+ use tex && myconf="$myconf --with-system-kpathsea --with-tex-datadir=/usr/share"
+ kde_src_compile configure make
+
+}
+
+