summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-02-09 16:21:25 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-02-09 16:21:25 +0000
commitb5482d971afcbe4aa81c1cea1b646b9158f52122 (patch)
tree28c13ff99d842033a1ebf8ca9f7d8146b086a448 /kde-base/kdegraphics
parentVersion bump. (diff)
downloadgentoo-2-b5482d971afcbe4aa81c1cea1b646b9158f52122.tar.gz
gentoo-2-b5482d971afcbe4aa81c1cea1b646b9158f52122.tar.bz2
gentoo-2-b5482d971afcbe4aa81c1cea1b646b9158f52122.zip
Version bump.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'kde-base/kdegraphics')
-rw-r--r--kde-base/kdegraphics/ChangeLog8
-rw-r--r--kde-base/kdegraphics/files/digest-kdegraphics-3.4.0_beta21
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.4.0_beta2.ebuild51
3 files changed, 59 insertions, 1 deletions
diff --git a/kde-base/kdegraphics/ChangeLog b/kde-base/kdegraphics/ChangeLog
index 955cf1322694..3c8143e62015 100644
--- a/kde-base/kdegraphics/ChangeLog
+++ b/kde-base/kdegraphics/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdegraphics
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/ChangeLog,v 1.153 2005/02/08 14:35:55 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/ChangeLog,v 1.154 2005/02/09 16:18:45 greg_g Exp $
+
+*kdegraphics-3.4.0_beta2 (09 Feb 2005)
+
+ 09 Feb 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +kdegraphics-3.4.0_beta2.ebuild:
+ Version bump.
08 Feb 2005; Gregorio Guidi <greg_g@gentoo.org>
-files/kdegraphics-3.2.2-gcc34-compile.patch,
diff --git a/kde-base/kdegraphics/files/digest-kdegraphics-3.4.0_beta2 b/kde-base/kdegraphics/files/digest-kdegraphics-3.4.0_beta2
new file mode 100644
index 000000000000..d99130579dbe
--- /dev/null
+++ b/kde-base/kdegraphics/files/digest-kdegraphics-3.4.0_beta2
@@ -0,0 +1 @@
+MD5 70270e2a8e7926001728986e33fd0d5c kdegraphics-3.3.92.tar.bz2 6521081
diff --git a/kde-base/kdegraphics/kdegraphics-3.4.0_beta2.ebuild b/kde-base/kdegraphics/kdegraphics-3.4.0_beta2.ebuild
new file mode 100644
index 000000000000..02a8ae159e0d
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.4.0_beta2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.4.0_beta2.ebuild,v 1.1 2005/02/09 16:18:45 greg_g Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE graphics-related apps"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="gphoto2 imlib opengl povray scanner tetex"
+
+DEPEND="~kde-base/kdebase-${PV}
+ gphoto2? ( media-gfx/gphoto2 )
+ scanner? ( media-gfx/sane-backends )
+ dev-libs/fribidi
+ imlib? ( media-libs/imlib )
+ virtual/ghostscript
+ media-libs/tiff
+ povray? ( media-gfx/povray
+ virtual/opengl )"
+
+RDEPEND="${DEPEND}
+ app-text/xpdf
+ tetex? (
+ || ( >=app-text/tetex-2
+ app-text/ptex
+ app-text/cstetex
+ app-text/dvipdfm )
+ )"
+
+src_unpack() {
+ kde_src_unpack
+
+ epatch ${FILESDIR}/CAN-2005-0064_kde-3.4.patch
+}
+
+src_compile() {
+ use gphoto2 \
+ && myconf="$myconf --with-kamera \
+ --with-gphoto2-includes=/usr/include/gphoto2 \
+ --with-gphoto2-libraries=/usr/lib/gphoto2" \
+ || myconf="$myconf --without-kamera"
+
+ use scanner || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kooka libkscan"
+
+ use imlib \
+ && myconf="$myconf --with-imlib --with-imlib-config=/usr/bin" \
+ || myconf="$myconf --without-imlib"
+
+ kde_src_compile
+}