summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-31 18:55:31 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-31 18:55:31 +0000
commit2be2083b387fb3daff54e1e7a9e79bd31e0c118a (patch)
tree345d1789f417557f0f6d12c8650940dbb57f05a9 /kde-base/kdenetwork
parentAdd patch to fix yet-again more ICQ protocol changes, see KDE BUG #130630. (diff)
downloadgentoo-2-2be2083b387fb3daff54e1e7a9e79bd31e0c118a.tar.gz
gentoo-2-2be2083b387fb3daff54e1e7a9e79bd31e0c118a.tar.bz2
gentoo-2-2be2083b387fb3daff54e1e7a9e79bd31e0c118a.zip
Add patch to fix yet-again more ICQ protocol changes, see KDE BUG #130630.
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'kde-base/kdenetwork')
-rw-r--r--kde-base/kdenetwork/ChangeLog9
-rw-r--r--kde-base/kdenetwork/files/digest-kdenetwork-3.5.3-r46
-rw-r--r--kde-base/kdenetwork/files/kopete-0.12.1-icqfix3.patch13
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.5.3-r4.ebuild92
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.5.4.ebuild5
5 files changed, 122 insertions, 3 deletions
diff --git a/kde-base/kdenetwork/ChangeLog b/kde-base/kdenetwork/ChangeLog
index 8354de6efdce..f7deea474ed4 100644
--- a/kde-base/kdenetwork/ChangeLog
+++ b/kde-base/kdenetwork/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kdenetwork
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.213 2006/07/26 08:37:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.214 2006/07/31 18:55:31 flameeyes Exp $
+
+*kdenetwork-3.5.3-r4 (31 Jul 2006)
+
+ 31 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kopete-0.12.1-icqfix3.patch, +kdenetwork-3.5.3-r4.ebuild,
+ kdenetwork-3.5.4.ebuild:
+ Add patch to fix yet-again more ICQ protocol changes, see KDE BUG #130630.
*kdenetwork-3.5.4 (26 Jul 2006)
*kdenetwork-3.5.3-r3 (26 Jul 2006)
diff --git a/kde-base/kdenetwork/files/digest-kdenetwork-3.5.3-r4 b/kde-base/kdenetwork/files/digest-kdenetwork-3.5.3-r4
new file mode 100644
index 000000000000..0d9cb09f0130
--- /dev/null
+++ b/kde-base/kdenetwork/files/digest-kdenetwork-3.5.3-r4
@@ -0,0 +1,6 @@
+MD5 07d313f91154d3c2f4620b921277fdc8 kdenetwork-3.5-patchset-01.tar.bz2 2986
+RMD160 288113734e7767a7526f4b9311c1985ac8aa91bf kdenetwork-3.5-patchset-01.tar.bz2 2986
+SHA256 0bbde1adaa4e8fff02c1f1fd6ceb66ec9af14dd19ff64567ab0fd03926d7d05b kdenetwork-3.5-patchset-01.tar.bz2 2986
+MD5 119af91a048c34d9a917a1898f215554 kdenetwork-3.5.3.tar.bz2 7524718
+RMD160 0c57f39652946c577ad0d6ec7f4fc593fe38a0bc kdenetwork-3.5.3.tar.bz2 7524718
+SHA256 f0323e33226b30ca30bfee05a9b6da8a1de964c9593d134294f83a54db0f4f3c kdenetwork-3.5.3.tar.bz2 7524718
diff --git a/kde-base/kdenetwork/files/kopete-0.12.1-icqfix3.patch b/kde-base/kdenetwork/files/kopete-0.12.1-icqfix3.patch
new file mode 100644
index 000000000000..ac786297eb5e
--- /dev/null
+++ b/kde-base/kdenetwork/files/kopete-0.12.1-icqfix3.patch
@@ -0,0 +1,13 @@
+Index: kopete/protocols/oscar/liboscar/oscartypes.h
+===================================================================
+--- kopete/protocols/oscar/liboscar/oscartypes.h (revision 568242)
++++ kopete/protocols/oscar/liboscar/oscartypes.h (revision 568243)
+@@ -239,7 +239,7 @@
+ const WORD ICQ_MAJOR = 0x0014;
+ const WORD ICQ_MINOR = 0x0034;
+ const WORD ICQ_POINT = 0x0000;
+- const WORD ICQ_BUILD = 0x0A0F;
++ const WORD ICQ_BUILD = 0x0BB8;
+ const char ICQ_OTHER[] = { 0x00, 0x00, 0x04, 0x3d };
+ const char ICQ_COUNTRY[] = "us";
+ const char ICQ_LANG[] = "en";
diff --git a/kde-base/kdenetwork/kdenetwork-3.5.3-r4.ebuild b/kde-base/kdenetwork/kdenetwork-3.5.3-r4.ebuild
new file mode 100644
index 000000000000..b9080f7b1502
--- /dev/null
+++ b/kde-base/kdenetwork/kdenetwork-3.5.3-r4.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.3-r4.ebuild,v 1.1 2006/07/31 18:55:31 flameeyes Exp $
+
+inherit kde-dist eutils flag-o-matic
+
+DESCRIPTION="KDE network applications: Kopete, KPPP, KGet,..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="rdesktop sametime slp ssl wifi xmms"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
+
+BOTH_DEPEND="~kde-base/kdebase-${PV}
+ dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ sametime? ( =net-libs/meanwhile-0.4* )
+ xmms? ( media-sound/xmms )
+ slp? ( net-libs/openslp )
+ wifi? ( net-wireless/wireless-tools )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ ) <virtual/x11-7 )
+ kernel_linux? ( virtual/opengl )"
+
+RDEPEND="${BOTH_DEPEND}
+ rdesktop? ( >=net-misc/rdesktop-1.4.1 )
+ dev-lang/perl
+ ssl? ( dev-perl/IO-Socket-SSL
+ app-crypt/qca-tls )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ || ( (
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ kernel_linux? ( x11-libs/libXv )
+ x11-proto/scrnsaverproto
+ ) <virtual/x11-7 )
+ dev-util/pkgconfig"
+
+PATCHES="${FILESDIR}/kopete-3.5.3-icqfix.patch
+ ${FILESDIR}/kopete-3.5.x-oscarcontacts.patch
+ ${FILESDIR}/kopete-0.12.1-icqfix3.patch"
+
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
+src_compile() {
+ export BINDNOW_FLAGS="$(bindnow-flags)"
+
+ local myconf="--with-libidn
+ $(use_enable sametime sametime-plugin)
+ $(use_enable slp) $(use_with wifi)
+ $(use_with xmms) --without-external-libgadu"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ chmod u+s "${D}/${KDEDIR}/bin/reslisa"
+
+ # empty config file needed for lisa to work with default settings
+ dodir /etc
+ touch "${D}/etc/lisarc"
+
+ # lisa, reslisa initscripts
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" "${WORKDIR}/patches/lisa" > "${T}/lisa"
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" "${WORKDIR}/patches/reslisa" > "${T}/reslisa"
+ exeinto /etc/init.d
+ doexe "${T}/lisa" "${T}/reslisa"
+
+ insinto /etc/conf.d
+ newins "${WORKDIR}/patches/lisa.conf" lisa
+ newins "${WORKDIR}/patches/reslisa.conf" reslisa
+}
diff --git a/kde-base/kdenetwork/kdenetwork-3.5.4.ebuild b/kde-base/kdenetwork/kdenetwork-3.5.4.ebuild
index 66733ee40e63..1ec15cf36faf 100644
--- a/kde-base/kdenetwork/kdenetwork-3.5.4.ebuild
+++ b/kde-base/kdenetwork/kdenetwork-3.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.4.ebuild,v 1.1 2006/07/26 08:37:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.4.ebuild,v 1.2 2006/07/31 18:55:31 flameeyes Exp $
inherit kde-dist eutils flag-o-matic
@@ -47,7 +47,8 @@ DEPEND="${BOTH_DEPEND}
) <virtual/x11-7 )
dev-util/pkgconfig"
-PATCHES="${FILESDIR}/kopete-3.5.x-oscarcontacts.patch"
+PATCHES="${FILESDIR}/kopete-3.5.x-oscarcontacts.patch
+ ${FILESDIR}/kopete-0.12.1-icqfix3.patch"
pkg_setup() {
if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then