summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-04 19:14:09 +0000
committerJohannes Huber <johu@gentoo.org>2014-03-04 19:14:09 +0000
commitb635da4d6a5d3adc02954e54eac873b1ccef912d (patch)
tree20c5621fa841bba0ea00b22c0f7164dbce35a9b2 /kde-base/kdepim-runtime
parentAdd missing DEPEND. #501740 (diff)
downloadgentoo-2-b635da4d6a5d3adc02954e54eac873b1ccef912d.tar.gz
gentoo-2-b635da4d6a5d3adc02954e54eac873b1ccef912d.tar.bz2
gentoo-2-b635da4d6a5d3adc02954e54eac873b1ccef912d.zip
Version bump KDE SC 4.12.3
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kdepim-runtime')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog7
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.12.3.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index ac1ef45e8b0d..4c6e22c5bfa7 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.189 2014/02/23 10:01:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.190 2014/03/04 19:13:35 johu Exp $
+
+*kdepim-runtime-4.12.3 (04 Mar 2014)
+
+ 04 Mar 2014; Johannes Huber <johu@gentoo.org> +kdepim-runtime-4.12.3.ebuild:
+ Version bump KDE SC 4.12.3
23 Feb 2014; Agostino Sarubbo <ago@gentoo.org>
-kdepim-runtime-4.11.2-r1.ebuild:
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.12.3.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.12.3.ebuild
new file mode 100644
index 000000000000..487b47d01a31
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.12.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.12.3.ebuild,v 1.1 2014/03/04 19:13:35 johu Exp $
+
+EAPI=5
+
+KMNAME="kdepim-runtime"
+inherit kde4-base
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug facebook google kolab"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs, see bug 313233
+
+DEPEND="
+ app-misc/strigi
+ >=app-office/akonadi-server-1.10.43
+ dev-libs/boost:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-libs/shared-desktop-ontologies-0.11.0
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+ facebook? ( net-libs/libkfbapi )
+ google? ( >=net-libs/libkgapi-2.0 )
+ kolab? ( net-libs/libkolab )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+ !kde-misc/akonadi-google
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package facebook LibKFbAPI)
+ $(cmake-utils_use_find_package google LibKGAPI2)
+ $(cmake-utils_use_find_package kolab Libkolab)
+ $(cmake-utils_use_find_package kolab Libkolabxml)
+ )
+
+ kde4-base_src_configure
+}