summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-03 20:59:18 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-03 20:59:18 +0000
commitdda9955f6a8009b71661059b51b7070dad49d25f (patch)
tree92bd015eee4003210c60080c1743cb184c6bc92d /kde-base/kdepimlibs
parentVersion bump to KDE 4.0.3. This is still not intended for mainstream so DO NO... (diff)
downloadgentoo-2-dda9955f6a8009b71661059b51b7070dad49d25f.tar.gz
gentoo-2-dda9955f6a8009b71661059b51b7070dad49d25f.tar.bz2
gentoo-2-dda9955f6a8009b71661059b51b7070dad49d25f.zip
Version bump to KDE 4.0.3. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog9
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.0.3.ebuild33
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 73e71d6da0ed..1fb36f24ebb2 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.8 2008/03/20 16:51:00 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.9 2008/04/03 20:59:18 philantrop Exp $
+
+*kdepimlibs-4.0.3 (03 Apr 2008)
+
+ 03 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kdepimlibs-4.0.3.ebuild:
+ Version bump to KDE 4.0.3. This is still not intended for mainstream so DO
+ NOT KEYWORD IT without talking to the KDE herd first.
20 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-kdepimlibs-4.0.1.ebuild:
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.0.3.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.0.3.ebuild
new file mode 100644
index 000000000000..596b9679588e
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.0.3.ebuild,v 1.1 2008/04/03 20:59:18 philantrop Exp $
+
+EAPI="1"
+
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook ldap sasl"
+LICENSE="GPL-2 LGPL-2"
+
+# Tests last checked in 4.0.3. Over 50% fails. A lot hang.
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ dev-libs/boost
+ dev-libs/libgpg-error
+ ldap? ( >=net-nds/openldap-2 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with ldap Ldap)
+ $(cmake-utils_use_with sasl Sasl2)"
+ kde4-base_src_compile
+}