summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-11-02 20:48:23 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-11-02 20:48:23 +0000
commit07a5746d946658a2d5d39b2008bdad2d2b2e127c (patch)
treea949b9dad962aee8c01f5011d077283fc50836d4 /kde-base/kinfocenter/kinfocenter-4.7.3.ebuild
parent[profiles/arch/powerpc] Update kde mask (diff)
downloadgentoo-2-07a5746d946658a2d5d39b2008bdad2d2b2e127c.tar.gz
gentoo-2-07a5746d946658a2d5d39b2008bdad2d2b2e127c.tar.bz2
gentoo-2-07a5746d946658a2d5d39b2008bdad2d2b2e127c.zip
[kde-base] KDE SC 4.7.3
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kinfocenter/kinfocenter-4.7.3.ebuild')
-rw-r--r--kde-base/kinfocenter/kinfocenter-4.7.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/kinfocenter/kinfocenter-4.7.3.ebuild b/kde-base/kinfocenter/kinfocenter-4.7.3.ebuild
new file mode 100644
index 000000000000..ded92a444ede
--- /dev/null
+++ b/kde-base/kinfocenter/kinfocenter-4.7.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kinfocenter/kinfocenter-4.7.3.ebuild,v 1.1 2011/11/02 20:47:56 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="The KDE Info Center"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug ieee1394"
+
+DEPEND="
+ $(add_kdebase_dep solid)
+ sys-apps/pciutils
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ virtual/glu
+ virtual/opengl
+ )
+"
+RDEPEND="${DEPEND}
+ sys-apps/usbutils
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with ieee1394 RAW1394)
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-meta_src_configure
+}