summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-01-25 23:01:57 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-01-25 23:01:57 +0000
commit9c89d6f0f6bb15225ab0f1fdfaeb15bf03d869fd (patch)
tree465fc1d3a40ded71865b78bd6515325315a567c4 /kde-base/kmail/files
parentVersion bump (diff)
downloadgentoo-2-9c89d6f0f6bb15225ab0f1fdfaeb15bf03d869fd.tar.gz
gentoo-2-9c89d6f0f6bb15225ab0f1fdfaeb15bf03d869fd.tar.bz2
gentoo-2-9c89d6f0f6bb15225ab0f1fdfaeb15bf03d869fd.zip
Removed even more dysfunctional tests
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kmail/files')
-rw-r--r--kde-base/kmail/files/kmail-4.4.9-nodbus.patch76
1 files changed, 74 insertions, 2 deletions
diff --git a/kde-base/kmail/files/kmail-4.4.9-nodbus.patch b/kde-base/kmail/files/kmail-4.4.9-nodbus.patch
index f546162c5a4d..af3237def53b 100644
--- a/kde-base/kmail/files/kmail-4.4.9-nodbus.patch
+++ b/kde-base/kmail/files/kmail-4.4.9-nodbus.patch
@@ -1,6 +1,32 @@
+diff -ruN kmail-4.4.9.orig/kmail/tests/CMakeLists.txt kmail-4.4.9/kmail/tests/CMakeLists.txt
+--- kmail-4.4.9.orig/kmail/tests/CMakeLists.txt 2010-12-22 18:52:24.000000000 +0100
++++ kmail-4.4.9/kmail/tests/CMakeLists.txt 2011-01-25 23:52:38.953021223 +0100
+@@ -9,14 +9,14 @@
+ add_definitions(-DKMAIL_UNITTESTS=YES)
+
+ ########### htmlquotecolorertest ###############
+-set(htmlquotecolorertest_SRCS htmlquotecolorertest.cpp ../htmlquotecolorer.cpp)
+-kde4_add_unit_test(htmlquotecolorertest TESTNAME kmail-quotecolorertest ${htmlquotecolorertest_SRCS})
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${KDE4_ENABLE_EXCEPTIONS}")
+-target_link_libraries(htmlquotecolorertest
+- ${QT_QTTEST_LIBRARY}
+- ${QT_QTCORE_LIBRARY}
+- ${KDE4_KHTML_LIBRARY}
+-)
++# set(htmlquotecolorertest_SRCS htmlquotecolorertest.cpp ../htmlquotecolorer.cpp)
++# kde4_add_unit_test(htmlquotecolorertest TESTNAME kmail-quotecolorertest ${htmlquotecolorertest_SRCS})
++# set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${KDE4_ENABLE_EXCEPTIONS}")
++# target_link_libraries(htmlquotecolorertest
++# ${QT_QTTEST_LIBRARY}
++# ${QT_QTCORE_LIBRARY}
++# ${KDE4_KHTML_LIBRARY}
++# )
+
+ ########### utiltests ###############
+
diff -ruN kmail-4.4.9.orig/messagecore/tests/CMakeLists.txt kmail-4.4.9/messagecore/tests/CMakeLists.txt
--- kmail-4.4.9.orig/messagecore/tests/CMakeLists.txt 2010-12-22 18:52:15.000000000 +0100
-+++ kmail-4.4.9/messagecore/tests/CMakeLists.txt 2011-01-23 23:22:36.000000000 +0100
++++ kmail-4.4.9/messagecore/tests/CMakeLists.txt 2011-01-25 23:50:54.421021223 +0100
@@ -13,6 +13,6 @@
# Attachment tests.
add_messagecore_test( attachmentcompressjobtest.cpp )
@@ -8,4 +34,50 @@ diff -ruN kmail-4.4.9.orig/messagecore/tests/CMakeLists.txt kmail-4.4.9/messagec
-add_messagecore_test( attachmentfromurljobtest.cpp )
+# add_messagecore_test( attachmentfromurljobtest.cpp )
add_messagecore_test( attachmentparttest.cpp )
- add_messagecore_test( attachmentpropertiesdialogtest.cpp )
+-add_messagecore_test( attachmentpropertiesdialogtest.cpp )
++# add_messagecore_test( attachmentpropertiesdialogtest.cpp )
+diff -ruN kmail-4.4.9.orig/messageviewer/tests/CMakeLists.txt kmail-4.4.9/messageviewer/tests/CMakeLists.txt
+--- kmail-4.4.9.orig/messageviewer/tests/CMakeLists.txt 2010-12-22 18:52:47.000000000 +0100
++++ kmail-4.4.9/messageviewer/tests/CMakeLists.txt 2011-01-25 23:51:58.374021223 +0100
+@@ -6,23 +6,23 @@
+ )
+
+ ########### htmlquotecolorertest ###############
+-set(messageviewer_htmlquotecolorertest_SRCS htmlquotecolorertest.cpp ../htmlquotecolorer.cpp)
+-kde4_add_unit_test(messageviewer_htmlquotecolorertest TESTNAME messageviewer-quotecolorertest ${messageviewer_htmlquotecolorertest_SRCS})
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${KDE4_ENABLE_EXCEPTIONS}")
+-target_link_libraries(messageviewer_htmlquotecolorertest
+- ${QT_QTTEST_LIBRARY}
+- ${QT_QTCORE_LIBRARY}
+- ${KDE4_KHTML_LIBRARY}
+- messageviewer
+-)
++# set(messageviewer_htmlquotecolorertest_SRCS htmlquotecolorertest.cpp ../htmlquotecolorer.cpp)
++# kde4_add_unit_test(messageviewer_htmlquotecolorertest TESTNAME messageviewer-quotecolorertest ${messageviewer_htmlquotecolorertest_SRCS})
++# set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${KDE4_ENABLE_EXCEPTIONS}")
++# target_link_libraries(messageviewer_htmlquotecolorertest
++# ${QT_QTTEST_LIBRARY}
++# ${QT_QTCORE_LIBRARY}
++# ${KDE4_KHTML_LIBRARY}
++# messageviewer
++# )
+
+ ########### stringutiltest ###############
+-set(stringutiltest_SRCS stringutiltest.cpp)
+-kde4_add_unit_test(stringutiltest TESTNAME messageviewer-stringutiltest ${stringutiltest_SRCS})
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${KDE4_ENABLE_EXCEPTIONS}")
+-target_link_libraries(stringutiltest
+- ${QT_QTTEST_LIBRARY}
+- ${QT_QTCORE_LIBRARY}
+- ${KDE4_KHTML_LIBRARY}
+- messageviewer
+-)
++# set(stringutiltest_SRCS stringutiltest.cpp)
++# kde4_add_unit_test(stringutiltest TESTNAME messageviewer-stringutiltest ${stringutiltest_SRCS})
++# set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${KDE4_ENABLE_EXCEPTIONS}")
++# target_link_libraries(stringutiltest
++# ${QT_QTTEST_LIBRARY}
++# ${QT_QTCORE_LIBRARY}
++# ${KDE4_KHTML_LIBRARY}
++# messageviewer
++# )