summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-31 19:35:04 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-31 19:35:04 +0000
commit209ffe5090195322b4a3b620a6a9b3c43bd67453 (patch)
tree2609708a0f1d976047d3ad949ddf2a84fa55cc91 /kde-base/kopete
parentRevision bump, we're at 2.6.19_rc4. (diff)
downloadgentoo-2-209ffe5090195322b4a3b620a6a9b3c43bd67453.tar.gz
gentoo-2-209ffe5090195322b4a3b620a6a9b3c43bd67453.tar.bz2
gentoo-2-209ffe5090195322b4a3b620a6a9b3c43bd67453.zip
Add patch for KDE bug #136566.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/ChangeLog8
-rw-r--r--kde-base/kopete/files/digest-kopete-3.5.5-r26
-rw-r--r--kde-base/kopete/files/kopete-3.5.5-icqfix.patch12
-rw-r--r--kde-base/kopete/kopete-3.5.5-r2.ebuild128
4 files changed, 153 insertions, 1 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index f5aa3941a3c8..862c20ad3d0c 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.87 2006/10/27 13:55:23 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.88 2006/10/31 19:35:04 flameeyes Exp $
+
+*kopete-3.5.5-r2 (31 Oct 2006)
+
+ 31 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kopete-3.5.5-icqfix.patch, +kopete-3.5.5-r2.ebuild:
+ Add patch for KDE bug #136566.
27 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> kopete-3.5.5-r1.ebuild:
Allow installing kopete with 3.5.0 kdelibs.
diff --git a/kde-base/kopete/files/digest-kopete-3.5.5-r2 b/kde-base/kopete/files/digest-kopete-3.5.5-r2
new file mode 100644
index 000000000000..e013575200c5
--- /dev/null
+++ b/kde-base/kopete/files/digest-kopete-3.5.5-r2
@@ -0,0 +1,6 @@
+MD5 07d313f91154d3c2f4620b921277fdc8 kdenetwork-3.5-patchset-01.tar.bz2 2986
+RMD160 288113734e7767a7526f4b9311c1985ac8aa91bf kdenetwork-3.5-patchset-01.tar.bz2 2986
+SHA256 0bbde1adaa4e8fff02c1f1fd6ceb66ec9af14dd19ff64567ab0fd03926d7d05b kdenetwork-3.5-patchset-01.tar.bz2 2986
+MD5 a6e642c070cbd50d4a817f6588bf8e46 kdenetwork-3.5.5.tar.bz2 9235564
+RMD160 3e757d10ee5bf24b2ccf131e693fb614b9fdb9f4 kdenetwork-3.5.5.tar.bz2 9235564
+SHA256 c3f36e69bbd23902f2bdd9a1a8cda93b0436338ada422bb8ac6bc3d2bcd8e38f kdenetwork-3.5.5.tar.bz2 9235564
diff --git a/kde-base/kopete/files/kopete-3.5.5-icqfix.patch b/kde-base/kopete/files/kopete-3.5.5-icqfix.patch
new file mode 100644
index 000000000000..4aa3f2759c14
--- /dev/null
+++ b/kde-base/kopete/files/kopete-3.5.5-icqfix.patch
@@ -0,0 +1,12 @@
+Index: kdenetwork-3.5.5/kopete/protocols/oscar/liboscar/client.cpp
+===================================================================
+--- kdenetwork-3.5.5.orig/kopete/protocols/oscar/liboscar/client.cpp
++++ kdenetwork-3.5.5/kopete/protocols/oscar/liboscar/client.cpp
+@@ -340,6 +340,7 @@ void Client::lt_loginFinished()
+ //we've finished logging in. start the services setup
+ kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "stage two done. setting up services" << endl;
+ initializeStaticTasks();
++ d->ownStatusTask->go();
+ ServiceSetupTask* ssTask = new ServiceSetupTask( d->connections.defaultConnection()->rootTask() );
+ connect( ssTask, SIGNAL( finished() ), this, SLOT( serviceSetupFinished() ) );
+ ssTask->go( true ); //fire and forget
diff --git a/kde-base/kopete/kopete-3.5.5-r2.ebuild b/kde-base/kopete/kopete-3.5.5-r2.ebuild
new file mode 100644
index 000000000000..afbfbadf634b
--- /dev/null
+++ b/kde-base/kopete/kopete-3.5.5-r2.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5.5-r2.ebuild,v 1.1 2006/10/31 19:35:04 flameeyes Exp $
+
+KMNAME=kdenetwork
+MAXKDEVER=$PV
+KM_DEPRANGE="3.5.0 $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="http://kopete.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="jingle sametime ssl xmms xscreensaver slp kernel_linux latex crypt
+ winpopup sms irc yahoo gadu groupwise netmeeting statistics autoreplace
+ connectionstatus contactnotes translator webpresence texteffect highlight
+ alias autoreplace history nowlistening addbookmarks"
+
+# The kernel_linux? ( ) conditional dependencies are for webcams, not supported
+# on other kernels AFAIK
+BOTH_DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ sametime? ( =net-libs/meanwhile-0.4* )
+ xmms? ( media-sound/xmms )
+ jingle? (
+ >=media-libs/speex-1.1.6
+ dev-libs/expat
+ ~net-libs/ortp-0.7.1 )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ ) <virtual/x11-7 )
+ kernel_linux? ( virtual/opengl )
+ sms? ( app-mobilephone/gsmlib )"
+
+RDEPEND="${BOTH_DEPEND}
+ ssl? ( app-crypt/qca-tls )
+ !kde-base/kopete
+ !kde-base/kdenetwork
+ latex? ( virtual/tetex
+ media-gfx/imagemagick )
+ crypt? ( app-crypt/gnupg )"
+# gnomemeeting is deprecated and ekiga is not yet ~ppc64
+# only needed for calling
+# netmeeting? ( net-im/gnomemeeting )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ || ( (
+ x11-proto/videoproto
+ kernel_linux? ( x11-libs/libXv )
+ xscreensaver? ( x11-proto/scrnsaverproto )
+ ) <virtual/x11-7 )"
+
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
+kopete_disable() {
+ einfo "Disabling $2 $1"
+ sed -i -e "s/$2//" "${S}/kopete/$1s/Makefile.am"
+}
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ epatch "${FILESDIR}/kopete-0.12_alpha1-xscreensaver.patch"
+ # use ekiga instead of gnomemeeting by default
+ epatch "${FILESDIR}/gnomemeeting-ekiga.patch"
+
+ epatch "${FILESDIR}/${P}-icqfix.patch"
+
+ use latex || kopete_disable plugin latex
+ use crypt || kopete_disable plugin cryptography
+ use netmeeting || kopete_disable plugin netmeeting
+ use statistics || kopete_disable plugin statistics
+ use autoreplace || kopete_disable plugin autoreplace
+ use connectionstatus || kopete_disable plugin connectionstatus
+ use contactnotes || kopete_disable plugin contactnotes
+ use translator || kopete_disable plugin translator
+ use webpresence || kopete_disable plugin webpresence
+ use texteffect || kopete_disable plugin texteffect
+ use highlight || kopete_disable plugin highlight
+ use alias || kopete_disable plugin alias
+ use addbookmarks || kopete_disable plugin addbookmarks
+ use history || kopete_disable plugin history
+ use nowlistening || kopete_disable plugin nowlistening
+
+ use winpopup || kopete_disable protocol winpopup
+ use gadu || kopete_disable protocol '\$(GADU)'
+ use irc || kopete_disable protocol irc
+ use groupwise || kopete_disable protocol groupwise
+ use yahoo || kopete_disable protocol yahoo
+
+ rm -f "${S}/configure"
+}
+
+src_compile() {
+ # External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
+ # Maybe we can enable it in the future.
+ # The nowlistening plugin has xmms support.
+ local myconf="$(use_enable jingle)
+ $(use_enable sametime sametime-plugin)
+ $(use_with xmms) --without-external-libgadu
+ $(use_with xscreensaver) $(use_enable sms smsgsm)
+ $(use_enable debug testbed)"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ rm -f "${D}${KDEDIR}"/bin/{stun,relay}server
+}