summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-22 12:59:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-22 12:59:48 +0000
commit810e34ac5b677fafdafe81ce55acdff8d91eda33 (patch)
treed112372fbfbd90d9514bf9052d6f9d9a67ed89e1 /kde-base/ksim
parentMove myconf population in src_compile rather than global scope. (diff)
downloadgentoo-2-810e34ac5b677fafdafe81ce55acdff8d91eda33.tar.gz
gentoo-2-810e34ac5b677fafdafe81ce55acdff8d91eda33.tar.bz2
gentoo-2-810e34ac5b677fafdafe81ce55acdff8d91eda33.zip
Move myconf population in src_compile rather than global scope.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'kde-base/ksim')
-rw-r--r--kde-base/ksim/ChangeLog6
-rw-r--r--kde-base/ksim/ksim-3.4.3.ebuild8
-rw-r--r--kde-base/ksim/ksim-3.5.2.ebuild11
-rw-r--r--kde-base/ksim/ksim-3.5.3.ebuild11
4 files changed, 25 insertions, 11 deletions
diff --git a/kde-base/ksim/ChangeLog b/kde-base/ksim/ChangeLog
index 7324aa773419..cef76741eeb8 100644
--- a/kde-base/ksim/ChangeLog
+++ b/kde-base/ksim/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/ksim
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksim/ChangeLog,v 1.52 2006/06/01 19:52:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksim/ChangeLog,v 1.53 2006/06/22 12:59:48 flameeyes Exp $
+
+ 22 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> ksim-3.4.3.ebuild,
+ ksim-3.5.2.ebuild, ksim-3.5.3.ebuild:
+ Move myconf population in src_compile rather than global scope.
*ksim-3.5.3 (01 Jun 2006)
diff --git a/kde-base/ksim/ksim-3.4.3.ebuild b/kde-base/ksim/ksim-3.4.3.ebuild
index 75fec1dda91c..d8ef1c2cfbf3 100644
--- a/kde-base/ksim/ksim-3.4.3.ebuild
+++ b/kde-base/ksim/ksim-3.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksim/ksim-3.4.3.ebuild,v 1.8 2006/03/24 23:50:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksim/ksim-3.4.3.ebuild,v 1.9 2006/06/22 12:59:48 flameeyes Exp $
KMNAME=kdeutils
MAXKDEVER=$PV
@@ -13,4 +13,8 @@ IUSE="snmp"
DEPEND="snmp? ( net-analyzer/net-snmp )"
PATCHES="$FILESDIR/configure-fix-kdeutils-snmp.patch"
-myconf="$myconf $(use_with snmp)"
+
+src_compile() {
+ myconf="$myconf $(use_with snmp)"
+ kde-meta_src_compile
+}
diff --git a/kde-base/ksim/ksim-3.5.2.ebuild b/kde-base/ksim/ksim-3.5.2.ebuild
index b75c70c9823d..c4bea4b5feba 100644
--- a/kde-base/ksim/ksim-3.5.2.ebuild
+++ b/kde-base/ksim/ksim-3.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksim/ksim-3.5.2.ebuild,v 1.10 2006/06/01 10:17:57 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksim/ksim-3.5.2.ebuild,v 1.11 2006/06/22 12:59:48 flameeyes Exp $
KMNAME=kdeutils
MAXKDEVER=$PV
@@ -12,9 +12,12 @@ KEYWORDS="alpha amd64 ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="snmp"
DEPEND="snmp? ( net-analyzer/net-snmp )"
-myconf="$myconf $(use_with snmp)"
-
src_unpack() {
kde-meta_src_unpack
sed -i -e "s:Hidden=true:Hidden=false:" ksim/ksim.desktop
-} \ No newline at end of file
+}
+
+src_compile() {
+ myconf="$myconf $(use_with snmp)"
+ kde-meta_src_compile
+}
diff --git a/kde-base/ksim/ksim-3.5.3.ebuild b/kde-base/ksim/ksim-3.5.3.ebuild
index 6ea7139092ae..5e9ceef6e085 100644
--- a/kde-base/ksim/ksim-3.5.3.ebuild
+++ b/kde-base/ksim/ksim-3.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksim/ksim-3.5.3.ebuild,v 1.1 2006/06/01 19:52:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksim/ksim-3.5.3.ebuild,v 1.2 2006/06/22 12:59:48 flameeyes Exp $
KMNAME=kdeutils
MAXKDEVER=$PV
@@ -12,9 +12,12 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="snmp"
DEPEND="snmp? ( net-analyzer/net-snmp )"
-myconf="$myconf $(use_with snmp)"
-
src_unpack() {
kde-meta_src_unpack
sed -i -e "s:Hidden=true:Hidden=false:" ksim/ksim.desktop
-} \ No newline at end of file
+}
+
+src_compile() {
+ myconf="$myconf $(use_with snmp)"
+ kde-meta_src_compile
+}