summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-11-09 01:26:11 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-11-09 01:26:11 +0000
commit31b1713d673a74f620886448235eaf0888c49061 (patch)
treee2e12df677c7dbe49076f81f84fad3f15476d3c7 /kde-base/ksplash
parentFull auto: Version bump for KDE-4.1.3 (diff)
downloadgentoo-2-31b1713d673a74f620886448235eaf0888c49061.tar.gz
gentoo-2-31b1713d673a74f620886448235eaf0888c49061.tar.bz2
gentoo-2-31b1713d673a74f620886448235eaf0888c49061.zip
Full auto: Version bump for KDE-4.1.3
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.1.3.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index f8ead33ed1e7..a268b11f5fb6 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.12 2008/10/21 11:21:21 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.13 2008/11/09 01:26:11 scarabeus Exp $
+
+*ksplash-4.1.3 (08 Nov 2008)
+
+ 08 Nov 2008; Tomas Chvatal <scarabeus@gentoo.org> +ksplash-4.1.3.ebuild:
+ Version bump.
21 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
-ksplash-4.0.4.ebuild, -ksplash-4.0.5.ebuild:
diff --git a/kde-base/ksplash/ksplash-4.1.3.ebuild b/kde-base/ksplash/ksplash-4.1.3.ebuild
new file mode 100644
index 000000000000..8d15e33d70c2
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.1.3.ebuild,v 1.1 2008/11/09 01:26:11 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME=kdebase-workspace
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~x86"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+RDEPEND="media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_has 3dnow X86_3DNOW)
+ $(cmake-utils_has altivec PPC_ALTIVEC)
+ $(cmake-utils_has mmx X86_MMX)
+ $(cmake-utils_has sse X86_SSE)
+ $(cmake-utils_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_configure
+}