summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-11 23:49:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-11 23:49:11 +0000
commitfb00b307e1fa3e99f7349f231891b1447a22b6d3 (patch)
tree20b05b666f879e7e43beba15aab37c22532e0a61 /kde-base/ksplashml
parentdev-lisp/abcl:cmucl - Build Armed Bear Common Lisp using CMU Common Lisp (diff)
downloadgentoo-2-fb00b307e1fa3e99f7349f231891b1447a22b6d3.tar.gz
gentoo-2-fb00b307e1fa3e99f7349f231891b1447a22b6d3.tar.bz2
gentoo-2-fb00b307e1fa3e99f7349f231891b1447a22b6d3.zip
Added patch to disable xinerama support from ksplashml.
(Portage version: 2529-svn)
Diffstat (limited to 'kde-base/ksplashml')
-rw-r--r--kde-base/ksplashml/ChangeLog8
-rw-r--r--kde-base/ksplashml/files/ksplashml-3.5.0-xinerama.patch32
-rw-r--r--kde-base/ksplashml/ksplashml-3.5.0.ebuild19
3 files changed, 54 insertions, 5 deletions
diff --git a/kde-base/ksplashml/ChangeLog b/kde-base/ksplashml/ChangeLog
index fad190321a46..d45c896ffe4a 100644
--- a/kde-base/ksplashml/ChangeLog
+++ b/kde-base/ksplashml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/ksplashml
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplashml/ChangeLog,v 1.34 2005/12/17 10:23:15 corsair Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplashml/ChangeLog,v 1.35 2006/01/11 23:49:11 flameeyes Exp $
+
+ 11 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/ksplashml-3.5.0-xinerama.patch, ksplashml-3.5.0.ebuild:
+ Added patch to disable xinerama support from ksplashml.
17 Dec 2005; Markus Rothe <corsair@gentoo.org> ksplashml-3.5.0.ebuild:
Added ~ppc64
diff --git a/kde-base/ksplashml/files/ksplashml-3.5.0-xinerama.patch b/kde-base/ksplashml/files/ksplashml-3.5.0-xinerama.patch
new file mode 100644
index 000000000000..4b824247e89b
--- /dev/null
+++ b/kde-base/ksplashml/files/ksplashml-3.5.0-xinerama.patch
@@ -0,0 +1,32 @@
+Index: kdebase-3.5.0/ksplashml/themeengine/simple/configure.in.in
+===================================================================
+--- kdebase-3.5.0/ksplashml/themeengine/simple/configure.in.in (revision 497108)
++++ kdebase-3.5.0/ksplashml/themeengine/simple/configure.in.in (working copy)
+@@ -1,9 +1,13 @@
+-xinerama_save_ldflags="$LDFLAGS"
+-LDFLAGS="$X_LDFLAGS"
+-
+ LIB_XINERAMA=
+
+-KDE_CHECK_HEADER(X11/extensions/Xinerama.h,
++AC_ARG_WITH([xinerama],
++ AS_HELP_STRING([--without-xinerama], [Disable xinerama extension support (default: check)]) )
++
++if test "x$with_xinerama" != "xno"; then
++ xinerama_save_ldflags="$LDFLAGS"
++ LDFLAGS="$X_LDFLAGS"
++
++ KDE_CHECK_HEADER(X11/extensions/Xinerama.h,
+ [
+ AC_CHECK_LIB(Xinerama,XineramaQueryExtension,
+ [
+@@ -17,5 +21,7 @@
+ #include <X11/Xlib.h>
+ ] )
+
+-AC_SUBST(LIB_XINERAMA)
+-LDFLAGS="$xinerama_save_ldflags"
++ AC_SUBST(LIB_XINERAMA)
++ LDFLAGS="$xinerama_save_ldflags"
++fi
++
diff --git a/kde-base/ksplashml/ksplashml-3.5.0.ebuild b/kde-base/ksplashml/ksplashml-3.5.0.ebuild
index b0707ac7eaf5..e985d5460ab3 100644
--- a/kde-base/ksplashml/ksplashml-3.5.0.ebuild
+++ b/kde-base/ksplashml/ksplashml-3.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplashml/ksplashml-3.5.0.ebuild,v 1.4 2005/12/17 10:23:15 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplashml/ksplashml-3.5.0.ebuild,v 1.5 2006/01/11 23:49:11 flameeyes Exp $
KMNAME=kdebase
MAXKDEVER=$PV
@@ -9,5 +9,18 @@ inherit kde-meta eutils
DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="xinerama"
+
+RDEPEND="xinerama? ( || ( x11-libs/libXinerama virtual/x11 ) )"
+
+DEPEND="${RDEPEND}
+ xinerama? ( || ( x11-proto/xineramaproto virtual/x11 ) )"
+
+PATCHES="${FILESDIR}/${P}-xinerama.patch"
+
+src_compile() {
+ myconf="${myconf} $(use_with xinerama)"
+
+ kde-meta_src_compile
+}