summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
commit2e92514fb34e1f80047f1661e4193fa9a3d3a06c (patch)
treef15f05d59c776fb13bf637e65c070c72f7b65720 /kde-base/ksysguard
parentFix libpng SLOT depend wrt #339796 by "MaratIK". (diff)
downloadgentoo-2-2e92514fb34e1f80047f1661e4193fa9a3d3a06c.tar.gz
gentoo-2-2e92514fb34e1f80047f1661e4193fa9a3d3a06c.tar.bz2
gentoo-2-2e92514fb34e1f80047f1661e4193fa9a3d3a06c.zip
Add KDE SC 4.5.2 =)
(Portage version: 2.2_rc88_p115/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ksysguard')
-rw-r--r--kde-base/ksysguard/ChangeLog7
-rw-r--r--kde-base/ksysguard/ksysguard-4.5.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/ksysguard/ChangeLog b/kde-base/ksysguard/ChangeLog
index 34a06857951a..477b35b6f651 100644
--- a/kde-base/ksysguard/ChangeLog
+++ b/kde-base/ksysguard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksysguard
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.187 2010/09/06 01:22:03 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.188 2010/10/06 09:17:06 alexxy Exp $
+
+*ksysguard-4.5.2 (05 Oct 2010)
+
+ 05 Oct 2010; Alexey Shvetsov <alexxy@gentoo.org> +ksysguard-4.5.2.ebuild:
+ Version bump KDE SC 4.5.2
*ksysguard-4.5.1 (06 Sep 2010)
diff --git a/kde-base/ksysguard/ksysguard-4.5.2.ebuild b/kde-base/ksysguard/ksysguard-4.5.2.ebuild
new file mode 100644
index 000000000000..e229751a5e1b
--- /dev/null
+++ b/kde-base/ksysguard/ksysguard-4.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ksysguard-4.5.2.ebuild,v 1.1 2010/10/06 09:17:06 alexxy Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KSysguard is a network enabled task manager and system monitor application."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug lm_sensors"
+
+COMMONDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}"
+
+KMEXTRA="
+ libs/ksysguard/
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with lm_sensors Sensors)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ ewarn "Note that ksysguard has powerful features; one of these is the executing of arbitrary"
+ ewarn "programs with elevated privileges (as data sources). So be careful opening worksheets"
+ ewarn "from untrusted sources!"
+}