summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
commit469c774bcd0309358560d5b77f5346fb8804f9bf (patch)
treece4119225d8c992262a6486b5bb41718a6a9529c /kde-base/kwin
parent[profiles] Update kde mask (diff)
downloadgentoo-2-469c774bcd0309358560d5b77f5346fb8804f9bf.tar.gz
gentoo-2-469c774bcd0309358560d5b77f5346fb8804f9bf.tar.bz2
gentoo-2-469c774bcd0309358560d5b77f5346fb8804f9bf.zip
[kde-base] Add KDE SC 4.7.1
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog7
-rw-r--r--kde-base/kwin/kwin-4.7.1.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index ec11c50b7769..82f9cc7156e8 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.240 2011/09/05 22:18:32 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.241 2011/09/07 20:13:56 alexxy Exp $
+
+*kwin-4.7.1 (07 Sep 2011)
+
+ 07 Sep 2011; Alexey Shvetsov <alexxy@gentoo.org> +kwin-4.7.1.ebuild:
+ Version bump KDE SC 4.7.1
*kwin-4.6.5-r1 (05 Sep 2011)
diff --git a/kde-base/kwin/kwin-4.7.1.ebuild b/kde-base/kwin/kwin-4.7.1.ebuild
new file mode 100644
index 000000000000..85e171eb5fea
--- /dev/null
+++ b/kde-base/kwin/kwin-4.7.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.7.1.ebuild,v 1.1 2011/09/07 20:13:56 alexxy Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug gles xinerama"
+
+COMMONDEPEND="
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep liboxygenstyle)
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ opengl? ( >=media-libs/mesa-7.10 )
+ gles? ( >=media-libs/mesa-7.10[egl(+),gles] )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/compositeproto
+ x11-proto/damageproto
+ x11-proto/fixesproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}
+ x11-apps/scripts
+"
+
+KMEXTRACTONLY="
+ ksmserver/
+ libs/kephal/
+ libs/oxygen/
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.4.2-xinerama_cmake_automagic.patch"
+)
+
+# you can use just gles or opengl or none
+REQUIRED_USE="opengl? ( !gles ) gles? ( !opengl )"
+
+src_configure() {
+ # FIXME Remove when activity API moved away from libkworkspace
+ append-cppflags "-I${EPREFIX}/usr/include/kworkspace"
+
+ mycmakeargs=(
+ $(cmake-utils_use_with gles OpenGLES)
+ $(cmake-utils_use gles KWIN_BUILD_WITH_OPENGLES)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xinerama X11_Xinerama)
+ -DWITH_X11_Xcomposite=ON
+ )
+
+ kde4-meta_src_configure
+}