summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:18:14 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:18:14 +0000
commit8646866a647f7b1eccda3bb0b652ce6df62c8aa8 (patch)
treee59a51b842c509c4ea0c0e559699583bc28e04a7 /kde-base/okular
parent[kde-base/kiten] Version bump to KDE SC 4.4.0 (diff)
downloadgentoo-2-8646866a647f7b1eccda3bb0b652ce6df62c8aa8.tar.gz
gentoo-2-8646866a647f7b1eccda3bb0b652ce6df62c8aa8.tar.bz2
gentoo-2-8646866a647f7b1eccda3bb0b652ce6df62c8aa8.zip
[kde-base/okular] Version bump to KDE SC 4.4.0
(Portage version: 2.2_rc62/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.4.0.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index f740133cd7c2..aad554aba5c6 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.60 2010/01/25 17:29:45 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.61 2010/02/09 00:18:14 alexxy Exp $
+
+*okular-4.4.0 (09 Feb 2010)
+
+ 09 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +okular-4.4.0.ebuild:
+ Version bump to KDE SC 4.4.0
*okular-4.3.5 (25 Jan 2010)
diff --git a/kde-base/okular/okular-4.4.0.ebuild b/kde-base/okular/okular-4.4.0.ebuild
new file mode 100644
index 000000000000..d46f874a8fea
--- /dev/null
+++ b/kde-base/okular/okular-4.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.4.0.ebuild,v 1.1 2010/02/09 00:18:14 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdegraphics"
+inherit kde4-meta
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="chm crypt debug djvu ebook +handbook +jpeg +ps +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ sys-libs/zlib
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( media-libs/jpeg )
+ pdf? (
+ >=virtual/poppler-0.12.3[lcms]
+ >=virtual/poppler-qt4-0.12.3
+ )
+ ps? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libs/mobipocket"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with chm)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ insinto "${KDEDIR}"/share/apps/cmake/modules
+ doins "${S}"/cmake/modules/FindOkular.cmake
+
+ kde4-meta_src_install
+}