summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2013-06-08 17:33:50 +0000
committerAgostino Sarubbo <ago@gentoo.org>2013-06-08 17:33:50 +0000
commitd7e9eb7fec425c8a3850523bb0395145911aa234 (patch)
tree4038f4d5c08927643514195ae7637d29f323c701 /kde-base/qtruby
parentAdd blocker on <dhcpcd-5.6.7; old versions do not support the -4 option. Many... (diff)
downloadgentoo-2-d7e9eb7fec425c8a3850523bb0395145911aa234.tar.gz
gentoo-2-d7e9eb7fec425c8a3850523bb0395145911aa234.tar.bz2
gentoo-2-d7e9eb7fec425c8a3850523bb0395145911aa234.zip
Remove old
(Portage version: 2.1.12.2/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 7194459F)
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog5
-rw-r--r--kde-base/qtruby/qtruby-4.10.2.ebuild74
2 files changed, 4 insertions, 75 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index e58b3d31c031..715dde770523 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/qtruby
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.159 2013/06/08 10:09:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.160 2013/06/08 17:33:47 ago Exp $
+
+ 08 Jun 2013; Agostino Sarubbo <ago@gentoo.org> -qtruby-4.10.2.ebuild:
+ Remove old
08 Jun 2013; Agostino Sarubbo <ago@gentoo.org> qtruby-4.10.3.ebuild:
Stable for ppc64, wrt to bug #471392
diff --git a/kde-base/qtruby/qtruby-4.10.2.ebuild b/kde-base/qtruby/qtruby-4.10.2.ebuild
deleted file mode 100644
index 2b37afb1f123..000000000000
--- a/kde-base/qtruby/qtruby-4.10.2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.10.2.ebuild,v 1.5 2013/05/05 10:14:31 ago Exp $
-
-EAPI=5
-
-OPENGL_REQUIRED="always"
-DECLARATIVE_REQUIRED="optional"
-KDE_REQUIRED="never"
-USE_RUBY="ruby18"
-# No ruby19 for three reasons:
-# 1) it does not build (yet) - will likely be solved soon
-# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
-# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
-# files with identical path+name will overwrite each other - difficult :(
-
-inherit kde4-base ruby-ng
-
-DESCRIPTION="Qt Ruby bindings"
-KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug phonon qscintilla qwt webkit"
-
-DEPEND="
- $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
-"
-
-RDEPEND="${DEPEND}
-"
-
-# Split from kdebindings-ruby in 4.7
-add_blocker kdebindings-ruby
-
-pkg_setup() {
- ruby-ng_pkg_setup
- kde4-base_pkg_setup
-}
-
-src_unpack() {
- local S="${WORKDIR}/${P}"
- kde4-base_src_unpack
-
- cd "${WORKDIR}"
- mkdir all
- mv ${P} all/ || die "Could not move sources"
-}
-
-all_ruby_prepare() {
- kde4-base_src_prepare
-}
-
-each_ruby_configure() {
- local CMAKE_USE_DIR=${S}
- mycmakeargs=(
- -DRUBY_LIBRARY=$(ruby_get_libruby)
- -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
- -DRUBY_EXECUTABLE=${RUBY}
- $(cmake-utils_use_disable declarative QtDeclarative)
- $(cmake-utils_use_with phonon)
- $(cmake-utils_use_with qscintilla QScintilla)
- $(cmake-utils_use_with qwt Qwt5)
- $(cmake-utils_use_disable webkit QtWebKit)
- )
- kde4-base_src_configure
-}
-
-each_ruby_compile() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_compile
-}
-
-each_ruby_install() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_install
-}