summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-29 18:35:19 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-29 18:35:19 +0000
commite022af9e09a506be3fa71a44a9dacb94554ae3b0 (patch)
tree927f368d76846ba1fc8372e4a16b73202107d984 /kde-base/qyoto
parentfixing testing (diff)
downloadgentoo-2-e022af9e09a506be3fa71a44a9dacb94554ae3b0.tar.gz
gentoo-2-e022af9e09a506be3fa71a44a9dacb94554ae3b0.tar.bz2
gentoo-2-e022af9e09a506be3fa71a44a9dacb94554ae3b0.zip
Version bump KDE SC 4.12.5
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.12.5.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index 56c1944ccaee..34120150e25e 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.113 2014/04/17 00:43:26 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.114 2014/04/29 18:34:43 johu Exp $
+
+*qyoto-4.12.5 (29 Apr 2014)
+
+ 29 Apr 2014; Johannes Huber <johu@gentoo.org> +qyoto-4.12.5.ebuild:
+ Version bump KDE SC 4.12.5
16 Apr 2014; Johannes Huber <johu@gentoo.org> qyoto-4.13.0.ebuild:
Restore KEYWORDS for KDE SC 4.13.0
diff --git a/kde-base/qyoto/qyoto-4.12.5.ebuild b/kde-base/qyoto/qyoto-4.12.5.ebuild
new file mode 100644
index 000000000000..ca32921f7447
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.12.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.12.5.ebuild,v 1.1 2014/04/29 18:34:43 johu Exp $
+
+EAPI=5
+
+KDE_REQUIRED="never"
+inherit mono-env kde4-base
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Qyoto"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ mono-env_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}