summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-11-03 16:31:05 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-11-03 16:31:05 +0000
commitaed7569556697316dc345ae4ca172377916e8ab2 (patch)
tree6e2289aa47f31b041e7299a47dc94defaa7729a3 /kde-base/systemsettings
parentKeyword ~ppc64 wrt #337385 (diff)
downloadgentoo-2-aed7569556697316dc345ae4ca172377916e8ab2.tar.gz
gentoo-2-aed7569556697316dc345ae4ca172377916e8ab2.tar.bz2
gentoo-2-aed7569556697316dc345ae4ca172377916e8ab2.zip
KDE SC 4.5.3 Version bump
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/systemsettings')
-rw-r--r--kde-base/systemsettings/ChangeLog8
-rw-r--r--kde-base/systemsettings/systemsettings-4.5.3.ebuild90
2 files changed, 97 insertions, 1 deletions
diff --git a/kde-base/systemsettings/ChangeLog b/kde-base/systemsettings/ChangeLog
index dd6d501c3904..eec51229b74c 100644
--- a/kde-base/systemsettings/ChangeLog
+++ b/kde-base/systemsettings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/systemsettings
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/ChangeLog,v 1.91 2010/10/06 09:17:33 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/ChangeLog,v 1.92 2010/11/03 16:30:28 scarabeus Exp $
+
+*systemsettings-4.5.3 (03 Nov 2010)
+
+ 03 Nov 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +systemsettings-4.5.3.ebuild:
+ Version bump
*systemsettings-4.5.2 (05 Oct 2010)
diff --git a/kde-base/systemsettings/systemsettings-4.5.3.ebuild b/kde-base/systemsettings/systemsettings-4.5.3.ebuild
new file mode 100644
index 000000000000..ea9b6bd803bd
--- /dev/null
+++ b/kde-base/systemsettings/systemsettings-4.5.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/systemsettings-4.5.3.ebuild,v 1.1 2010/11/03 16:30:28 scarabeus Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdebase-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="System settings utility"
+IUSE="debug +usb xinerama"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+COMMONDEPEND="
+ dev-libs/glib:2
+ $(add_kdebase_dep libkworkspace)
+ media-libs/fontconfig
+ >=media-libs/freetype-2
+ >=x11-libs/libxklavier-3.2
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXft
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ opengl? ( virtual/opengl )
+ usb? ( =virtual/libusb-0* )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/kbproto
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}
+ x11-apps/setxkbmap
+ x11-misc/xkeyboard-config
+"
+
+KMEXTRA="
+ kcontrol/
+"
+KMEXTRACTONLY="
+ krunner/dbus/org.kde.krunner.App.xml
+ krunner/dbus/org.kde.screensaver.xml
+ kwin/
+ libs/
+ plasma/
+"
+
+add_blocker kcontrol '<4.3.98'
+add_blocker konqueror '<4.4.70'
+
+PATCHES=( "${FILESDIR}/${PN}-4.4.2-xinerama_cmake_automagic.patch" )
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+="
+ doc/kcontrol
+ doc/kfontview
+ "
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_prepare() {
+ sed -i -e 's/systemsettingsrc DESTINATION ${SYSCONF_INSTALL_DIR}/systemsettingsrc DESTINATION ${CONFIG_INSTALL_DIR}/' \
+ systemsettings/CMakeLists.txt \
+ || die "Failed to fix systemsettingsrc install location"
+
+ kde4-meta_src_prepare
+}
+
+# FIXME: is have_openglxvisual found without screensaver
+src_configure() {
+ # Old keyboard-detection code is unmaintained,
+ # so we force the new stuff, using libxklavier.
+ mycmakeargs=(
+ -DUSE_XKLAVIER=ON -DWITH_LibXKlavier=ON
+ -DWITH_GLIB2=ON -DWITH_GObject=ON
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with usb)
+ $(cmake-utils_use_with xinerama X11_Xinerama)
+ )
+
+ kde4-meta_src_configure
+}