summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-06-06 00:52:49 +0000
committerChris Reffett <creffett@gentoo.org>2013-06-06 00:52:49 +0000
commit2bb51be3466c899c9dc374f5e4f52a960d7ac83a (patch)
tree98c8ae7620df83f43fd3d78da147b33ca679ef65 /kde-base
parentFix encoding. (diff)
downloadgentoo-2-2bb51be3466c899c9dc374f5e4f52a960d7ac83a.tar.gz
gentoo-2-2bb51be3466c899c9dc374f5e4f52a960d7ac83a.tar.bz2
gentoo-2-2bb51be3466c899c9dc374f5e4f52a960d7ac83a.zip
Revision bump, apply patch to fix battery monitor widget wrt bug 472382, credit to Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/plasma-workspace/ChangeLog10
-rw-r--r--kde-base/plasma-workspace/files/plasma-workspace-4.10.4-keep-batterymonitor-in-sync-with-systray.patch30
-rw-r--r--kde-base/plasma-workspace/plasma-workspace-4.10.4-r1.ebuild (renamed from kde-base/plasma-workspace/plasma-workspace-4.10.4.ebuild)7
3 files changed, 44 insertions, 3 deletions
diff --git a/kde-base/plasma-workspace/ChangeLog b/kde-base/plasma-workspace/ChangeLog
index 2749e614ee98..d2ea43d24d85 100644
--- a/kde-base/plasma-workspace/ChangeLog
+++ b/kde-base/plasma-workspace/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/plasma-workspace
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.219 2013/06/05 10:32:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.220 2013/06/06 00:52:49 creffett Exp $
+
+*plasma-workspace-4.10.4-r1 (06 Jun 2013)
+
+ 06 Jun 2013; Chris Reffett <creffett@gentoo.org>
+ +files/plasma-workspace-4.10.4-keep-batterymonitor-in-sync-with-systray.patch,
+ +plasma-workspace-4.10.4-r1.ebuild, -plasma-workspace-4.10.4.ebuild:
+ Revision bump, apply patch to fix battery monitor widget wrt bug 472382,
+ credit to Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
05 Jun 2013; Agostino Sarubbo <ago@gentoo.org> plasma-workspace-4.10.3.ebuild:
Stable for x86, wrt to bug #471392
diff --git a/kde-base/plasma-workspace/files/plasma-workspace-4.10.4-keep-batterymonitor-in-sync-with-systray.patch b/kde-base/plasma-workspace/files/plasma-workspace-4.10.4-keep-batterymonitor-in-sync-with-systray.patch
new file mode 100644
index 000000000000..500fe1781bb6
--- /dev/null
+++ b/kde-base/plasma-workspace/files/plasma-workspace-4.10.4-keep-batterymonitor-in-sync-with-systray.patch
@@ -0,0 +1,30 @@
+commit 72b9956766b26164628ccc979952fd1ae5bc5e41
+Author: Kai Uwe Broulik <kde@privat.broulik.de>
+Date: Tue Jun 4 17:47:17 2013 +0200
+
+ Also set minimum size when it *is* constrained
+
+ BUG: 309447
+ FIXED-IN: 4.11.0
+
+* 2013-06-04: Backport to 4.10.4
+
+diff --git a/plasma/generic/applets/batterymonitor/contents/ui/CompactRepresentation.qml b/plasma/generic/applets/batterymonitor/contents/ui/CompactRepresentation.qml
+index f8691a1..e9dc772 100644
+--- a/plasma/generic/applets/batterymonitor/contents/ui/batterymonitor.qml 2013-05-28 20:38:22.000000000 +0200
++++ b/plasma/generic/applets/batterymonitor/contents/ui/batterymonitor.qml 2013-06-04 21:15:26.234102844 +0200
+@@ -70,8 +70,12 @@
+
+ Component.onCompleted: {
+ if (!isConstrained()) {
+- minimumWidth = 32;
+- minimumHeight = 32;
++ minimumWidth = theme.iconSizes.dialog;
++ minimumHeight = minimumHeight * view.count;
++ } else {
++ // NOTE: Keep in sync with systray
++ minimumHeight = 24;
++ minimumWidth = 24;
+ }
+ plasmoid.addEventListener('ConfigChanged', configChanged);
+ }
diff --git a/kde-base/plasma-workspace/plasma-workspace-4.10.4.ebuild b/kde-base/plasma-workspace/plasma-workspace-4.10.4-r1.ebuild
index 73e4ac61292c..51323139bd69 100644
--- a/kde-base/plasma-workspace/plasma-workspace-4.10.4.ebuild
+++ b/kde-base/plasma-workspace/plasma-workspace-4.10.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/plasma-workspace-4.10.4.ebuild,v 1.1 2013/06/04 18:22:13 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/plasma-workspace-4.10.4-r1.ebuild,v 1.1 2013/06/06 00:52:49 creffett Exp $
EAPI=5
@@ -85,7 +85,10 @@ KMEXTRACTONLY="
KMLOADLIBS="libkworkspace libplasmaclock libplasmagenericshell libtaskmanager"
-PATCHES=( "${FILESDIR}/${PN}-4.10.1-noplasmalock.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-4.10.1-noplasmalock.patch"
+ "${FILESDIR}/${PN}-4.10.4-keep-batterymonitor-in-sync-with-systray.patch"
+ )
pkg_setup() {
if use python ; then