summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-16 00:05:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-16 00:05:50 +0000
commitb060333a85aaf8ca2f8f6f44a7952b33fa1b9946 (patch)
tree6d90498e692171de82e95decbedb1f4ecec6a999 /kde-base
parentwhitespace (diff)
downloadgentoo-2-b060333a85aaf8ca2f8f6f44a7952b33fa1b9946.tar.gz
gentoo-2-b060333a85aaf8ca2f8f6f44a7952b33fa1b9946.tar.bz2
gentoo-2-b060333a85aaf8ca2f8f6f44a7952b33fa1b9946.zip
add some more ifdefery to the patch, by Fabian Kislat, bug #407607
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/ffmpegthumbs/ChangeLog6
-rw-r--r--kde-base/ffmpegthumbs/files/ffmpegthumbs-4.8.1-ffmpeg.patch7
2 files changed, 10 insertions, 3 deletions
diff --git a/kde-base/ffmpegthumbs/ChangeLog b/kde-base/ffmpegthumbs/ChangeLog
index d712f3807c70..d8d6a714d581 100644
--- a/kde-base/ffmpegthumbs/ChangeLog
+++ b/kde-base/ffmpegthumbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/ffmpegthumbs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ffmpegthumbs/ChangeLog,v 1.46 2012/03/09 09:55:08 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ffmpegthumbs/ChangeLog,v 1.47 2012/03/16 00:05:50 aballier Exp $
+
+ 16 Mar 2012; Alexis Ballier <aballier@gentoo.org>
+ files/ffmpegthumbs-4.8.1-ffmpeg.patch:
+ add some more ifdefery to the patch, by Fabian Kislat, bug #407607
09 Mar 2012; Alexis Ballier <aballier@gentoo.org> ffmpegthumbs-4.8.1.ebuild,
+files/ffmpegthumbs-4.8.1-ffmpeg.patch:
diff --git a/kde-base/ffmpegthumbs/files/ffmpegthumbs-4.8.1-ffmpeg.patch b/kde-base/ffmpegthumbs/files/ffmpegthumbs-4.8.1-ffmpeg.patch
index afbb8a66f5af..bee819ddda4e 100644
--- a/kde-base/ffmpegthumbs/files/ffmpegthumbs-4.8.1-ffmpeg.patch
+++ b/kde-base/ffmpegthumbs/files/ffmpegthumbs-4.8.1-ffmpeg.patch
@@ -18,12 +18,15 @@ Index: ffmpegthumbs-4.8.1/ffmpegthumbs/ffmpegthumbnailer/moviedecoder.cpp
kDebug() << "Could not open input file: " << fileInfo.absoluteFilePath();
return;
}
-@@ -89,7 +91,7 @@ void MovieDecoder::destroy()
+@@ -89,7 +91,11 @@ void MovieDecoder::destroy()
}
if ((!m_FormatContextWasGiven) && m_pFormatContext) {
-- av_close_input_file(m_pFormatContext);
++#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(54,0,0)
+ av_close_input_file(m_pFormatContext);
++#else
+ avformat_close_input(&m_pFormatContext);
++#endif
m_pFormatContext = NULL;
}