summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2003-01-05 01:51:02 +0000
committerHannes Mehnert <hannes@gentoo.org>2003-01-05 01:51:02 +0000
commitcc29c9c5b34ffadbba44eb17c51ac49f7531cb46 (patch)
tree7acbd95821b939c61b183a3f239c05122519acf7 /kde-base
parentunmask x86, xft2 enabled version (diff)
downloadgentoo-2-cc29c9c5b34ffadbba44eb17c51ac49f7531cb46.tar.gz
gentoo-2-cc29c9c5b34ffadbba44eb17c51ac49f7531cb46.tar.bz2
gentoo-2-cc29c9c5b34ffadbba44eb17c51ac49f7531cb46.zip
konqueror no longer crashes if compiled with debug and the "Home" button is pressed
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdelibs/ChangeLog7
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.0.5a-dontcrash.diff14
-rw-r--r--kde-base/kdelibs/kdelibs-3.0.5a.ebuild6
3 files changed, 24 insertions, 3 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index ab166f6b82c3..4990fb39fba0 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.37 2002/12/21 14:02:39 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.38 2003/01/05 01:51:02 hannes Exp $
+
+ 04 Jan 2003; Hannes Mehnert <hannes@gentoo.org> kdelibs-3.0.5a.ebuild:
+ included patch to have no crash if compiled with debug and clicking on
+ "Home" button in konqueror. no need to version bump cause most users
+ don't compile with debug and most users don't use the "Home" button.
*kdelibs-3.0.5a (21 Dec 2002)
diff --git a/kde-base/kdelibs/files/kdelibs-3.0.5a-dontcrash.diff b/kde-base/kdelibs/files/kdelibs-3.0.5a-dontcrash.diff
new file mode 100644
index 000000000000..5fb8463d545e
--- /dev/null
+++ b/kde-base/kdelibs/files/kdelibs-3.0.5a-dontcrash.diff
@@ -0,0 +1,14 @@
+RCS file: /home/kde/kdelibs/khtml/rendering/render_replaced.cpp,v
+retrieving revision 1.92.2.5
+retrieving revision 1.92.2.6
+diff -b -p -u -r1.92.2.5 -r1.92.2.6
+--- khtml/rendering/render_replaced.cpp 1 Oct 2002 19:22:51 -0000 1.92.2.5
++++ khtml/rendering/render_replaced.cpp 4 Jan 2003 23:42:31 -0000 1.92.2.6
+@@ -153,7 +153,6 @@ void RenderWidget::detach()
+ RenderWidget::~RenderWidget()
+ {
+ KHTMLAssert( refCount() <= 0 );
+- assert(!m_view);
+
+ if(m_widget) {
+ m_widget->hide();
diff --git a/kde-base/kdelibs/kdelibs-3.0.5a.ebuild b/kde-base/kdelibs/kdelibs-3.0.5a.ebuild
index f04c1e3949ab..6361195150b9 100644
--- a/kde-base/kdelibs/kdelibs-3.0.5a.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.0.5a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.0.5a.ebuild,v 1.1 2002/12/21 13:48:19 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.0.5a.ebuild,v 1.2 2003/01/05 01:51:02 hannes Exp $
inherit kde kde.org
#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
@@ -57,8 +57,10 @@ set-kdedir $PV
src_unpack() {
unpack ${P}.tar.bz2
cd ${S}
+ # fixes crash if kdelibs is compiled with debug and you
+ # click on "Home" button in konqueror
+ patch -p0 < ${FILESDIR}/${P}-dontcrash.diff
kde_sandbox_patch ${S}/kio/misc/kpac
-
}