summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-06-22 15:02:40 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-06-22 15:02:40 +0000
commitf7cd64c0751abdee3d66719458728f8233a5ad30 (patch)
tree183116005364210b289ebc5f4e02c82a772bd91a /kde-base
parentx86 stable wrt bug #474172 (diff)
downloadgentoo-2-f7cd64c0751abdee3d66719458728f8233a5ad30.tar.gz
gentoo-2-f7cd64c0751abdee3d66719458728f8233a5ad30.tar.bz2
gentoo-2-f7cd64c0751abdee3d66719458728f8233a5ad30.zip
Backport crash patch from upstream.
(Portage version: 2.1.12.5/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/katepart/ChangeLog8
-rw-r--r--kde-base/katepart/files/katepart-4.10.4-crash.patch51
-rw-r--r--kde-base/katepart/katepart-4.10.4-r1.ebuild29
3 files changed, 87 insertions, 1 deletions
diff --git a/kde-base/katepart/ChangeLog b/kde-base/katepart/ChangeLog
index e039f28eb842..716d370de2d5 100644
--- a/kde-base/katepart/ChangeLog
+++ b/kde-base/katepart/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/katepart
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/katepart/ChangeLog,v 1.82 2013/06/08 17:33:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/katepart/ChangeLog,v 1.83 2013/06/22 15:02:40 kensington Exp $
+
+*katepart-4.10.4-r1 (22 Jun 2013)
+
+ 22 Jun 2013; Michael Palimaka <kensington@gentoo.org>
+ +files/katepart-4.10.4-crash.patch, +katepart-4.10.4-r1.ebuild:
+ Backport crash patch from upstream.
08 Jun 2013; Agostino Sarubbo <ago@gentoo.org> -katepart-4.10.2.ebuild:
Remove old
diff --git a/kde-base/katepart/files/katepart-4.10.4-crash.patch b/kde-base/katepart/files/katepart-4.10.4-crash.patch
new file mode 100644
index 000000000000..b8c618be0c2c
--- /dev/null
+++ b/kde-base/katepart/files/katepart-4.10.4-crash.patch
@@ -0,0 +1,51 @@
+From d2e34218068432ba9c312591067e53eda67cb68a Mon Sep 17 00:00:00 2001
+From: Dominik Haumann <dhaumann@kde.org>
+Date: Wed, 12 Jun 2013 22:30:32 +0200
+Subject: [PATCH] fix crash in passive notification system
+
+@packagers / distributions: Better backport this to you 4.10.4 packages.
+
+FIXED-IN: 4.10.5
+BUG: 320302
+---
+ part/view/katemessagewidget.cpp | 21 +++++++++++++++++++--
+ 1 file changed, 19 insertions(+), 2 deletions(-)
+
+diff --git a/part/view/katemessagewidget.cpp b/part/view/katemessagewidget.cpp
+index d3c895f..6c227c0 100644
+--- a/part/view/katemessagewidget.cpp
++++ b/part/view/katemessagewidget.cpp
+@@ -225,11 +225,28 @@ void KateMessageWidget::startAutoHideTimer()
+ return;
+ }
+
++ // switching KateViews may result isVisible() == true and still m_messageList.size() == 0.
++ // The problem is that the hideEvent is never called for the KMessageWidget, if the
++ // parent widget is hidden. In that case, we 'miss' that the notification is gone...
++ if (m_messageList.size() == 0) {
++ m_hideAnimationRunning = false;
++ m_autoHideTimerRunning = false;
++ m_autoHideTime = -1;
++
++ if (isVisible()) {
++ m_hideAnimationRunning = true;
++ if (m_fadeEffect) {
++ m_fadeEffect->fadeOut();
++ } else {
++ m_messageWidget->animatedHide();
++ }
++ }
++ return;
++ }
++
+ // remember that auto hide timer is running
+ m_autoHideTimerRunning = true;
+
+- // the message must still still be valid
+- Q_ASSERT(m_messageList.size());
+ KTextEditor::Message* message = m_messageList[0];
+ QTimer::singleShot(m_autoHideTime == 0 ? (6*1000) : m_autoHideTime, message, SLOT(deleteLater()));
+ }
+--
+1.8.2.1
+
diff --git a/kde-base/katepart/katepart-4.10.4-r1.ebuild b/kde-base/katepart/katepart-4.10.4-r1.ebuild
new file mode 100644
index 000000000000..f6d6c36f86d4
--- /dev/null
+++ b/kde-base/katepart/katepart-4.10.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/katepart/katepart-4.10.4-r1.ebuild,v 1.1 2013/06/22 15:02:40 kensington Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kate"
+KMMODULE="part"
+inherit kde4-meta
+
+DESCRIPTION="KDE Editor KPart"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RESTRICT="test"
+# bug 392993
+
+add_blocker kdelibs 4.6.50
+
+PATCHES=( "${FILESDIR}/${P}-crash.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ "-DKDE4_BUILD_TESTS=OFF"
+ )
+
+ kde4-meta_src_configure
+}