summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-01-23 13:43:11 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-01-23 13:43:11 +0000
commitba3d70b05e7175cb4062421e0ef2875907455f18 (patch)
treeed0bce6a8a1ef2b0fffb4aa9217c35731cf37e12 /kde-misc/kanyremote
parentMarked ~amd64-linux, fix for Prefix, bug #300037 (diff)
downloadgentoo-2-ba3d70b05e7175cb4062421e0ef2875907455f18.tar.gz
gentoo-2-ba3d70b05e7175cb4062421e0ef2875907455f18.tar.bz2
gentoo-2-ba3d70b05e7175cb4062421e0ef2875907455f18.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc/kanyremote')
-rw-r--r--kde-misc/kanyremote/ChangeLog9
-rw-r--r--kde-misc/kanyremote/kanyremote-5.11.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/kde-misc/kanyremote/ChangeLog b/kde-misc/kanyremote/ChangeLog
index 84b6dd3ba933..14437a3d09fc 100644
--- a/kde-misc/kanyremote/ChangeLog
+++ b/kde-misc/kanyremote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/kanyremote
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.5 2009/08/11 13:23:32 hwoarang Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.6 2010/01/23 13:43:11 hwoarang Exp $
+
+*kanyremote-5.11 (23 Jan 2010)
+
+ 23 Jan 2010; <hwoarang@gentoo.org> +kanyremote-5.11.ebuild:
+ Version bump
11 Aug 2009; Markos Chandras <hwoarang@gentoo.org>
-kanyremote-5.8.2.ebuild:
diff --git a/kde-misc/kanyremote/kanyremote-5.11.ebuild b/kde-misc/kanyremote/kanyremote-5.11.ebuild
new file mode 100644
index 000000000000..d86ed30abbc4
--- /dev/null
+++ b/kde-misc/kanyremote/kanyremote-5.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-5.11.ebuild,v 1.1 2010/01/23 13:43:11 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+DEPEND=">=net-misc/anyremote-4.4[bluetooth?]
+ dev-python/PyQt4[X]
+ kde-base/pykde4
+ bluetooth? ( dev-python/pybluez )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # workaround to bluetooth check when bluetooth use flag is disabled
+ ! use bluetooth && epatch "${FILESDIR}/disable_bluetooth.patch"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}