summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-08-09 13:20:56 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-08-09 13:20:56 +0000
commita645020e03ddb9abfbc099c8fc7ac7c9f13c0318 (patch)
tree2a1fefb28802870930b8027aa34da3873bd68840 /kde-misc/kompose/kompose-0.5.4.ebuild
parentVersion bump. (diff)
downloadgentoo-2-a645020e03ddb9abfbc099c8fc7ac7c9f13c0318.tar.gz
gentoo-2-a645020e03ddb9abfbc099c8fc7ac7c9f13c0318.tar.bz2
gentoo-2-a645020e03ddb9abfbc099c8fc7ac7c9f13c0318.zip
Version bump. Thanks to Tobias Roeser for the patch, bug #125209.
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'kde-misc/kompose/kompose-0.5.4.ebuild')
-rw-r--r--kde-misc/kompose/kompose-0.5.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-misc/kompose/kompose-0.5.4.ebuild b/kde-misc/kompose/kompose-0.5.4.ebuild
new file mode 100644
index 000000000000..a0d9985491a5
--- /dev/null
+++ b/kde-misc/kompose/kompose-0.5.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kompose/kompose-0.5.4.ebuild,v 1.1 2006/08/09 13:20:56 carlo Exp $
+
+inherit kde
+
+DESCRIPTION="A KDE fullscreen task manager."
+HOMEPAGE="http://kompose.berlios.de"
+SRC_URI="http://download.berlios.de/kompose/${P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="media-libs/imlib2"
+RDEPEND="media-libs/imlib2"
+need-kde 3.5
+
+PATCHES="${FILESDIR}/${P}-ktoolbar-patch"
+
+function pkg_setup() {
+ # bug 94881
+ if ! built_with_use media-libs/imlib2 X; then
+ eerror "This package requires imlib2 to be built with X11 support."
+ eerror "Please run USE=X emerge media-libs/imlib2, then try emerging kompose again."
+ die "imlib2 must be built with USE=X"
+ fi
+}
+
+src_compile() {
+ rm configure
+ kde_src_compile
+}
+